Official Coffee Lake Refresh Thread/BIOS for ALL Clevo Laptops - RTX CARDS NOW SUPPORTED

Discussion in 'Sager and Clevo' started by DaMafiaGamer, Oct 25, 2018.

  1. IllusiveMan

    IllusiveMan Notebook Consultant

    Reputations:
    42
    Messages:
    296
    Likes Received:
    85
    Trophy Points:
    41
    P751DM1 is mainly dead without a proper BIOS with latest CPU and GPU support. The issues with audio drivers and now with the keyboard backlit is getting annoying, also shutting down also is not working properly.
     
    mirt81 likes this.
  2. mirt81

    mirt81 Notebook Guru

    Reputations:
    11
    Messages:
    52
    Likes Received:
    10
    Trophy Points:
    16
    Right P751DM1 is annoying . . .im Run with Skylake and Maxwell2 but triggerd by sometimes Integrate newest CpuMicroCode and IntelMeFirmware into latest StockBios makes Somtimes Chilling over Annoy . . . and maybe RLECViewer does a part for that ! ! ?
     
    IllusiveMan likes this.
  3. IllusiveMan

    IllusiveMan Notebook Consultant

    Reputations:
    42
    Messages:
    296
    Likes Received:
    85
    Trophy Points:
    41
    Does it work like this?

    I use @dsanke BIOS with Kaby and Pascal. When I tried to install some drivers for keyboard backlit it broke the lightbar which no longer appears in the hotkey app.

    This RLECviewer? : https://github.com/zuyan9/RLECViewer
     
  4. mirt81

    mirt81 Notebook Guru

    Reputations:
    11
    Messages:
    52
    Likes Received:
    10
    Trophy Points:
    16
    Im using this RLECViewer v2.4 http://forum.notebookreview.com/threads/rlecviewer-custom-clevo-fan-control.818858/ please read from first @ last entryfor Secure Useage !
    Downloadlink Installer: https://github.com/duguzuyang/RLECViewer/raw/master/Install/Product/RLECViewer.exe !
    Running now for a week with Monitoring Fanspeeds per MSI AfterBurner and there are maybe Scary behavior on first look but for me it´s not Critical

    P751DM1 and other CPU as Skylake is a mess Only with begin of P7xxDM Models with Native Kabylake support is the option to use NextGeneration CPU without much trouble . . . Ds@nke self went to P751DM2.
    Your trouble with audio drivers and keyboard backlit also shutting down is Normal on P751DM1 with Kabylake and what i read from Modders to complicate to be Fixed.

    Also with Skylake CPU and Ds@nke Mod Bios there trouble with audio drivers and keyboard backlit also shutting down .
     
    Last edited: Jul 28, 2020
  5. moral hazard

    moral hazard Notebook Nobel Laureate

    Reputations:
    2,768
    Messages:
    7,950
    Likes Received:
    78
    Trophy Points:
    216
    Audio drivers and backlight definitely an issue with my p870dm + i5-8600.

    The other issue is when on battery power, I get random BSOD (no matter even if I increase voltages in bios and run stock clocks for everything).
    Not a big deal because this thing is always on a desk connected to power.

    Lastly, when gaming with the 980m, the machine turns off and power adapter light goes off. Like it's hitting overcurrent Protection.

    I've messed with all the cpu current limit settings in the bios with the same result.

    The 980m doesn't have this behaviour when running in my p375sm.

    Unsure whether those issues will be solved when I eventually upgrade the cpu, ram and GPU.

    This is Sager branded, no idea which reseller was the original seller and whether Prema bios would be an option.

    For now, this machine is just being used for my studies and not any gaming.
     
  6. matyee

    matyee Notebook Deity

    Reputations:
    229
    Messages:
    788
    Likes Received:
    389
    Trophy Points:
    76
    Hi all,
    Finally I have managed to upgrade my 751dm2 with 1.07.24 RTX dsanke bios! I have bough an intel QQBZ cpu, which is almost an i9 9900 with lower clocks (4,4-4,2). The issue what I have, that under stress the cpu is stuck at 2,6Ghz. The only bench I have managed to keep the original clock (4,2@all core) is the cpu-z bench. With that the cpu used 100W+, so it seemed fine. With CB15 the scores were also poor, all clock 2,6ghz. P95 same :( What could be the issue? Thx!
     
    Last edited: Jul 29, 2020
  7. IllusiveMan

    IllusiveMan Notebook Consultant

    Reputations:
    42
    Messages:
    296
    Likes Received:
    85
    Trophy Points:
    41
    I am not sure where from the backlit config comes from, it is controlled by second EC but it's also connected to main EC and to PCH as well. It worked fine for me until drivers broke it, and I am not sure how to fix it now.
    Apart of that, because it's a different audio codec ALC892 in 750dm vs ALC898 in 750DM2 maybe this is one reason with drivers. Replacing the 892 codec with 898 is not very straight, and not sure it will work, there a re a few different pinouts.

    Maybe the charger is dying.

    Could be again main EC firmware issue like in 750DM.

    Without prema mod... it's unusable.
     
  8. leo758

    leo758 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi everybody (i'm a newbe and my english is bad, sorry for that).
    I think i bricked my laptop (P870KM1G), i don't know how. all works fine until yesterday during a clean installation of win10, after intelMe drivers installation (well done), no problems, but after that i had to pick the phone(for 30min). When i was back it was in sleeping mode (normal), but it wasn't start until that. when I start it (start button) the laptop turn on (without any screen during 2s) turned off immediately.
    If someone knows what is the problem exactly.
    My cfg at last before death: P870KM1-G Dsanke Bios, I9 9900KF CPU, GTX 1080 GPU x2 in SLI with G-Sync activated (UHD panel), audio working fine with SoundBlaster connect 360 app no issues, the only thing i didn't have was the thunderbolt cause i've flashed the thunderbolt controller (winbond 25Q80DV...) with bios firmware because i though that was it, with no backup, my missed up.

    Thanks for all
     
  9. moral hazard

    moral hazard Notebook Nobel Laureate

    Reputations:
    2,768
    Messages:
    7,950
    Likes Received:
    78
    Trophy Points:
    216
    Could just be unlucky and have a component failure.

    Try starting the machine with just 1 GPU installed and 1 stick of ram.
     
  10. mirt81

    mirt81 Notebook Guru

    Reputations:
    11
    Messages:
    52
    Likes Received:
    10
    Trophy Points:
    16
    Was on same Isue and try remember me right . . . had Ds@nke bi0s but Played with the Intel-Me-Firmware by my self updatet the bi0s had
    triggered the Isue . . . by plug out or in the Accu after that the DeskTop go on again . . . then was a other Isue while PSU was pluged in and did a restart of Windows the PSU shuts down and only after disconect PSU from howl Energy it was usable to Power on the DeskTop . . . this behavior was still Present with Stock bi0s so i have a Half Functional PSU . . . to Run the DeskTop it was something to do with Accu and disconecting the PSU .

    So the PSU works for PowerOn the DeskTop but do a restart lets ShutOff the PSU also with Accu Pluged in . . . maybe dont Install IntelMeFirmware directly and try to use only the drivers that windows do Install if you can awake your P870KM1G again . . . Lucky Luck for th@t !


    Could just be unlucky and have a component failure.

    Try starting the machine with just 1 GPU installed and 1 stick of ram.
     
Loading...

Share This Page