Official Coffee Lake Refresh Thread/BIOS for ALL Clevo Laptops - RTX CARDS NOW SUPPORTED

Discussion in 'Sager and Clevo' started by DaMafiaGamer, Oct 25, 2018.

  1. Monyku

    Monyku Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hello everyone, i've been lurking for while forum and decided to try this mode on mine P870KM1-G with GTX 1080 and i5 8600k

    Writing this to warn you - i didn't get to BIOS installation part.

    I almost fried my notebook because of vBIOS proposed for this mode. After vbios update it is UEFI x3000A (mine stock is x30002.

    So flashing vbios went well. After it i wanted to check is it stable - so i ran regular Firestrike test on max fan profile. I noticed after few seconds that there are FPS drops. Than Screen went black and after 2-3 seconds whole notebook was off. Couldn't get it ON after that - my first though - fried GPU because of faulty vBIOS. Than i realized that my power adapter is off to. Tried with extra adapter from MSI laptop but no luck

    Decided to dissemble laptop and try NVRAM reset. Couldn't believe but it helped. Laptop turned on and screen was working (so GPU should). After it i flashed back my old vBIOS and ran firestrike again. Everything went fine with max temperature 65C.

    Flashing this faulty vbios cost me power adapter and battery (it is not charging now - stays all time at 0%).

    Idk is it possible to flash this bios/ec without custom vbios.

    @dsanke - i think you should take closer look at this vBIOS. I am not only one who had problems with it - but i guess only one that almost fried notebook.
     
    Last edited: Nov 29, 2018
  2. ScruffyITA

    ScruffyITA Notebook Enthusiast

    Reputations:
    7
    Messages:
    42
    Likes Received:
    3
    Trophy Points:
    16
    wowwwwwwwww im back after new cpu installation. all works really fine. just applied for now a -100mv undervolt. while gaming cpu temperature was around 60° celsius... and now on my game i never never went down 60 fps.... good stable 60 frame in all scenarios. im really really happy with that.

    just now have 2 things to fix and im all ok
    1: how can u remove the freewere bios warning when powering pc ?
    2: how to flash the ec file? can i use the efi usb pendrive ive created to flash bios to flash now the ec firmware ?

    audio is working again after driver reinstall. some jack now has changed while before i had front speaker now its optical, but all is ok and sound seems working better.

    im really impressed by now for the speed of my pc that infact is a notebook with extreme performance... :D

    tnx everybody for the help and tnx for the developer for making that great bios mod :)


    ps: monyku what vga u have ? i have 1070 and with uefi version ok already from store.
     
    jclausius likes this.
  3. Monyku

    Monyku Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    @ScruffyITA i am also grateful to dsanke for all work - i think it's amazing. About GPU - it's 1080. Someone mentioned in this topic also that graphic perform lower by 20% - maybe you have same issue.
     
  4. ScruffyITA

    ScruffyITA Notebook Enthusiast

    Reputations:
    7
    Messages:
    42
    Likes Received:
    3
    Trophy Points:
    16
    i did a vantage test and score is 10k higher , also gpu values are highrer now.

    before i5 9600k i had a i5 6600.
     
  5. Pagis

    Pagis Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    Awesome! Did you manage to do everything just with usb or did you use programmer?
     
  6. ScruffyITA

    ScruffyITA Notebook Enthusiast

    Reputations:
    7
    Messages:
    42
    Likes Received:
    3
    Trophy Points:
    16
    all by usb. was really easy to do it. i also saved my original bios :)
     
  7. anton strila

    anton strila Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    quick question did any1 try 8350k on a 65w would it just run at stock speeds 4.0ghz? or it requires additional bios modding?
     
  8. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,655
    Messages:
    54,010
    Likes Received:
    15,649
    Trophy Points:
    931
    It would run the default 4ghz speed.
     
  9. dsanke

    dsanke Notebook Geek

    Reputations:
    79
    Messages:
    89
    Likes Received:
    175
    Trophy Points:
    41
    @Monyku I don't know what cause your problem because the vBIOS are from Clevo , I did and can not edit them because if I edit them it won't pass the security check of nvflash tool . I just removed the old GOP and paste new one on it .
    GOP is a program to make your screen work with pure UEFI boot .
    The GOP is from NVIDIA too .
    If you do not update GOP , according to my test , the BIOS from TM series won't let you boot .
    @ScruffyITA And the "freeware" tips is inside Logo picture , you can replace it with whatever method you like .
    I usually use UEFITool to do this.
     
    Last edited: Dec 3, 2018
    Rahego likes this.
  10. ScruffyITA

    ScruffyITA Notebook Enthusiast

    Reputations:
    7
    Messages:
    42
    Likes Received:
    3
    Trophy Points:
    16
    tnx very much again for the good bios. was not me having problem with the gop and nvidia driver :D i did no error or any problem doing the upgrade. tnx for the tips on removing the logo, ill do it later :)
     
Loading...

Share This Page