*** Official Clevo P65xSA/SE/SG / Sager NP8650/51/52 Owner´s Lounge ***

Discussion in 'Sager/Clevo Reviews & Owners' Lounges' started by jaybee83, Oct 13, 2014.

  1. ValkerieFire

    ValkerieFire God Follower

    Reputations:
    1,551
    Messages:
    1,418
    Likes Received:
    23
    Trophy Points:
    56
    You can't keep up with technology. I bought a Tesla model S 2 months ago. They update almost as fast as computers, but they cost a whole lot more. Still I'm glad I got one.

    I am also feeling the 1060 laptop temptation.
     
  2. sett3

    sett3 Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    is there a possibility to buy an eDP cable for 3K panasonic panel? it's part number should be 6-43-P6501-021-1C.
     
  3. opper

    opper Notebook Enthusiast

    Reputations:
    0
    Messages:
    43
    Likes Received:
    22
    Trophy Points:
    16
    This week I installed the Windows 10 anniversary update, after which m P505 (P651SE) becamse very noisy. Fans are spinning up a lot more, even when doing nothing. Anybody else experiencing this? The Clevo Control Center crashes on Startup, so I cannot select the "Quiet" profile.
     
  4. anmatheextreme

    anmatheextreme Notebook Consultant

    Reputations:
    4
    Messages:
    267
    Likes Received:
    23
    Trophy Points:
    31
    Best you can do is reinstall Clevo Control Center and enable that Quiet profile. You will find the latest version here: http://www.clevo.com.tw/EN/E-SERVICES/download/ftpout_download.asp?sno=7875&no=1

    Also bear in mind that lately there are a lot of updates pushed by Microsoft that download and install automatically in the background. My CPU has been hitting temps in the 70s at times due to that and unfortunately you can't do anything to stop them.
     
    Last edited: Aug 19, 2016
  5. comicgeek

    comicgeek Notebook Geek

    Reputations:
    5
    Messages:
    98
    Likes Received:
    19
    Trophy Points:
    16
    Try to reinstall the Clevo drivers and see if that fixes it. When I updated to the anniversary update my Bluetooth devices stopped working. I managed to fix it after reinstalling the driver from Clevo.
     
  6. ITAdviser

    ITAdviser Notebook Enthusiast

    Reputations:
    0
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    5
    Seems that fingerprint reader have been broken. There is no EgisTec ES603 Swipe Fingerprint Sensor device into Device Manager. Instead I see "Unknown USB Device (Device Descriptor Request Failed)" device
    USB\VID_0000&PID_0002\5&2AD42009&0&3
    I tried to reinstall Windows 10, install drivers from mysn site for fingerprint reader but without any good results. How to fix this issue?
     
  7. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,010
    Messages:
    50,643
    Likes Received:
    14,346
    Trophy Points:
    931
    What happens if you go through the windows process in device manager of installing the driver?
     
  8. kingyr

    kingyr Notebook Consultant

    Reputations:
    245
    Messages:
    151
    Likes Received:
    21
    Trophy Points:
    31
    Hey All,

    I know this has been brought up before, but I finally got my hands on a 1440p 144hz monitor, so for those with 1440p monitors, have you got 144hz? Currently getting 1440p@120hz - unless this is the best it can do out of miniDP? Monitor is a Asus MG279Q and got a P650SG.

    No current option to set it any higher, 120hz is nice though! but if the ability to get 144hz is there may as well get the most.

    Thanks :)
     
  9. whoang

    whoang Notebook Enthusiast

    Reputations:
    0
    Messages:
    33
    Likes Received:
    1
    Trophy Points:
    16
    Hello, P650sg owner here. My Killer 1525 network card is dying on me after a little over 1 year of use. Keeps disconnecting and reconnect even with the latest drivers. I have ordered an Intel 8260 to replace it. Anybody a current owner of an Intel 8260? How do you like it? Do I need to know anything important before I install it, btw I have never installed a network card so... yeah. Any help will be appreciated.
     
  10. kingyr

    kingyr Notebook Consultant

    Reputations:
    245
    Messages:
    151
    Likes Received:
    21
    Trophy Points:
    31
    ^ running an 8260 in mine actually, swapped over couple of months back, can't fault it. Works seamlessly, no drops and keeps a solid connection.

    Installation wise, very simple - Uninstall all killer drivers before you begin. If you have never opened it up, the whole underside of the laptop is a cover, so just remove all the screws then pop it off. Wireless card comes out on an angle, also has to go in on an angle and is held down by 1 screw, do not over tighten and use the right size screw driver.

    Have a look at these 2 pictures for reference: -
    underside
    wireless card

    Should take about 10 mins or less to install, you'll be right!
     
Loading...

Share This Page