*** Official Clevo P65xSA/SE/SG / Sager NP8650/51/52 Owner´s Lounge ***

Discussion in 'Sager/Clevo Reviews & Owners' Lounges' started by jaybee83, Oct 13, 2014.

  1. ldkv

    ldkv Notebook Consultant

    Reputations:
    26
    Messages:
    146
    Likes Received:
    11
    Trophy Points:
    31
    Hi guys,

    I'm looking for a smaller charger/adapter for my P650SG, so I can carry to school. However I'm not sure which exact model (90W or 120W) should I buy or where to buy it. Do you have any suggestion in Europe (or particularly France) ? Thank you :)
     
  2. anmatheextreme

    anmatheextreme Notebook Consultant

    Reputations:
    4
    Messages:
    267
    Likes Received:
    23
    Trophy Points:
    31
    I wouldn't recommend the 90W as it seems too small for this system. I have however tried using a 120W adapter and it works ok for everything except gaming. So 120W should be what you need.
     
    ldkv likes this.
  3. jerwaz

    jerwaz Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    6
    I'm using a 90W PSU when I'm not at home. If your system is fully charged, it is enougth for basic usage. However, it isn't enougth for the system to charge and operate at the same time !
     
    ldkv likes this.
  4. Oxford_Guy

    Oxford_Guy Notebook Evangelist

    Reputations:
    10
    Messages:
    655
    Likes Received:
    50
    Trophy Points:
    41
    Something weird has started happening recently in Windows 10 on my XMG P505 (rebadged Clevo P651SE) - I can't seem to being application windows that are minimized or in the background to the front, which is incredibly annoying. Even Alt-tab doesn't work to switch active Windows.

    Have I accidently activated some obscure Windows 10 setting? If so, how do I revert this to normal behaviour?

    Or could this be related to something else e.g. possibly to recent Nvidia Driver updates? That would be a bit weird, though.
     
  5. Khaladan

    Khaladan Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    Sounds like your Applikation opens on an not connected external Monitor. Please try Win Key + left arrow or right arrow to move your App to the internal Monitor.
     
  6. Oxford_Guy

    Oxford_Guy Notebook Evangelist

    Reputations:
    10
    Messages:
    655
    Likes Received:
    50
    Trophy Points:
    41
    I'll try that, but why would it do this? How can I stop it doing this?
     
  7. Khaladan

    Khaladan Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    I do not know why it happens . I suspect that somewhere a preferred monitor is stored for the Application.
    I've seen this before at work.
     
  8. Oxford_Guy

    Oxford_Guy Notebook Evangelist

    Reputations:
    10
    Messages:
    655
    Likes Received:
    50
    Trophy Points:
    41
    Okay, tried that, it's definitely not this. It's weird, as it won't even bring to the front an application windows I can see behind another application! It's damn stupid! I've never had this happen on a computer before.

    Sometimes it even briefly brings the window at the back to the fore, then instantly switches back again to the other application window
     
  9. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,117
    Messages:
    51,367
    Likes Received:
    14,653
    Trophy Points:
    931
    You could try re-installing the intel drivers with a clean install.
     
  10. Oxford_Guy

    Oxford_Guy Notebook Evangelist

    Reputations:
    10
    Messages:
    655
    Likes Received:
    50
    Trophy Points:
    41
    Which ones? The Intel GPU drivers?
     
Loading...

Share This Page