nVIDIA mobile Kepler 6xx MASTER overclocking guide. Workaround for max clocks/OC stability.

Discussion in 'Gaming (Software and Graphics Cards)' started by Mobius 1, Jul 14, 2012.

Thread Status:
Not open for further replies.
  1. Oz!

    Oz! Notebook Enthusiast

    Reputations:
    11
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Hi mate, good to know it worked. And thats strange about P1 i haven't seen that yet. I'm guessing u have a bios from apple which is a bit different.

    Basically, -setGPUClock:0,0,0 and -setMemoryClock:0,0,0 are the main one's you want to be messing with.

    0,0,0 the first 0 represents which gpu is applying to, since u only have one, u put 0, indicating the first card. The second 0 represents which performance level it's applying to, u have 0,1,2 (pstates 8,5,1), and the 3rd 0 represents the clock speed u want.

    So if u wanted to put 1060mhz on pstate 1, u would put -setGPUClock:0,2,1060

    The base clock offset, personally i've found no real use for this, it changes how gpuz will display the clock speed on the normal page, but -setGPUClock will always override in my experience. But what i have found strangely, it affects voltage. For example at my default frequencies 835/900, if i put -setBaseClockOffset:0,0,0 i get a normal voltage of 1.05v. If i set it to the maximum i can, -setBaseClockOffset:0,0,135, the voltage will actually go down... to 0.987v, and if i set it lower -setBaseClockOffset:0,0,-135, the voltage will go up, but not beyond the highest 1.05v. It also scales with frequency, so at 950 core clock with 135 base clock offset, i would get 1.037v, but setting the offset back to 0 the voltage would go up to 1.05v. Kinda useless imo i just leave it at 135 offset and just use -setGPUClock to set the actual frequency.

    So for 1060/2600:

    nvidiaInspector.exe -setBaseClockOffset:0,0,135 -setMemoryClockOffset:0,0,600 -setGpuClock:0,2,1060 -setMemoryClock:0,2,2600 -forcepstate:0,0

    What i would also do after applying this, is to see what -forcepstate:0,1 will do and if it still works, considering that u don't actually have a pstate0.

    EDIT: actually since u don't have pstate0, then the offsets will be different, considering that the second 0 in the 0,0,0 doesn't represent the performance level like -setGPUClock, but it represents the actual pstate value. So maybe for u have to put -setBaseClockOffset:0,1,135 for it to apply to pstate1.

    Try this instead:

    nvidiaInspector.exe -setBaseClockOffset:0,1,135 -setMemoryClockOffset:0,1,600 -setGpuClock:0,2,1060 -setMemoryClock:0,2,2600 -forcepstate:0,1
    ------------------------------------------------------

    EDIT: Zax19, for testing purposes could u try this line and see if it's any better clocking above 1000mhz?

    nvidiaInspector.exe -setBaseClockOffset:0,0,-135 -setMemoryClockOffset:0,0,500 -setGpuClock:0,2,1100 -setMemoryClock:0,2,2500 -forcepstate:0,0
     
  2. sjac89

    sjac89 Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    Oz I also have the 650m gddr3 version, Is 1100mhz the best memory clock we can get? If i go above it i get artifacts in game, Im using this command.

    nvidiaInspector.exe -setGpuClock:0,1,1000 -setMemoryClock:0,1,1100 -forcepstate:0,0
     
  3. Oz!

    Oz! Notebook Enthusiast

    Reputations:
    11
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Well everybody's card is differennt, but yeah i get the same clock. 1150 artifacts nearly instantly and 1125 after a little while. 1100 i've never seen artifact in all the long hours of gaming i've done on it.

    Wish i had the ddr5 version :( lol feels like sometimes i'm bandwidth starved.
     
  4. CHRONOSome

    CHRONOSome Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hey, Oz!

    Thank you again for explaining everything.

    I tried the following line:

    Code:
    nvidiaInspector.exe -setBaseClockOffset:0,1,135 -setMemoryClockOffset:0,1,600 -setGpuClock:0,2,1060 -setMemoryClock:0,2,2600 -forcepstate:0,1
    It works fine, I also tried the following line:

    Code:
    nvidiaInspector.exe -setGpuClock:0,2,1060 -setMemoryClock:0,2,2600 -forcepstate:0,1
    And surprisingly it worked in absolutely the same way. So as the conclusion for the MacBook Pro with the nVIDIA GT 650M VGA the offset is not needed/does not work.

    Now about issues.

    The VGA is throttling... For instance if I have 1040 MHz core clock speed it is jumping down to 675 MHz. I have also tried using ThrottleStop and disabled the BD PROCHOT protocol, however it is still throttling...

    Please find the log GPU-Z log file.

    1.PNG

    I don't know, may be it is normal for the mobile VGA, but in real life tests (games) the throttling is not noticeable.
     
  5. Oz!

    Oz! Notebook Enthusiast

    Reputations:
    11
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Excellent. Yeah the offsets aren't really needed. As i said i only found the baseclockoffset to affect voltage in a way, but is useless at higher clocks as its going to max out the voltage regardless.

    The memory offset i need to use in the P8 state, as it's tied to the P0 clock. for -setmemoryclock:0,0,1100 on the p8 state i need to set the offset for the p0 state as well otherwise it won't set.

    Strange about the clock dropping down. What game was it which made that happen?

    oh and throttlestop is only for the cpu.
     
  6. Mobius 1

    Mobius 1 Notebook Nobel Laureate

    Reputations:
    3,345
    Messages:
    9,069
    Likes Received:
    6,373
    Trophy Points:
    681
    I never said that TStop is for the GPU :p
     
  7. rjtnag

    rjtnag Notebook Evangelist

    Reputations:
    71
    Messages:
    316
    Likes Received:
    52
    Trophy Points:
    41
  8. Mobius 1

    Mobius 1 Notebook Nobel Laureate

    Reputations:
    3,345
    Messages:
    9,069
    Likes Received:
    6,373
    Trophy Points:
    681
  9. FelipeBL

    FelipeBL Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hey! I'm really new to overclocking (started yesterday, lol).. and firstly, I'd like to thank Oz! for the usefull tips and commands.

    Anyway I too have a GT650M 2Gb DDR3, and I'm using 970/1100, using the command Oz! posted a few comments back. The problem is I'm getting really high temps when gaming... like above 80ºc and near 90º sometimes... I'm guessing thats because I live in a really hot town... it's 32ºc now, and this is not a hot day...

    My question is... will this high temps during gaming will fry my card in a short time? Is there any recommend temp for this cards?
     
  10. Mobius 1

    Mobius 1 Notebook Nobel Laureate

    Reputations:
    3,345
    Messages:
    9,069
    Likes Received:
    6,373
    Trophy Points:
    681
    Ideally for kepler based cards is below 85

    Tried repasting+using cooler pad?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page