NP8150 Intel 6230 Ping Spikes (Not from polling)

Discussion in 'Sager and Clevo' started by Bryanu, Feb 26, 2012.

Thread Status:
Not open for further replies.
  1. Bryanu

    Bryanu Notebook Deity

    Reputations:
    98
    Messages:
    737
    Likes Received:
    16
    Trophy Points:
    31
    Being I am the OP figure would give some updates. This might be more of a Windows vs Driver issue though which I will explain further down.

    I have worked with a few Intel Engineers and they have told me:

    "I spoke with some of our driver developers today, and your prediction is accurate. Work on the scanning algorithms is happening while we speak. It’s a very difficult task. Different users have different requirements. We’ve got users in hospitals that mount their computers on carts and run down the halls, moving from patient room to patient room. These users want seamless fast roaming, and that requires accurate scanning. Then we have users that might sit in one location all day and be associated to the same AP. This requires minimal scanning. You could argue that perhaps configuration parameters be added to help define the environment, but one thing most users seem to want is minimal interaction in the configuration of WiFi. For the most part, they just want to turn on the computer, connect, and move on."


    So straight from the horses mouth it is a known issue. This is from an email back in May and to this date is still an issue.

    They did provide me the following which fixed the issue but has it's own downfall:

    "There’s a parameter in the registry that will prevent the adapter from scanning while associated to an AP. It’s named ScanWhenAssociated. Default value is 1. Set it to 0 to prevent scanning. The negative outcome for this action is that roaming may be affected. When it comes time to roam, the WiFi adapter might not have an up to date scan list. To find the parameter in the registry you can do a search under CurrentControlSet."

    After that change you will probably need to reboot.

    Anyway so the options on Intel at the moment are the above or use the program I stated in OP "WLAN Optimizer" and selecting the stream option. (Disabling background scanning doesn't seem to do the trick, which is odd because based on the above regedit change that is background scanning...)

    Anyway so to move onto the why I think it's also Windows and the Drivers together causing...

    I recently got an Killer 1202 N card for this laptop.

    Removed all old Intel drivers, installed card and installed latest drivers.
    Guess what? SAME THING haha.
    What I found on this driver however is the driver DOES have a setting to set background scanning to OFF. Doing so FIXED my problem and best of all if I click wireless it will force a scan so I can see networks, unlike the Intel registry change if you are connected to a network and have that regedit set, NO SCAN will happen, not even manual unless you disconnect from the AP.

    People have found force installing XP drivers seems to fix this also (seems more likely XP just didn't support this exact method of however vendors are using).

    On a final note, this is not router dependent, is all client side.

    I beta test hardware for various router manufactures and have been on an 802.11ac router since before they became public (multiple vendor ones also) and them as well as my original 802.11n router all did the same thing.

    So this all being said, it is basically a type of background scanning but has been modified somewhat. What I find odd is how the Intel vs Killer (Atheros) handle background scanning differently.

    So my solution for now is I have left the Killer card in. It has BT4.0 so is newer vs Intel anyway. Only downside is the WLAN light doesn't work when using killer cards ha.

    Anyway, good luck all, feel free to post any new sharing yourself also and again remember this is only in relation to a ping spike every 60-90 seconds, not a constant high ping... If you just have high ping it's something else.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page