No sound from MacBook internal speaker

Discussion in 'Apple and Mac OS X' started by CountAltec, Sep 17, 2007.

Thread Status:
Not open for further replies.
  1. CountAltec

    CountAltec Notebook Guru

    Reputations:
    7
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    I bought a MacBook a few weeks ago and all has been working well until I noticed this today:

    When my headphones are unplugged from the MacBook audio output, there is no sound from the internal speakers. I tried to adjust the audio volume, but the slider is disabled.
    When I went to Sound in System Preferences, under the Output tab all I see is Name: Digital Out,
    Port: Built-in Output
    The selected Device has no Output controls.

    I had a look at the audio output jack and there is a red light glowing.
    When I plug in my headphones, I hear audio through the headphones and Sound in System Preferences shows:
    Name: Headphones
    Port: Built-in Output
    and the volume control slider is now enabled.

    Any ideas what could be wrong? I tried to run a search in the forums for this issue but came up with nothing.

    Thanks
     
  2. RadcomTxx

    RadcomTxx Notebook Deity

    Reputations:
    101
    Messages:
    873
    Likes Received:
    0
    Trophy Points:
    30
    you somehow have the digital out enabled. you need to disable the digital out to enable the internal speakers again. this happens automatically when you plug headphones in.
     
  3. CountAltec

    CountAltec Notebook Guru

    Reputations:
    7
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
  4. JimyTheAssassin

    JimyTheAssassin Notebook Evangelist

    Reputations:
    109
    Messages:
    501
    Likes Received:
    0
    Trophy Points:
    30
    oh ya.. the old toothpick fix... gotta love that one =) kudos for finding the work around.
     
  5. CountAltec

    CountAltec Notebook Guru

    Reputations:
    7
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    So.. I shut down the MacBook last night, and now that it's booted up, all works fine!
     
  6. MacAdvantage

    MacAdvantage Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I found something that worked! The same issue happened on one of my customers' MacBook. The Sound control panel only allowed the option to choose Digital Audio, the internal speakers did not show up as an option, and the prohibit sign (circle with a line through it) showed up when pressing the sound up, sound down keys.

    As suggested, I tried plugging and unplugging a set of external headphones into the headphone jack several times and wiggling, but that did not work. I wasn't ready to try the toothpick suggestion yet.

    However, I decided to turn my attention to the audio-in jack, so I plugged the same headphones into the that jack (next to the headphone jack), removed them, and voila - all was back to normal.

    Hope this helps some of you out there. --Andrew
     
  7. r0k

    r0k Notebook Evangelist

    Reputations:
    104
    Messages:
    406
    Likes Received:
    0
    Trophy Points:
    30
    Welcome to NBR, MacAdvantage!

    You woke up a rather old thread but I'm glad you brought this up in case I ever see this issue.
     
  8. Sam

    Sam Notebook Virtuoso

    Reputations:
    3,661
    Messages:
    9,249
    Likes Received:
    0
    Trophy Points:
    205
    Yeah, thanks for your answer, MacAdvantage, but this thread is outdated and I'll have to close it now :eek:. Welcome, by the way! Hope to see you around :).
     
Loading...
Thread Status:
Not open for further replies.

Share This Page