No Backlight on LED screen

Discussion in 'VAIO / Sony' started by nebage, Sep 27, 2011.

  1. thenighthawk

    thenighthawk Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    i was i an hurry, it was the main cause. Otherwise i will certainly remove battery first :( i was a good lesson to me,i will never forget again :mad:
     
  2. sky123

    sky123 Notebook Consultant

    Reputations:
    1
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    30
    Can anyone tell me how they manage to solder this?

    I am a complete newb at this and would appreciate if someone pointed me to right direction (a video maybe?)
     
  3. applemaca

    applemaca Notebook Enthusiast

    Reputations:
    1
    Messages:
    35
    Likes Received:
    2
    Trophy Points:
    16
  4. thenighthawk

    thenighthawk Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    we need higher resolution macro photos of lcd cable connector area both sides and colour please.
     
  5. trieudoahong

    trieudoahong Notebook Consultant

    Reputations:
    19
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    30
    is it a known issue or just a trick to make it work?
     
  6. ngvuanh

    ngvuanh Notebook Deity

    Reputations:
    288
    Messages:
    1,168
    Likes Received:
    31
    Trophy Points:
    66
    @applemaca
    The fuse is pointed by red arrow.

    @trieudoahong
    It is not a trick, you have to replace or short the fuse to get backlight back.
    It could be a fault in design or just improper handling when people replace broken LCD (not unplug battery/AC adapter).

    [​IMG]
     
    umerilyas likes this.
  7. roninra

    roninra Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi i got similar problem with my vaio p11z with 8" led screen I've read whole story and im sure i need to replace the fuse... problem is i cant locate anything with F or N , bios battery connector is marked red and i spotted two resistors marked green i got no way to test it will have to buy multimeter... maybe someone had this model with same problem ... i marked the connector on both images fuse should be somewhere close but board is so tiny im not sure if everything is visible...please please help me... if you need better pictures or if you got anything that could help respond regards rob :)
    ImageShack® - Online Photo and Video Hosting
     
  8. ngvuanh

    ngvuanh Notebook Deity

    Reputations:
    288
    Messages:
    1,168
    Likes Received:
    31
    Trophy Points:
    66
    You might have other problems than just a blown fuse.
    I notice the board was suffered liquid spilled with evidences of corrosion.
    ImageShack Album - 2 images
     
  9. roninra

    roninra Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    hi thank you for respond yeah I've noticed that white stuff on the board .... i bought this laptop of ebay with broken screen thought it will be easy screen replacement bought new screen then new cable still no joy....then i found this forum :) apart from back light its perfect working order i checked with external monitor so im 100% sure fuse is the case... can You see anything that could be looking like fuse ? thanks in advance Rob
     
  10. ngvuanh

    ngvuanh Notebook Deity

    Reputations:
    288
    Messages:
    1,168
    Likes Received:
    31
    Trophy Points:
    66
    I posted your pictures with some red circles.
    I have pointed out the fuse for you on the second photo.
    It is at lower left corner of the board on the side without CPU and chipset.
     
Loading...

Share This Page