New XPS 15- 9530 Wireless card not working

Discussion in 'Dell XPS and Studio XPS' started by marc515, Dec 10, 2013.

Thread Status:
Not open for further replies.
  1. marc515

    marc515 Notebook Consultant

    Reputations:
    0
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    31
    Just got our new XPS 15-9530 Base Model, and the Intel AC7260 wireless card is not working!

    Spent almost 2 hours on the phone with tech support and they are sending someone out to replace the card.

    Not only is it the worst tech support I've ever experienced, I'm really disappointed with a new computer which is not working properly.

    This experience is pushing me closer to an Apple MacBook Pro for sure!
     
  2. marc515

    marc515 Notebook Consultant

    Reputations:
    0
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    31
    Is anyone else experiencing any issues with their wireless card on their 9530?

    Hopefully, this is only a 1 in a million
     
  3. manishdev

    manishdev Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    6
    I just got mine on 12/7 and am currently stress testing it.

    I have a Dual Band Router (Netgear WNDR3700 rev 1 - WNDR3700 | WiFi Routers | Networking | Home | NETGEAR)

    With the 2.4Ghz - N connection I was experiencing issues, not connecting to the wifi, but getting an internet connection. Only tested this for a little while on the first day I got my laptop. Will revisit the test tonight.

    With the 5Ghz - N connection, it has worked like a champ since I first got my laptop. Was great when streaming 4k content off of Youtube

    At work, we have a 2.4GHz N connection. It worked great all day with no issues. Also great when streaming 4k content off of Youtube.

    I will retest the 2.4 Ghz N connection at home and reply back.

    Good luck with getting yours taken care of.

    FYI, I also ordered the Anker USB 3,0 to Ethernet adapter from Amazon and will be testing that as well
     
  4. marc515

    marc515 Notebook Consultant

    Reputations:
    0
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    31
    UPDATE:

    Well after 3 hours of Dell tech support and no solution but them wanting to replace the Wifi card, I decided I would do some of my own research; thank goodness for the internet.

    My Router worked fine with every other device in out home, but apparently with Windows 8.1 and all the new drivers the problem ended up being the firmware in my router, I updated the firmware and our new XPS-15 is working fine.

    Looks like we all have to stay on our toes!
     
Loading...
Thread Status:
Not open for further replies.

Share This Page