NEW UPGRADE with GTX 1070 for old Clevo/Alienware/MSI

Discussion in 'Sager and Clevo' started by woodzstack, Nov 1, 2017.

  1. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,738
    Messages:
    48,306
    Likes Received:
    13,171
    Trophy Points:
    931
    BIOS corruption due to static, something happening in shipping, you never know.
     
  2. mjahearn

    mjahearn Notebook Enthusiast

    Reputations:
    5
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    6
    As in the vBIOS on the card, right? Because I'm able to boot into Windows with my old card installed still.
     
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,738
    Messages:
    48,306
    Likes Received:
    13,171
    Trophy Points:
    931
    Yes, talking about the card itself.
     
  4. andrewff2

    andrewff2 Notebook Evangelist

    Reputations:
    24
    Messages:
    329
    Likes Received:
    41
    Trophy Points:
    41
    Sup guys,

    Just wondering if anyone here tried to upgrade the P151EM with the 1070? I´ve tried it myself everything stock and it's working.
     
  5. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,738
    Messages:
    48,306
    Likes Received:
    13,171
    Trophy Points:
    931
    P151 shares the same motherboard with the p150em and p170em so what's true for one will be true for yours too
     
  6. andrewff2

    andrewff2 Notebook Evangelist

    Reputations:
    24
    Messages:
    329
    Likes Received:
    41
    Trophy Points:
    41
    Hmm that's cool! Yeah i was looking around is the same HM77
     
Loading...

Share This Page