1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

New M17x R3 blue screens when in AHCI mode

Discussion in 'Alienware 17 and M17x' started by jd63636, Feb 8, 2012.

  1. jd63636

    jd63636 Notebook Geek

    Messages:
    88
    Likes Received:
    9
    Trophy Points:
    16
    So I brought my new R3 home today and booted it up.



    What I noticed was the intel raid utility screen which was odd since I ordered it with the single 256Gb SSD But. It came out of the box with the sata set to "raid mode".

    So I went in to the bios and switched it to AHCI. However the computer boots then blue screens. If i switch back to raid mode it boots to windows fine?

    I switched back to AHCI and reloaded the alienspawn image and same results.

    After one hour on the phone with tech support they have no clue ;-7

    And their parting comment is it will run more stable this way LOL

    Anyone seen this before on a M17X R3? This was to expensive to be having this happening right out of the box.

    Config:

    M17X R3
    A09 Bios
    Core i7 2670QM
    Radeon HD 6870m
    1920 x 1080 60Hz WLED
    256Gb SSD (Samsung PM810)
    Slot-Loading Dual Layer Blu-ray Reader (BR-ROM, DVD+-RW, CD-RW)
     
  2. Volkly

    Volkly Notebook Enthusiast

    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    15
    try going to windows first with raid in bios:

    Msahci driver requires Atapi.sys miniport to be loaded during boot as well. So you need to change theStart value to 0 for both of the following entries in your registry. You can use regedit.exe utility.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi

    Or you can also simply run the below command lines in an elevated window.

    REG ADD HKLM\System\CurrentControlSet\Services\msahci /v Start /d 0 /f /t REG_DWORD
    REG ADD HKLM\System\CurrentControlSet\Services\atapi /v Start /d 0 /f /t REG_DWORD

    Reboot to Bios, and change it to AHCI
     
  3. The Revelator

    The Revelator Notebook Prophet

    Messages:
    4,571
    Likes Received:
    0
    Trophy Points:
    105
    For best results, you need to reinstall Windows (with full format) with SATA mode set to AHCI.

    There is also a registry hack that allows you to use the existing installation. Load Regedit and navigate to the following keys:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pciide, and
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi

    Change the value of each to 0. Then reboot, but enter the BIOS (F2 at the boot screen) and change the SATA setting to AHCI. Save and exit the BIOS. It should boot cleanly using AHCI.

    Edit: Sorry, Volkly, didn't see your post until after posting.
     
  4. Volkly

    Volkly Notebook Enthusiast

    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    15
    no apologies need at all, we are all just trying to help! hope it helps the OP and resolve his issue
     
  5. Tsunade_Hime

    Tsunade_Hime such bacon. wow Super Moderator

    Messages:
    10,509
    Likes Received:
    915
    Trophy Points:
    531
    Could be your AHCI mode is flaky? My R2 couldn't install anything in IDE mode, plus POST was super slow. My E6410 would have random BSOD in AHCI or RAID mode, I had to RMA it to Dell for a refund.
     
  6. Mr. Fox

    Mr. Fox Overclocked | Overvolted Moderator

    Messages:
    18,910
    Likes Received:
    7,143
    Trophy Points:
    931
    I really don't understand why so many folks feel compelled to take the BIOS out of RAID0 and put it into AHCI mode. Perhaps only to not see the Ctrl+I screen for 1 or 2 seconds during post? There must be a good reason Dell/Alienware uses RAID0 from the factory as the default setting on all systems, including those with a single drive configuration.

    The nice thing about having Windows installed with the BIOS set to RAID0 is the ability to add a matching drive later and create a RAID0 setup within Windows using Intel RST. If you install Windows in AHCI mode you'll inevitably need to do a clean install. It also allows you to make a more versatile drive image that can be installed on a single drive and/or used to create a RAID0 setup later on.
     
  7. jd63636

    jd63636 Notebook Geek

    Messages:
    88
    Likes Received:
    9
    Trophy Points:
    16
    Mr Fox

    That is exactly my point and the question I could not get an answer on from Alienware.

    It strikes me as odd that Alienware configures a single (SSD) drive config for Raid in the bios. Unless there is a (stability) or some other problem they can not fix when running in AHCI mode?

    As for the Ctrl+I screen I have no problem seeing it for the 1-2 seconds.

    I just would like the question answered by a competent tech at Alienware.
     
  8. widezu69

    widezu69 Goodbye Alienware

    Messages:
    4,181
    Likes Received:
    142
    Trophy Points:
    131
    That's an oxymoron. The techs are pretty incompetent most of the time. I reckon that at the factory, they just install the drive and then windows without touching the bios. It is a matter of ease nothing else.

    You can keep asking but chances are you will never get a straight answer. Just do the fixes people have posted above and you will be rocking AHCI no problems.
     
  9. YodaGoneMad

    YodaGoneMad Notebook Deity

    Messages:
    1,382
    Likes Received:
    12
    Trophy Points:
    56
    Intel themselves recommends Raid in all cases, they claim that Raid is the same as AHCI in terms of performance and features, you just also have the option of using Raid features as well. Generally you have to modify or re-install windows to change these settings, so it makes sense to send the machines out with Raid enabled so it can do anything without needing to be modified.

    This is normal, every machine is always set to Raid, and changing to AHCI always causes issues without modification or a reinstall. Dell does it because Intel tells them to do it. If you check under the Intel utility in Windows you will see that all AHCI features (like Native Command, etc) are enabled in Raid mode.
     
  10. GeoCake

    GeoCake http://ted.ph

    Messages:
    1,232
    Likes Received:
    1
    Trophy Points:
    56
    I found my single SSD faster (half a second - second) under a RAID controller... But that screen on boot up annoyed me.

    Someone should do some before and after benchmarks.
     
  11. jd63636

    jd63636 Notebook Geek

    Messages:
    88
    Likes Received:
    9
    Trophy Points:
    16
    Just changed the three values suggested between the two posts and works like a charm.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci - changed from 3 to 0
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi- changed from 3 to 0
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pciide - changed from 3 to 0
     
  12. jd63636

    jd63636 Notebook Geek

    Messages:
    88
    Likes Received:
    9
    Trophy Points:
    16
    Thanks for all the responses and explanations. I reset everything back to original config. Now to get everything loaded on and play some WOW
     
  13. The Revelator

    The Revelator Notebook Prophet

    Messages:
    4,571
    Likes Received:
    0
    Trophy Points:
    105
    Good news and good luck. Enjoy that R3. :)
     

Share This Page