New Dell XPS 15 9560 is very slow!!!

Discussion in 'Dell' started by Al913, Jun 23, 2017.

  1. Al913

    Al913 Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    15
    Just got a brand new Dell XPS 15 9560 today and was very excited. However only using it for a couple of hours it is really slow. For searching the web it takes literally 15 seconds to load a new page. The computer has the 7th gen i7, 8 gb ram, and 256 SSD. My older computer which broke was over 5 years old and it only took 3 seconds to load a new page.

    However just with my chrome browser and spotify open, my ram is running at 60% and task manager is saying I have 160 processes!!!

    For some software background, I downloaded: Google Chrome, GeForce Experience, Kaspersky Internet Security, Steam, Spotify, Robocraft, Mozilla Firefox, CW Client, and HiSuite.

    I did update my Nvidia Geforce Driver, but did not download a new Windows 10. However I did update the Windows Update.
     
  2. namaiki

    namaiki Sydney, Australia Super Moderator

    Reputations:
    3,889
    Messages:
    6,090
    Likes Received:
    75
    Trophy Points:
    216
    Does the computer feel slow with other applications? Is wifi reception weak causing slow loading times?
    Ram usage around 50% is good. Windows uses your RAM for caching to keep things responsive.
     
  3. Al913

    Al913 Notebook Enthusiast

    Reputations:
    0
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    15
    When I play CW wars client it is not slow at all. This morning things seem to be a bit better.

    Should I put a new copy of windows? Will that wipe all the desktop apps I downloaded? Will it wipe my security software?
     
  4. namaiki

    namaiki Sydney, Australia Super Moderator

    Reputations:
    3,889
    Messages:
    6,090
    Likes Received:
    75
    Trophy Points:
    216
    If you reinstall Windows, it will generally wipe everything.
     
  5. bennni

    bennni Notebook Evangelist

    Reputations:
    43
    Messages:
    354
    Likes Received:
    185
    Trophy Points:
    56
    Is it possible that it's a fairly fresh install and Windows Update was downloading 100000000000000 updates in the background? That always happens when I install a fresh OS and am too lazy to bundle the recent updates into the install media.
     
  6. kojack

    kojack Notebook Deity

    Reputations:
    111
    Messages:
    902
    Likes Received:
    71
    Trophy Points:
    41
    I think where it is new, it's loading updates in the background. Give it a few days, keep an eye on the updates from Microsoft and Dell as well. My 13 5000 does this as well. But after they are all done, and a restart it's just like the Jackalope...fast as fast can be! ha ha. There is no reason for an xps to be slow other than updates.
     
  7. republicofsam

    republicofsam Notebook Consultant

    Reputations:
    56
    Messages:
    146
    Likes Received:
    24
    Trophy Points:
    31
    I just got mine about a week ago, I had the same problem. Windows downloaded like 200 updates including the new creators update. Install of latest drivers and a few restarts all was lightning fast.
     
  8. kojack

    kojack Notebook Deity

    Reputations:
    111
    Messages:
    902
    Likes Received:
    71
    Trophy Points:
    41
    Figured as much. Yeah windows updates when you get a new machine DRAG it down bad. Once you are all up to date, it's much better!
     
  9. kojack

    kojack Notebook Deity

    Reputations:
    111
    Messages:
    902
    Likes Received:
    71
    Trophy Points:
    41
    oh, btw, OP, did your computer speed up after?
     
Loading...

Share This Page