New BIOS for 15R2/17R3 v1.4.4

Discussion in '2015+ Alienware 13 / 15 / 17' started by 95TA, Jan 18, 2018.

  1. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,538
    Likes Received:
    5,075
    Trophy Points:
    681
    I had to disable OS level mitigation after BIOS update to negate the performance impact. So I'm vulnerable.

    Disable Speedstep,BD PROCHOT and enable Speedshift,C1E.
     
  2. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,538
    Likes Received:
    5,075
    Trophy Points:
    681
    Even I'm out of warranty. I used Dell Gset application to flash it. You can put the exe file to usb drive and restart the pc. Upon seeing AW logo, press F12 and select BIOS flash Update. Use tab key to navigate to each and every buttons to select the file and flash it safely.
     
  3. VICKYGAMEBOY

    VICKYGAMEBOY Notebook Deity

    Reputations:
    306
    Messages:
    914
    Likes Received:
    606
    Trophy Points:
    106
    I have 8 more months warranty left.. so im glad i can test out for others.. intel is not delaying anything here, they uploaded the patch within a week time of discovery, where in OEMs are too lazy to implement, yes im more leaning towards RZ2 or TR2 for my desktops, its time to put my haswell chip to sleep.. btw im using AHCI, so i dint see any negative impact on SSD Reads / writes.. may be they are having isssues for my skylake models updating me firmware, like i had, so many random issues after updating to 11.8, windows activation issue, cold reboots, etc etc
     
    Vasudev likes this.
  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,538
    Likes Received:
    5,075
    Trophy Points:
    681
    Try enabling the OS mitigation http://forum.notebookreview.com/thr...xes-index-post-1.779394/page-55#post-10666250
     
  5. 0lok

    0lok Notebook Evangelist

    Reputations:
    205
    Messages:
    671
    Likes Received:
    364
    Trophy Points:
    76
    This is my set up. -175 mV cpu undervolt using TS. Also the screen shot was taken when I woke up early in the morning. As you can see no temp issues. My CPU clock just run on base clock when on light load. Last night I was playing PUBG my cpu clock was running fine and stable on 3.1 ghz. I have also tried enabling CPU mode in bios and has no changes made. I have been having this problem ever since I update my bios beyond bios version 1.3.6. Bios 1.3.6 has been the most stable bios version for so far. I hope someone can help me with this problem. If no other solution can be found I think I will just roll back to bios 1.3.6.
    Edited:
    Also to have I'm on high performance mode. My CPU didn't use to drop down to base clock on bios 1.3.6. Always stable on 3.1ghz..
    Cpu Core on base clock.jpg
     
    Last edited: Jan 20, 2018
    Vasudev likes this.
  6. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,538
    Likes Received:
    5,075
    Trophy Points:
    681
    Enable Speedshift EPP and disable Speedstep. Save TS profile.
     
  7. Papusan

    Papusan JOKEBOOKS = That sucks! Dont wast your $ on FILTHY

    Reputations:
    16,428
    Messages:
    20,186
    Likes Received:
    31,867
    Trophy Points:
    931
    Have you compared your fixed core voltage with your undervolt on newest firmware vs. what you used to run before?
     
  8. VICKYGAMEBOY

    VICKYGAMEBOY Notebook Deity

    Reputations:
    306
    Messages:
    914
    Likes Received:
    606
    Trophy Points:
    106
    @Vasudev should we tag someone from alienware ?? so that they knows that the new bios doesnt have the firmware update which fixes SA0086 issues.. ive already wrote a mail to few of them, @Papusan help tag us few if u you know..
     
  9. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,538
    Likes Received:
    5,075
    Trophy Points:
    681
    Our option is to fix their BIOS ourselves using fpt tool as Falk said. Unlock all menus and change MEFW local update and re-flash to enabled for Prema's MEtool to work. I don't have a HW programer and I am scared as Hell to flash custom BIOS region.
    I have everything incl. menu unlocked, hot plug SATA's like Prema. Though I don't know anything about optimal OC settings like @Prema does, but its a mediocre work.
    With this I have a BIOS 1.3.12 with new microcode patch C2 {thanks to Daz}.
    Darn, why do Dell makes everything complicated.
    You can tag Wassemann but its been too long since they responded. Atleast Dell can give unlocked BIOS and we'll patch with new FW and uCodes.
     
    VICKYGAMEBOY likes this.
  10. VICKYGAMEBOY

    VICKYGAMEBOY Notebook Deity

    Reputations:
    306
    Messages:
    914
    Likes Received:
    606
    Trophy Points:
    106
    well i just use to have a SPI flasher, my uncle gave it to me, but its not working anymore, well dell makes things more complicated, like the new alien FX controllers, may be they are creating something unique.. lets wait and see, until that im done, ive tweeted alienware reps.. about the issue, if they see, they might update driver page.. if not.. all hands on u guys..
     
    Vasudev likes this.
Loading...

Share This Page