New BIOS for 15R2/17R3 v1.4.4

Discussion in '2015+ Alienware 13 / 15 / 17' started by 95TA, Jan 18, 2018.

  1. Hamsterminator

    Hamsterminator Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    After having my Alienware15r2 attempt an update followed by repeated crash restart cycles last night, I am only now having to scour the internet for advice on what to do about this.

    I am currently installing windows updates after a complete system reset and still have the original bios version that caused all this: 1.4.4. Dell seem to be advising people to install the version on their website which is also 1.4.4, but if windows updates are still causing serious compatability issues even now, I fear this isn't anywhere near over.

    1. Should I try to install the latest bios version as theyre advising?
    2. Is there any scope for a refund or similar despite being almost a year outside warranty? This is afterall their mistake surely?
     
  2. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,535
    Likes Received:
    5,073
    Trophy Points:
    681
  3. hodgeMN

    hodgeMN Notebook Evangelist

    Reputations:
    37
    Messages:
    409
    Likes Received:
    94
    Trophy Points:
    41

    Which gen CPU do you have? I imagine getting Dell to honor any sort of claims outside of your warranty is going to be tough.
     
  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,535
    Likes Received:
    5,073
    Trophy Points:
    681
    skylake.
     
  5. kien.nguyen

    kien.nguyen Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    6
    Hi everone,

    I'm having shutdown problem (leds stay on, have to long-press power to completely shutdown) after flashing 1.4.4. I've tried to revert to 1.3.12 using the method @Vasudev mentioned above, then reset CLRP1 pin on the motherboard, but none of the above works. I'm desperate to have a normal functioning system, can anyone please help!!
     
    Vasudev likes this.
  6. ilicitano

    ilicitano Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    10
    Trophy Points:
    6
    @kien.nguyen same problem here and I couldn't fix the problem. I'm currently on bios 1.3.12. I have cleared CMOS (CLRP1) and installed win10 again without success. I guess there is no a solution yet.
     
    Vasudev and kien.nguyen like this.
  7. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,535
    Likes Received:
    5,073
    Trophy Points:
    681
    Updated MEI FW yet? You could follow the guide in which I updated MEI FW to latest available 11.8.50.3448. FYI, Prema MEI Tool is uploaded.
    After MEI FW create a Dell Diag USB with your 1.4.4 BIOS and reset BIOS to defaults.
    *OFFICIAL* Alienware 13 R3 Owner's Lounge
     
    kien.nguyen likes this.
  8. 0lok

    0lok Notebook Evangelist

    Reputations:
    205
    Messages:
    671
    Likes Received:
    364
    Trophy Points:
    76
    @Vasudev if you have time try to make a new thread about the guide and make it as simple as possible and with a caps of do it on your own risk.. I guess that would be realky helpful I guess..
    @kien.nguyen Try reflashing bios 1.3.12 again so it will properly overwrite the bad bios from 1.4.4.. Just a suggestion tho.. hehehe
     
    kien.nguyen and Vasudev like this.
  9. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    4,412
    Messages:
    7,535
    Likes Received:
    5,073
    Trophy Points:
    681
    You have to follow that guide once to unlock your MEFW for future updates and afterwards you can use Prema's tool to update everytime.
    There's no risk at all since you are bypass security restrictions. Anyway, I will try to make or copy-paste that guide with readymade Prema tools.
     
    kien.nguyen and 0lok like this.
  10. tonyspo

    tonyspo Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi. I'm gathering customers which have been affected by this issue in a facebook group so we can gain visibility and hopefully receive the support we deserve. Feel free to join and share it. I'll keep you updated there on any resolution as soon as possible.

    BIOS update fault - Facebook group
     
Loading...

Share This Page