New Aero 15 Classic XA Owner Questions

Discussion in 'Gigabyte and Aorus' started by nr_clark, Dec 29, 2019.

  1. nr_clark

    nr_clark Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi all, I'm a new & proud owner of a Gigabyte 15 classic laptop. According to Best Buy, I bought the 144hz screen, 512GB, RTX 2070 non-max-q variant (CLASSIC-XA-F74ADP) even though I think they mis-labeled the item specs.

    I have concerns regarding the longevity of the machine.

    Q #1: The laptop gets VERY hot when playing AAA titles at max settings, even at max fan mode (fn + Esc). Does Gigabyte use thermal paste on the CPU & GPU? Which kind? I can apply Thermal Grizzly Conductonaut or something to help, but I was just wondering.

    Q #1.5: The rear of the laptop is very low and I don't think it's enough room for air flow. Any quick way around this?

    Q #2: The battery charges all the way and I was wanting to keep it in good health by limiting max charge to 80% or something. But it seems the Control Center doesn't have an option for that?

    Q #3: The laptop wakes up from sleep mode every 4hrs or so all on its own. Is this a bug and how can I go about fixing this?

    TIA for any help
     
  2. ClassicNerdGirl

    ClassicNerdGirl Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    3
    Trophy Points:
    6
    Hey, so I have an Aorus 15 XA - and it doesn't get hot when I'm gaming hard. But from what I'm seeing looking at the AERO 15 Classic specs is that you're running studio drivers and not RTX drivers. However, are you taking advantage of the AI settings to switch into gaming mode, if you haven't used those yet give it time to learn your use habits and it will send power to the right places without any tweaking on your part. I've found those really optimize things, I mean the fans get going hard, but that's better than overheating.

    2. If you go into the control center - if you click on Manager in the top nav, then click on the charging options (middle right column) you can set your charging preference.

    3. Weird - haven't had that problem, that sounds more like a Win10 issue, go in and check your settings in the Power & Sleep section.
     
Loading...

Share This Page