Need Help: Geforce GTX 1070n Successfully Installed in a G1 Zbook 15 but it's not perfect yet

Discussion in 'HP' started by ChanceJackson, Apr 23, 2017.

  1. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    I'm running the following specs


    i7-4700MQ @ 2.4Ghz or 3.4Ghz Turbo(Apparently I can overclock this another 3 or 400Mhz)
    16 GB Ram soon to be 32GB
    win 10 Anniversary edition
    500GB Sata 3 SSD
    MXM3.B GTX 1070n with Msi Non-Gsync Bios posted by Stas.b85 (I'd like to try a non gsync vbios from a Dell/Alienware that uses Optimus/Hybrid GFX and the MXM version of the GTX 1070n)

    Some things need troubleshooting are listed in order of importance:

    -When Hybrid GFX is on(I tried Auto and Enabled) the Intel iGPU displays to the laptop screen and my 1070n card can't see the laptop screen, or output to the screen or render games when the laptop screen is the main screen but the 1070n can output via DP to external screens and handle GPU duties if the external screen is the main screen

    -The CPU fan runs at max speed with this MXM in it, I assume it is because the Mobo can't read the temp sensors of the 1070n card and I think I can get around that with a more compatible vBios probably one from a Dell will due if not there are temp sensitive fan regulators I can get off ebay and I already ordered one that will ship straight outta china.




    ( Way less important)
    - if I turn off hybrid gfx the device/model id of the laptop changes from 1909 to 197B which requires the nvidia driver inf to be modified again with the "new" laptop model ID and the driver needs to be reinstalled but gpu never comes back on after the "gpu driver install" flicker and the the system beeps until reboot when it comes back on the driver isn't installed
     

    Attached Files:

  2. Ashtrix

    Ashtrix ψυχή υπεροχή

    Reputations:
    961
    Messages:
    1,769
    Likes Received:
    2,192
    Trophy Points:
    181
    Is your machine having 120Hz Panel ? HybridGFX from the way it sounds, seems to be like an Optimus/MUX implementation, Does this Zbook have HW MUX switch ? To make the machine switch to the dGPU/PEG mode like the older Ivy AW and Haswell PGA AWs and now Pascal BGA AWs.

    If you are running with the 1070N with iGPU seems like Intel FDI is working (60Hz) (??). Your screen specification is important...yes you said eDP but still, I'd like to know if it's 120Hz or the 60Hz, iirc HP Zbooks have the eDP to LVDS converters on the mobo like the MSI GT83 VR which has a 60Hz panel but uses internal LVDS to eDP conversion.

    As we all know Pascal needs eDP outputs or FDI enabled machines like M17x R4 with 60Hz can pull it off with Optimus/SG mode.

    P.S - Would be cool if you can share on how you did (Pictures please, love to see the guts :p ) the 1070N MXM3.0b upgrade onto a MXM A machine...;)
     
    Last edited: Apr 23, 2017
  3. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    Mind you I have I have 2 of them, one is stock and a good reference system however this one is dedicated to the 1070n MXM project in both cases so long as Hybrid Gfx is on all video to the laptop screen comes from the iGPU. On my stock system the 3d stuff is rendered by the quadro card even if I'm only using the laptop screen so that should be FDI working as it should

    BUT
    on my 1070 system the dGPU stands aside and lets the iGPU handle everything except for external monitor connections


    Not sure about all the Muxing but if I turn off Hybrid GFX the laptop model device ID changes from 1909 to 197b and the iGPU deactivates and the dGPU takes over but installing the nVidia driver in this mode can only get as far as the "gpu driver install" flicker and then it just stays on a blank black screen beeping with long intervals inbetween

    again when Hybrid Gfx is on in bios all video to the laptop screen comes from the iGPU so that should be FDI working as it should so that should be the diff between Muxing and using FDI right?



    The screen is that popular 15.6 AOU IPS and it is 60hz



    My systems is really jacked up right now right now once it is all neat and tidy I will post a thread called Something like "Bga OEMs Hate Him" and include pictures of the results from all the desoldering, dremeling, drilling and resoldering I did

    I forgot that I had read someone got it working that way. Do you recall who it was? I'd love to get there vBios
     
    Last edited: Apr 23, 2017
    Ashtrix likes this.
  4. Ashtrix

    Ashtrix ψυχή υπεροχή

    Reputations:
    961
    Messages:
    1,769
    Likes Received:
    2,192
    Trophy Points:
    181
    Yeah seems like it..as your screen is 60Hz & Pascal working.

    It's a Quadro card, you can't flash that on this GeForce GPU.

    I think @triturbo should know more about HP Zbook machines, Nevertheless amazing work +rep bud !!
     
    ChanceJackson likes this.
  5. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    Much Appreciated and thx for the Rep!

    @triturbo would you like to weigh in at all on this?
     
  6. Talon

    Talon Notebook Virtuoso

    Reputations:
    475
    Messages:
    2,136
    Likes Received:
    1,449
    Trophy Points:
    181
    What version of windows and what driver are you attempting to mod and install?
     
  7. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    Im using win 10 pro and the latest version of the mobile driver from nvidia 381.65 in which case it has installed without issue with Hybrid GFX on but it will not fully install when hybrid Gfx is off
     
  8. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    Guys I fixed it!

    I caused the problem by having an incomplete knowledge of nVidia INF modifications basically I used Nulls guid to setup everything and I just used a random Section ID and since his guide doesn't describe what they are for or how to mod them I never bothered to but when I went to rewatch the SoundOfLenses video on getting a 965m to work with his Zbook15 I realized he modified the section042 and added the NVSupportOptimus = 1 after trying just that and failing I looked into it all a great deal more and found that you need all 3 of the following in the section you choose for an nvidia card to work with optimus:

    rplacd/optimus.md

    Long story short I'm an idiot and the things I didn't know that I didn't know caused the problems I spent hours trying to fix through trial and error smh, total rookie mistake

    Now that the proof of concept stage is Over I have to build a proper cooling solution
     
  9. sasuke256

    sasuke256 Notebook Deity

    Reputations:
    495
    Messages:
    1,439
    Likes Received:
    446
    Trophy Points:
    101
    Step by step.. but a HP Zbook with a 1070, that's not gonna be easy to cool..
    Can you post pics of the machine ? Thanks !
     
  10. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    479
    Likes Received:
    199
    Trophy Points:
    56
    I have pictures but it was in an embarrassingly janky state as I worked on proof of concept(getting drivers and games etc working)

    I will post the pictures when I am done
     
Loading...

Share This Page