Need a hand improving overall performance.

Discussion in 'Alienware 17 and M17x' started by lancegaydon, Dec 13, 2013.

Thread Status:
Not open for further replies.
  1. lancegaydon

    lancegaydon Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    First off I am a self admitted noob when it comes to tweaking a PC for games so go easy on me!

    I just got my Alienware 17 a few days ago with the following:
    - Windows 7 64bit
    - 16 GB RAM
    - 750GB 6bg/s
    - Nvidia GTX 770m 3GB (driver 9.18.13.3182)
    - i7 4700MQ @2.40ghz
    -Benq GW2750

    So far I have been trying to play BF4 and Planetside 2 and no matter what I seem to do the performance is really bad. I just notice a choppyness to everything. I tried them both on low setting and it doesn't improve. I have set the .exe's to run using the High Perfomance GPU in the 3D setting inside the nvidia control panel. I also tried that nvidia experience thing and let it optimize both games for me but still it seems really bad.

    I am wondering if these games are actually running on the intel HD card instead of the nvidia one?

    I did try to play Payday 2 and that game won't even launch. I have read it will not run on the intel HD cards which should be fine since I am telling it to use the nvidia GPU in the nvidia control panel but still no success. Any ideas on this one?

    Any and all suggestions are welcome, thanks in advance.
     
    reborn2003 likes this.
  2. Voltran

    Voltran Notebook Geek

    Reputations:
    15
    Messages:
    90
    Likes Received:
    6
    Trophy Points:
    16
    Are you playing on battery? If so the terrible performance is normal.

    Open the NVIDIA control panel, there's a tab to that allows to to specify which GPU to use for which application, use it.

    If that still doesn't work, press fn+F5 and restart in dGPU mode only, see if that improves your performance. If it does, it confirms that you've been using the iGPU instead of the dGPU. Time to reinstall drivers.
     
  3. J.Dre

    J.Dre Notebook Nobel Laureate

    Reputations:
    3,700
    Messages:
    8,316
    Likes Received:
    3,819
    Trophy Points:
    431
    Sounds like Optimus is holding you back. According to NVIDIA's site: "Optimus technology is completely automatic allowing you to experience longer battery life and amazing visuals without having to manually change settings." What this really means is, "We're purposely giving you a hard time and sacrificing performance with our green thumb."

    I'm willing to bet if you update your drivers, disable Optimus, and let the laptop breathe (vents below), you'll notice an improvement in performance.
     
  4. bigtonyman

    bigtonyman Desktop Powa!!!

    Reputations:
    2,371
    Messages:
    5,023
    Likes Received:
    253
    Trophy Points:
    251
    optimus is over 100% more optimized than it used to be, and for the average consumer its probably better that it automatically switches. That being said, I personally prefer manual graphics switching as its easier when problems like this occur. OP do you have your graphics card drivers updated? Just a thought. :)
     
    Robbo99999 likes this.
  5. Robbo99999

    Robbo99999 Notebook Prophet

    Reputations:
    4,070
    Messages:
    6,632
    Likes Received:
    5,758
    Trophy Points:
    681
    I'd check your GPU temperatures, and make sure it's running at the clocks it's supposed to, and also to check the GPU temperatures (if it's getting too hot it will throttle & drop the clocks). You can use GPUz for this, and it will also show you if your games are using your GPU for your games: you can find all this out by looking at the 'Sensor Graphs' in GPUz. It's a free program to download, here's the link:

    Downloads | techPowerUp
     
    bigtonyman likes this.
  6. bigtonyman

    bigtonyman Desktop Powa!!!

    Reputations:
    2,371
    Messages:
    5,023
    Likes Received:
    253
    Trophy Points:
    251
    good point. I should have thought of that. Cons of being tired :p
     
  7. lancegaydon

    lancegaydon Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    6
    Apologies for taking so long to reply but I was away for the weekend.

    First thing I tried was the function F5 tip that Voltran gave. After restarting I had to reinstall the nvidia drivers then restart again. Everything is working perfectly now! Even that issue I described with Payday 2 has been fixed. I guess this means everything was initially running on the Intel gpu.

    Thanks everyone for the help!
     
  8. bigtonyman

    bigtonyman Desktop Powa!!!

    Reputations:
    2,371
    Messages:
    5,023
    Likes Received:
    253
    Trophy Points:
    251
    Glad you got it all taken care of man!! Now go frag some noobs!! :D
     
  9. Alienware-L_Porras

    Alienware-L_Porras Company Representative

    Reputations:
    3,658
    Messages:
    6,874
    Likes Received:
    969
    Trophy Points:
    281
    Great! I'm glad you got it sorted out with that. It was obviously the Intel GPU the one that was running the games :p
     
Loading...
Thread Status:
Not open for further replies.

Share This Page