Nahimic 3 on "unsupported systems"

Discussion in 'MSI' started by asm1, Sep 7, 2018.

  1. asm1

    asm1 Notebook Consultant

    Reputations:
    110
    Messages:
    274
    Likes Received:
    152
    Trophy Points:
    56
    Not taking credit for this, but heres how I manage to run Nahimic 3 on a 7th Gen MSI GE63 7RD laptop, after Nahimic absurdly withdrawing support claiming "M$ store makes it too complicated!" one one one1!

    As usual caveat emptor :mad: your mileage may vary, be prepared for it "not to work" as expected/properly/at all.

    1) uninstall all previous versions of nahimic/realtec audio control panel. Preferably using something like Revo uninstaller to get rid of as much as possible.

    On 7th Gen

    2) Get MSI version of drivers here : 8496 UAD WHQL Nahimic 1140

    3) If it DOES work, profit! Go get Realtek audio control panel and nahimic 3 form the Store. You did restart between uninstalling and reinstalling didn't you ?

    4) Cry /Swear, curse me out when it doesn't work.
    If your machine has an 8th gen version, try grabbing the latest driver from THAT page.


    5) Test - If everything is hunky dory, you can either sit on 8.496 from MSI or try updating the driver from here : Latest Realtek High Definition Audio Codecs

    There are instructions on how to install from .cab files at that link.

    I picked the smaller of the two downloads frrom the microsoft catalog... I think the larger one is the full suite.

    Because you already have Nahimic etc from the M$ store, and are just updating the driver, it *should* still work.


    On 6th Gen and earlier

    1) Try above

    2) Read this :

    https://nahimic.helprace.com/i550-u...rmed-working-on-older-and-unsupported-devices

    3) You may be able to modify the driver inf files to include the string for your particular audio chip, this does not apply to me so have not tested yet, but there are people who have, Google is your friend.

    Being that this is M$/MSI/Nahimic, any one of the 3 could break at any time. it did for me - I couldn't get beyond the 8496 driver above from MSI. It may be that they release another 8.5.xx branch driver that DOES work, but in the meantime use the cab /kludge to get around it.

    As/when I find a newer MSI driver that works I will update here. PIC shows my successful upgrade to from 8496 above, to 8509 from microsoft.cab repository. I have just upgraded again to 8522 and my sound is still working (so far!)

    Hope this helps
     

    Attached Files:

    Last edited: Sep 7, 2018
    Mr. Fox likes this.
  2. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    24,262
    Messages:
    32,863
    Likes Received:
    47,462
    Trophy Points:
    931
    Nice post. May help some MSI owners that have been adversely affected by the lackluster MSI/Nahimic /Windows 10 support. I think the idea of using Micro$lop Store or the Update Catalog to provide any kind of support is about as intelligent as urinating into a strong headwind... a very half-a$$ed approach and a pretty lousy deal for any notebook OEM to go there. Saying using Micro$loth Store is too complicated is just a lame cop-out. They never should have even considered that as an option in the first place.
     
    asm1 likes this.
  3. hacktrix2006

    hacktrix2006 Notebook Evangelist

    Reputations:
    216
    Messages:
    626
    Likes Received:
    386
    Trophy Points:
    76
    I have been Driver modding Realtek Drivers for Nahimic 3 since it came out. I run the 6th series GT72 and currently running Driver Version 8504.

    However i do agree with Mr Fox on this, the whole Microsoft seeking to control every aspect of the driver now is stupid, it also totally half arsed as well. Having to have a internet connection to get a Sound Application because it has to be UWP and in the store is retard.

    If people are struggling to get Nahimic working let me know will have a look and will test.
     
    asm1 and Mr. Fox like this.
  4. Mr. Fox

    Mr. Fox Undefiled BGA-Hating Elitist

    Reputations:
    24,262
    Messages:
    32,863
    Likes Received:
    47,462
    Trophy Points:
    931
    I would even go as far as to say it is totally vile and evil. This kind of nonsense is absolutely inexcusable.
     
  5. hacktrix2006

    hacktrix2006 Notebook Evangelist

    Reputations:
    216
    Messages:
    626
    Likes Received:
    386
    Trophy Points:
    76
    @Mr. Fox Microsoft are bullies thats for sure! Evil and Vile is also second nature to them.
    Just a shame that the Digital Certs are dam expensive to correct the issues Between MSI Microsoft and Nvidgreeda its been a nightmare.
     
    asm1 and Mr. Fox like this.
  6. asm1

    asm1 Notebook Consultant

    Reputations:
    110
    Messages:
    274
    Likes Received:
    152
    Trophy Points:
    56
    Thanks, I'm just trying to consolidate some of the info I had found as it is a bit scattered. Completely agree, not impressed with Avoloute (Nahimic) for lazy support and copping out to M$. Irony they blame M$ for it not being complatible but M$ actually provide signed, compatible and (mostly) working drivers from Realtek(!)

    Support from "Windows Store" is totally idiotic.. shame on MSI for getting involved with such mince.
     
    Mr. Fox likes this.
  7. hacktrix2006

    hacktrix2006 Notebook Evangelist

    Reputations:
    216
    Messages:
    626
    Likes Received:
    386
    Trophy Points:
    76
    There is a new UWP Nahimic 3 version 1.2.2 downloading the update now and will be testing it.
    Although Avoloute is blaming Microsoft for the Driver issue saying that older systems do not support UAD due to compatibility issues and system stability issues, also that Microsoft will not allow them to add Legacy drivers for it either seems abit fishy to me. I for one know that Linux is basically a UAD driver for realtek soundcards, it just looks up the codec the sound card is using then applies it, heck i am using UAD drivers right now and all i had to do was edit 3 files which were :-

    HDXMSI.inf
    AVolouteNH3Ext.inf
    HDX_MsiExt_AVO_RTK.inf

    All i did was copy one of the lines for the 899 Codec and replaced the SUBSYS with mine which 1180 or in the case of AVolouteNH3Ext.inf i added a line out right but changed the Codec and SubVendor sections.

    Notice i didn't mention Realteks inf file HDXRT.inf as i didn't need to edit that file one bit.

    So make what you will of that to whom should really cop the blame, but i can give you a clue, Its the Client to AVoloute whom happens to be an OEM/ODM.

    Edit: Nahimic Version 1.2.2 works after updating and rebooting the system.

    Edit 2: OP you might want to place this in the OP bud its a link to Github with all OEM Realtek Drivers https://github.com/CHEF-KOCH/GamingTweaks/releases
     
    Last edited: Sep 12, 2018
  8. LeftEyeNine

    LeftEyeNine Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    Hey guys, I registered on the forums just to appreciate the effort and look for answers to my problem.

    Preface: I own an MSI GS60 6QE 4K Ghost Pro which has a 6th gen Intel processor.

    I did what has been told in OP for 7th gens and when I ran Nahimic (which came installed with the driver package, not seperately via M$ Store) it said my system was not supported.

    So I saw I had to go the longer mile which was editing the aforementioned .INI files by copying a 899 codec line pasting it right beneath it and substitute 1462XXXX part with 14621158 as my device ID showed up like that in Dxdiag:

    [​IMG]

    After uninstalling currently installed drivers via Revo Uninstaller and taking a restart, when I wanted to install the edited drivers, I got the error:

    Install Realted Audio HD driver failure!!
    [Error Code: 0xE000024B]​

    I cannot get past this point and would like to know if I was doing anything wrong or whether there were any of you who had success owning a 6th gen processor.

    Thank you.
     
  9. hacktrix2006

    hacktrix2006 Notebook Evangelist

    Reputations:
    216
    Messages:
    626
    Likes Received:
    386
    Trophy Points:
    76
    @LeftEyeNine I managed to do mine, however i will cook you a modded inf. Just make sure you disable Driver Enforcer when you go to install.


    Edit: Download the zip attached and follow the info in the text file.
     

    Attached Files:

    Last edited: Sep 14, 2018
    LeftEyeNine likes this.
  10. LeftEyeNine

    LeftEyeNine Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5

    Apparently I missed the "driver enforcer disabling" part since nobody ever mentioned that in pages I've seen. Done that and the driver package installed without a hitch. Thank you very much for your time.

    Now, next up is why Nahimic force closes after showing up with a "loading..." screen. What is next, do you have any ideas?
     
Loading...

Share This Page