1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

my notebooks HOT!!

Discussion in 'Linux Compatibility and Software' started by arjunned, Jul 14, 2008.

Thread Status:
Not open for further replies.
  1. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    ok.. i've noticed over the past week that my notebook runs really hot..
    the cpu temp's are at abt 68 with lite usage like web surfing, and 65 while idling. the palm rest's are pretty warm but the bottom of the notebook's like an oven!!! the gpu temps fluctuate between 70 and 72 while idling and lite usage.

    these are temps are a bit too high as, while running vista, i never get temp's this high when idling, or even even surfing..:confused:

    is something wrong?? i'm pretty sure the fans are doing their job. are these temp's normal or should i be worried?:(
     
  2. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    the GPU is ok...but the CPU temps seem high. I run about 55C on the Desktop CPU in this laptop......might wanna google that. I assume you've check your services to see what is running. Any indexing going on?

    EDIT: I just noticed we have the same Video Card. CPU is high though, this one is a Desktop CPU and it doesn't get that hot. I get from 68 to 72 on my GPU....using Mandriva KDE
     
  3. redrubberpenguin

    redrubberpenguin Notebook Consultant

    Reputations:
    15
    Messages:
    262
    Likes Received:
    0
    Trophy Points:
    30
    That's rather high. My CPU idles at about 40-45 C and hits 60 at load maximum (in rare cases, too). AND my notebook has a smaller form factor than yours. Did you just get this notebook? You might want to ask for a replacement if you did.
     
  4. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    no, no idexing going on. but is there a way to check whether indexing is on? i've had this notebook for abt 6 months now. dont get these high cpu temp's in vista. :(

    anythin else i can chk?

    EDIT: ok i think it has something to do with power management. can anyone help me with cpu frequency scaling? i think the cpu's running high even when its idling.
     
  5. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    I think it's a setting somewhere....you have CPU set to DYNAMIC right in power management?
     
  6. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    is that in the bios?
     
  7. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    No, go into a terminal and type

    gksu gnome-power-manager

    then look at the settings and make sure dynamic is selected. Also, look in services and make sure the cpu-freq module is loading I think....not in gnome now
     
  8. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    ok i typed in the code but nothing's happening. also wen i add the cpu frquency scaling monitor applet to the panel it says that frequency scaling is not supported?!?!!?!
     
  9. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    yeah, it's something with CPU scaling/power management....shouldn't be difficult to correct....someone using gnome needs to step in here........knock knock? :D I would say go to synaptic package manager and search the following: gnome-power-manager, and cpu-freq. See if they are installed, if so, I'd mark them to reinstall and reboot then go into gnome power manager....I just can't look at what you're looking at now. But that won't hurt anything for sure.
     
  10. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    I just installed Ksensors, then rebooted....at first it showed my CPU at 67 degrees! but after a while it dropped down to 55C which is normal for this CPU. Have you given it time to adjust?
     
  11. amidond

    amidond Notebook Evangelist

    Reputations:
    17
    Messages:
    321
    Likes Received:
    2
    Trophy Points:
    31
    type this in terminal gconf-editor &

    Then navigate to gnome-powermangement under apps. Then you will see the option to change the CPU frequncy. My laptop was running pretty hot under perfomance and now I have changed it to ondemand.

    This is in Ubuntu.
     
  12. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    @amidond:
    i changed the cpufreq to ondemand.. but i still dont see a difference! notebook still running at same temp's.:(

    now i getting really worried..
     
  13. amidond

    amidond Notebook Evangelist

    Reputations:
    17
    Messages:
    321
    Likes Received:
    2
    Trophy Points:
    31
    Try the Ubuntu forums, I only just installed over the weekend so I don't know very much about Linux just yet. I do notice that I can get almost 4 hours battery life in Vista and only a little over 2 in Ubuntu.

    I have to do some more research yet. If I find anything I will post it back here.
     
  14. Dire NTropy

    Dire NTropy Notebook Deity

    Reputations:
    297
    Messages:
    720
    Likes Received:
    0
    Trophy Points:
    30
    Are you running any compiz effects? And is laptop-mode enabled?
     
  15. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    ya am running compiz in custom-settings. also laptop-mode is enabled.
     
  16. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    Wait.....don't think laptop-mode should be enabled as it's overridden by power manager I think...check services and see that laptop mode has a status of STOPPED, but checked to start at boot is normal. Sounds like a conflict.

    EDIT: compiz will run it up a little itself, but not that much.
     
  17. blackbird

    blackbird Notebook Deity

    Reputations:
    584
    Messages:
    1,546
    Likes Received:
    0
    Trophy Points:
    55
    setting cpufreq to ondemand wont do jack unless its correctly reading how the frequency ranges your cpu can go up and down (aka proper module for laptop is loaded)

    try these commands as root


    modprobe acpi-cpufreq


    then

    cpufreq-info


    read the output and check if the frequency scaling ranges are correct, typically it should be 1.20 --- your max cpu speed

    if incorrect edit /etc/conf.d/cpufreq as root and try to manually specify the min and max speeds your cpu can go to (for latest core 2 duos min is 1.2GHz and max is your max speed)

    in this file you can also set the governor, set it to ondemand.

    to set frequency governers through terminal just type as root cpufreq-set -g governor name



     
  18. theZoid

    theZoid Notebook Savant

    Reputations:
    1,324
    Messages:
    5,194
    Likes Received:
    2
    Trophy Points:
    206
    I don't understand why he's having a problem in the first place Mint.....
     
  19. blackbird

    blackbird Notebook Deity

    Reputations:
    584
    Messages:
    1,546
    Likes Received:
    0
    Trophy Points:
    55
    cpufrequtils not even installed ?

    botched install ?

    bad iso burn ?

    laptop hardware not properly detected and setup (daemons modules..) ?
     
  20. arjunned

    arjunned Notebook Deity

    Reputations:
    288
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    30
    ok here's wat i got after cpufreq-info...

    Code:
    arjunned@TheDeviantMint-laptop ~ $ sudo cpufreq-info
    cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
    Report errors and bugs to linux@brodo.de, please.
    analyzing CPU 0:
      driver: acpi-cpufreq
      CPUs which need to switch frequency at the same time: 0 1
      hardware limits: 800 MHz - 2.20 GHz
      available frequency steps: 2.20 GHz, 2.20 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
      available cpufreq governors: conservative, ondemand, powersave, userspace, performance
      current policy: frequency should be within 2.20 GHz and 2.20 GHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 2.20 GHz (asserted by call to hardware).
    analyzing CPU 1:
      driver: acpi-cpufreq
      CPUs which need to switch frequency at the same time: 0 1
      hardware limits: 800 MHz - 2.20 GHz
      available frequency steps: 2.20 GHz, 2.20 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
      available cpufreq governors: conservative, ondemand, powersave, userspace, performance
      current policy: frequency should be within 2.20 GHz and 2.20 GHz.
                      The governor "ondemand" may decide which speed to use
                      within this range.
      current CPU frequency is 2.20 GHz (asserted by call to hardware).
    
    the after entering /etc/conf.d/cpufreq as root, it says no file or directory found? wat am i doing wrong? i'm guessing i have to manually specify the min and max speed..
    thanx for being patient so far guys..:eek:
     
Thread Status:
Not open for further replies.

Share This Page