My new laptop has a low net work speed, what is wrong?

Discussion in 'Networking and Wireless' started by ztykid, Oct 5, 2017.

  1. ztykid

    ztykid Notebook Enthusiast

    Reputations:
    0
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    I just received the aorus x5 v7. Everything is fine except the net work. I use an Ethernet cable. With my old alienware (with a Killer1535), I can get over 500 mbps in net speed test and around 40MB/s when downloading games. However, with aorus (also a Killer1535), I can only get 20 mbps and 2.5MB/s. What is wrong?
     
  2. XiCynx

    XiCynx Notebook Guru

    Reputations:
    70
    Messages:
    67
    Likes Received:
    58
    Trophy Points:
    26
    Check to see if you have the Qualcomm Killer Network Suite installed, if so, then check to see if you have the Realtek WLAN Drivers installed as well. If both of these are installed it could be conflicting things. I would suggest to uninstall the Qualcomm Killer Network Suite, then uninstall the Realtek WLAN Drivers. Reboot the laptop and only reinstall the Qualcomm Killer Network Suite and see if that helps anything out. Remember to have the drivers downloaded prior to uninstall do you don't have to use another machine to download them.
     
    Last edited: Oct 7, 2017
    Vasudev likes this.
  3. XiCynx

    XiCynx Notebook Guru

    Reputations:
    70
    Messages:
    67
    Likes Received:
    58
    Trophy Points:
    26
    @ztykid Just tagging you in case you haven't seen this yet.
     
Loading...

Share This Page