Must-Read: SetFSB O/C Game Problems FIXED

Discussion in 'Gaming (Software and Graphics Cards)' started by Disgustipated, Apr 13, 2011.

Thread Status:
Not open for further replies.
  1. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    TO ANYONE THAT USES SETFSB FOR GAMING LAPTOP OVERCLOCKING

    and that's a lot of us

    I recently discovered a problem with SetFSB causing 'timing issues' in games when overclocking. After a certain point, it becomes very noticeable that your games are out of sync; ever run an older game without a frame limiter and had it go in 'turbo mode'? Well, this is the same thing: even modern games can run 'too fast.' When overclocking my core i5, my character in Crysis would be running 50% faster! This is highly undesirable, and I have been searching for a fix for a week or so now. Apparently the issue hasn't been discussed much, but someone unexpectedly graced me with a solution!

    Thanks to Unclewebb, the awesome, highly knowledgeable developer of the (IMHO) must-have overclocking utility 'ThrottleStop' (ESPECIALLY necessary for those of us with Core i 3/5/7 series CPU's in our laptops!!), I have found a solution for the game timing problems. Please read this post that he replied to me with, explaining the Why's and How's of it all:


    Again, huge thanks to Unclewebb for figuring this out and taking the time to reply to me.

    I am now running a constant 3.1 Ghz overclock while gaming, and my games are perfectly 'timed/syncd.' Awesome!

    Also, if you want to achieve maximum Turbo Boost under load or push your laptop's performance to the max, ThrottleStop is a must-have.

    For reference and context, please refer to this thread:

    http://forum.notebookreview.com/asu.../568525-setfsb-game-timing-problem-g60jx.html
     
    Jonxx likes this.
  2. Kingpinzero

    Kingpinzero ROUND ONE,FIGHT! You Win!

    Reputations:
    1,439
    Messages:
    2,332
    Likes Received:
    5
    Trophy Points:
    55
    I guess this helps those with an extreme cpu oced under windows after it has booted to desktop as well?
    I have to check it out.
     
  3. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    You only have this problem when using SetFSB or a similar program that changes the bus clock speed. When you overclock an Extreme processor like the X9000 by changing the multiplier, it doesn't screw up the internal clocks so everything should be OK. You can run the WinTimerTester program, links above, for about a minute to make sure that your clocks are in sync.
     
  4. Bearclaw

    Bearclaw Steaming

    Reputations:
    463
    Messages:
    1,617
    Likes Received:
    6
    Trophy Points:
    56
    A note for some people with dual HDD:

    if you have a separate boot manager (linux, mac etc) you will need to either take out that hard drive and then do this, or just use a bcd editor.
     
  5. Kingpinzero

    Kingpinzero ROUND ONE,FIGHT! You Win!

    Reputations:
    1,439
    Messages:
    2,332
    Likes Received:
    5
    Trophy Points:
    55
    Thought this can help as an added info.
    As you can see i own an X9000 on my xps m1730. First is oced to 3,4ghz thru bios as dell have a setting for it, then its oced to 3,8ghz using your little gem,TS.

    Now i ran the utility for 60-100 seconds and it wasnt really linked 1000:1, it was constantly little less, like 0.987. After the command line edit it reaced 1000:1 after 20 seconds and stays there all the time, so effectively this edit does something on xtreme cpus as well, at least on my side.
    Now im aware that 0.987 and 1000 are nearly the same thing, but since the edit made instantanely difference, it may be worth to add it as well as a "side effect".
     
  6. Disgustipated

    Disgustipated Notebook Consultant

    Reputations:
    74
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    30
    Bumping this so others can see it
     
  7. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    Kingpinzero: When I originally discovered this issue, I didn't get a lot of feedback so I appreciate your testing. Most desktop owners do the majority of their overclocking in the bios so this was not really an issue for them.

    In theory, when Windows first boots up, it is supposed to sync these timers so they both run at the same rate. I'm not sure why your laptop does what it does.

    I originally did some testing on a desktop QX9650 which has an adjustable multiplier. Changing the multiplier didn't have any affect on the timers so they continued to run in sync at 1.0000 : 1 like they are supposed to.
     
  8. Kingpinzero

    Kingpinzero ROUND ONE,FIGHT! You Win!

    Reputations:
    1,439
    Messages:
    2,332
    Likes Received:
    5
    Trophy Points:
    55
    Thanks to you for your awesome support.
    If i get time to spare ill double check my m860tu with the x9100 as well.
     
  9. nX3NTY

    nX3NTY Notebook Consultant

    Reputations:
    8
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    30
    Dufus posting something similar few months back, here is the link to his post, he even made a program to check whether you running on HPET or not
     
  10. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,989
    Messages:
    5,757
    Likes Received:
    4,704
    Trophy Points:
    431
    Dufus is the one that originally told me about this fix so I wrote WinTimerTester to test for this issue. :)

    I couldn't remember his name here on Notebook Review to give him credit. He goes by the name somebody on XtremeSystems and he has also helped me with many of ThrottleStop's important features.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page