MSI UMA/Discrete GPU mode select

Discussion in 'MSI' started by Trailryder, Jan 29, 2020.

  1. Trailryder

    Trailryder Notebook Guru

    Reputations:
    5
    Messages:
    72
    Likes Received:
    8
    Trophy Points:
    16
    MSI GE65 Raider GTX1660Ti

    Is mode selection done automatically by the machine or is it something I have control over? All the owners manual says is when the lighted power button is white it's in UMA onboard graphics mode. When it's glowing amber it's in Discrete GPU mode(GTX1660Ti).

    There's no option in the bios to turn off the onboard nor any way to select between the two.

    I noticed today it was glowing white. WTF? For an unrelated reason, I closed the screen like you would to put the unit to sleep. When I opened it again and it awoke, the light was amber and stayed that way. As a test, I put it to sleep a few more times and raised the screen again to awaken it and it always awoke with an amber light.

    I restart the computer and after log-in the light is white. I just noticed while typing this it flickers between white and amber sometimes. Close the screen, wait several seconds, open it again and this time it's staying white.

    Is there any way to tell, beside the light, what graphics are being used?

    What's going on?

    Can I disable the the onboard in Device Manager to have the machine run in Discrete GPU mode all the time?
     
    Last edited: Jan 29, 2020
  2. Krzyslaw

    Krzyslaw Notebook Consultant

    Reputations:
    36
    Messages:
    131
    Likes Received:
    102
    Trophy Points:
    56
    Your system is Nvidia Optimus based so gpus are auto switching.
    Changing gpu mode in bios (yes the option is there) would leave you with permanent black screen as your screen is tied to Intel gpu.
    And disabling Intel gpu in service manager would leave you with huge performance lose
     
    hmscott and Trailryder like this.
  3. Support.1@XOTIC PC

    Support.1@XOTIC PC Company Representative

    Reputations:
    203
    Messages:
    4,355
    Likes Received:
    1,099
    Trophy Points:
    231
    You can try doing things, like in the Nvidia control panel to set the system to use the Nvidia card most often. Or set the power management options to more performance based options.
     
  4. Trailryder

    Trailryder Notebook Guru

    Reputations:
    5
    Messages:
    72
    Likes Received:
    8
    Trophy Points:
    16
    In the windows power plan, the Intel graphics is set to Balanced on Battery and Max Performance on AC.

    I use my laptop primarily on AC. Would I put the "on AC" plan on a lower setting like balanced to get the dedicated Nvidia to be used more?
     
  5. Trailryder

    Trailryder Notebook Guru

    Reputations:
    5
    Messages:
    72
    Likes Received:
    8
    Trophy Points:
    16
    Thanks for that info. Not used to the technology, as I've been running an old dell vostro before this and my 5 year old desktop PC doesn't do this either.
     
  6. Trailryder

    Trailryder Notebook Guru

    Reputations:
    5
    Messages:
    72
    Likes Received:
    8
    Trophy Points:
    16
    There's an Intel VT enable/disable setting but nothing in the bios for either graphics other than that. This is the most rudimentary bios of any computer I've seen, especially for a UEFI bios. And especially for a gaming computer. I'd have thought the bios on this thing would have given even a seasoned gamer a run for their money.
     
    tiliarou and Kevin@GenTechPC like this.
  7. Krzyslaw

    Krzyslaw Notebook Consultant

    Reputations:
    36
    Messages:
    131
    Likes Received:
    102
    Trophy Points:
    56
    look for the bios key combo for msi laptops
     
Loading...

Share This Page