MSI Titan GT80 SLI lost all wifi connectivity

Discussion in 'MSI' started by etcetera, Oct 24, 2019.

  1. etcetera

    etcetera Notebook Evangelist

    Reputations:
    40
    Messages:
    540
    Likes Received:
    158
    Trophy Points:
    56
  2. senso

    senso Notebook Deity

    Reputations:
    260
    Messages:
    782
    Likes Received:
    201
    Trophy Points:
    76
    Your WiFi card is not being detected, so try re-seating it, or its dead.
     
  3. etcetera

    etcetera Notebook Evangelist

    Reputations:
    40
    Messages:
    540
    Likes Received:
    158
    Trophy Points:
    56
    I will try that.

    The card is Killer 1535.

    Is there a better card to upgrade to?
     
  4. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    969
    Messages:
    8,242
    Likes Received:
    2,010
    Trophy Points:
    331
    You can switch to Intel 9260.
     
  5. etcetera

    etcetera Notebook Evangelist

    Reputations:
    40
    Messages:
    540
    Likes Received:
    158
    Trophy Points:
    56
    Is that a better, faster card?
     
  6. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    969
    Messages:
    8,242
    Likes Received:
    2,010
    Trophy Points:
    331
  7. etcetera

    etcetera Notebook Evangelist

    Reputations:
    40
    Messages:
    540
    Likes Received:
    158
    Trophy Points:
    56
    My wifi came back, mysteriously. I didn't make any changes.
     
    Kevin@GenTechPC likes this.
  8. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    969
    Messages:
    8,242
    Likes Received:
    2,010
    Trophy Points:
    331
    Okay, if problem comes back (*knock on wood*) but hope not, and if you do decide to switch then you know which one to get now. :)
     
  9. etcetera

    etcetera Notebook Evangelist

    Reputations:
    40
    Messages:
    540
    Likes Received:
    158
    Trophy Points:
    56
    Still working today. I wonder what triggered it. I've had ongoing issues with the wifi, especially after the 1803 update last year when Windows got upgraded. It somehow never upgraded the drivers with it. Had to manually install them.
     
Loading...

Share This Page