MSI GT75 TITAN Drivers (8th gen)

Discussion in 'MSI' started by Ultra Male, Jan 20, 2017.

  1. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    18,822
    Messages:
    19,542
    Likes Received:
    27,821
    Trophy Points:
    931
    0 issues here, nothing in Event log even like before.

    did you make sure to unblock the ZIP file before extracting it by right clicking on it > Properties > Unblock from the bottom right since you now don't have the Ultra Male tweaked OS? If you don't unblock a file then it might not install properly.
     
  2. Wild Turkey

    Wild Turkey Notebook Consultant

    Reputations:
    62
    Messages:
    130
    Likes Received:
    64
    Trophy Points:
    41

    Ill try reinstalling he wifi, that seems to be what that error is linked to.
     
    Ultra Male likes this.
  3. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    6,809
    Messages:
    5,299
    Likes Received:
    7,227
    Trophy Points:
    681
    Ignore that error. I have no idea what that is. I get it also. It's something to do with some embedded controller option. From what little I could find, it's something related to some "Radio switch" thing.
     
  4. Wild Turkey

    Wild Turkey Notebook Consultant

    Reputations:
    62
    Messages:
    130
    Likes Received:
    64
    Trophy Points:
    41

    Aquantia AQtion 10Gbit Network Adapter : Network link is lost.

    On every reboot, hell there is not even a Cat6 connected. I am using WiFi...
     
    Ultra Male likes this.
  5. Wild Turkey

    Wild Turkey Notebook Consultant

    Reputations:
    62
    Messages:
    130
    Likes Received:
    64
    Trophy Points:
    41
    I already "fixed" that through Group Policy.
     
  6. JeanLegi

    JeanLegi Notebook Evangelist

    Reputations:
    278
    Messages:
    392
    Likes Received:
    356
    Trophy Points:
    76
    I have no before test. i still have warnings of the connection lost after booting and i think that is not a driver related issue i have several other failure and warnings but i'm to lazy to spent my time for more troubleshooting for things which making no trouble.
    my taptop is running fine and all games are playable :cool:

    I have 100Mbps download and 40 Mbps upload..

    Speedtest.jpg
     
    Last edited: Jan 3, 2019
  7. Wild Turkey

    Wild Turkey Notebook Consultant

    Reputations:
    62
    Messages:
    130
    Likes Received:
    64
    Trophy Points:
    41
    Speedtest.jpg Yeah, I have wiped this laptop 3 times and the WLAN error is there on a FRESH 1809 install...lol

    !@#$
     
    Last edited: Jan 3, 2019
  8. JeanLegi

    JeanLegi Notebook Evangelist

    Reputations:
    278
    Messages:
    392
    Likes Received:
    356
    Trophy Points:
    76
    Damn it i get even more failure reports :D WTF i have done? Nothing so far.
     
    Papusan likes this.
  9. AU4U

    AU4U Notebook Evangelist

    Reputations:
    83
    Messages:
    367
    Likes Received:
    38
    Trophy Points:
    41
    Last edited: Jan 5, 2019
  10. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    18,822
    Messages:
    19,542
    Likes Received:
    27,821
    Trophy Points:
    931
    Intel Thunderbolt Driver 1.0.2.26 added to the OP with instructions on how to update the driver
     
Loading...

Share This Page