MSI GS70 6QE Stealh Pro - headphone jack not working, two sound devices for top and bottom speakers

Discussion in 'MSI' started by ColinMacLaren, Sep 10, 2019 at 5:08 AM.

  1. ColinMacLaren

    ColinMacLaren Notebook Enthusiast

    Reputations:
    5
    Messages:
    36
    Likes Received:
    5
    Trophy Points:
    16
    Hello,

    I have a really weird issue with my MS GS70 2QE Steatlh Pro.

    The notebook has three sound jacks.
    [​IMG]


    Headphones (left) - LineIn (center) - MicIn (right)

    The notebook has two top speakers under the lid and a speaker on the bottom left.

    [​IMG]


    I have Windows 10 1903, latest bios, EC firmware and Sound drivers form the MSI support page.
    https://de.msi.com/Laptop/support/GS70-6QE-Stealth-Pro#down-driver&Win10 64

    With no external device connected I have one Realtek sound device in the Windows device manager.
    Windows recognizes this as quadraphonic speakers (4.0). Sound is only been played for the front left and front right speaker utilizing the two top speakers under the lid.

    If I plug my headphones into the headphone jack, nothing happens. Sound is still only been played from the two top speakers.

    Nahimic does nothing. The sound effects are not being used, no matter if I enable or disable them.

    Realtek GUI only shows the LineIn and MicIn connector, but does not recognize the headphone jack.

    When I plug a Mic into the LineIn or the MicIn, something really weird occurs.
    Not I have two Realtek audio devices in Windows sound dialogue. Now both are only recognized as stereo devices
    One is showing a speaker symbol and still playing sound from only the top speakers under the lid.
    One is showing a headphone symbol in Windows sound dialogue, but playing sound from the bottom speaker!

    It should probably work like this:
    With no headphones connected, combine the top and bottom speaker to a (pseudo) quadraphonic device. Add some effects with Nahimic.
    Recognize the headphones when they are plugged in, disabling internal speakers and switching to a stereo device.

    How do I fix this? your help is appreciated.
     
  2. hacktrix2006

    hacktrix2006 Hold My Vodka, I going to kill my GPU

    Reputations:
    305
    Messages:
    1,029
    Likes Received:
    603
    Trophy Points:
    131
    Try the driver that's in my signature. See if that helps.

    Sent from my SNE-LX1 using Tapatalk
     
    Kevin@GenTechPC likes this.
  3. ColinMacLaren

    ColinMacLaren Notebook Enthusiast

    Reputations:
    5
    Messages:
    36
    Likes Received:
    5
    Trophy Points:
    16
    Thanks, I was going to try them today after work. My notebook is not on the supported devices list, though-
     
  4. hacktrix2006

    hacktrix2006 Hold My Vodka, I going to kill my GPU

    Reputations:
    305
    Messages:
    1,029
    Likes Received:
    603
    Trophy Points:
    131
    Just because it's not on the list doesn't mean it's not supported, just means it's not been tested.

    It should work without issue and you get to use Nahimic 3 instead of Nahimic 2+ follow the instructions and you should be fine just uninstall the drivers and Nahimic 2+ then reboot before using my mod.

    Sent from my SNE-LX1 using Tapatalk
     
  5. ColinMacLaren

    ColinMacLaren Notebook Enthusiast

    Reputations:
    5
    Messages:
    36
    Likes Received:
    5
    Trophy Points:
    16
    Hello hackrix2006,

    I installed your driver.It improved my experience tremendously.

    - Internal speakers are working in quadophinonic mode and thus sound much better then before!
    - Headphones are working when I select SPDIF out.
    - Naimic is working for both internal speakers and headphones.
    -Old Realtek GUI (RAVCpl64.exe) is working.

    - Realtek Audio Console (UWP app) says "No connection to RPC service".
    edit: C:\WINDOWS\System32\RtkAudUService64.exe -background was disabled in Autostart. Now itis als working.

    Is there any chance to get Soundblaster Connectrunning with your driver?
     
    Last edited: Sep 10, 2019 at 1:16 PM
    Kevin@GenTechPC likes this.
  6. hacktrix2006

    hacktrix2006 Hold My Vodka, I going to kill my GPU

    Reputations:
    305
    Messages:
    1,029
    Likes Received:
    603
    Trophy Points:
    131
    Never tried, did your system have soundblaster audio?

    If not the chance are it will not work due to licensing.

    Also I am in a grey area of legality as it is right now, trying to mod Sound Blaster stuff in will see Creative on my behind quickly.

    Sent from my SNE-LX1 using Tapatalk
     
Loading...
Similar Threads - GS70 Stealh headphone
  1. Yuroshock
    Replies:
    6
    Views:
    553

Share This Page