MSI GS60 2PC Wifi Card disappearing

Discussion in 'MSI' started by atu567, Jan 19, 2017.

Thread Status:
Not open for further replies.
  1. atu567

    atu567 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hey everyone, I am having serious issues with my wifi, and I'm wondering if anyone encountered similar problems as well/could help troubleshoot.

    I have a GS60-2PC that I've had for about a year and a half now. Since the beginning of last August I have had crazy problems with my wifi card completely disappearing after I wake my computer from sleep (when it had wifi prior to being put to sleep) or after I've restarted or turned on my computer. After I wake up my computer, the only Network setting I have is my Killer LAN ethernet, and "scanning for hardware changes" on Device Manager does not change anything.
    Sometimes my wifi card will just disappear as I'm using the computer. For some reason, it starts with Chrome/entire computer freezing, then the Wifi going from "Connected" to "No Internet." If I turn off my wifi from the task bar, it disappears as an option and I can no longer click it to turn it back on.

    This problem started out infrequently, but now it's gotten to the point where no matter how many times I restart, I cannot get my computer to detect the wifi card. I had a Intel N-7260, but thinking that the problem was the wifi card, I purchased a N-7265 from online and installed it myself. The problems were better at first, but nonetheless they've come back and still persist.

    It seems like I'm not the only one who's encountered this issue: https://forum-en.msi.com/index.php?topic=265366.0

    However, I've tried all their fixes and none of them work. I'm a college student too, so an RMA isn't the most ideal situation (last one took a month and a half). Is there anyone who could help out?
     
  2. ichangedmyname

    ichangedmyname Notebook Consultant

    Reputations:
    9
    Messages:
    126
    Likes Received:
    45
    Trophy Points:
    41
    I used to have msi gs70 which had killer wireless card,and same thing happened to me.I posted in notebookreview forum before and we concluded as killer wireless cards beimg garabge, but i guess there is a deeper issue. My wireless card wouldn't show up in device manager all the sudden, usually after sleep. Sometimes it doesn't show up after shutdown too. I never found the solution.

    Here are three things that might help you
    It happened less frequently after downloading newest killer driver (not suite) from their website after formatting
    I opened the laptop, removed wireless card, start the system, shutdown the system and reinstall the wireless card.
    I removed wireless card then turned it on and uninstalled drivers then plugged it in while on and it worked for a while too.

    I think there's a firmware/electrical problem
     
  3. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    978
    Messages:
    8,368
    Likes Received:
    2,052
    Trophy Points:
    331
    This could be a BIOS/EC issue, try updating them to the latest version.
    But if not, then I'd suggest a RMA since it's possibly a mainboard issue.
     
  4. SkidrowSKT

    SkidrowSKT Notebook Deity

    Reputations:
    116
    Messages:
    1,062
    Likes Received:
    599
    Trophy Points:
    131
    Before doing anything, try these options:

    1- Go to device manager > Wireless adapter > Properties > Find where it says "Allow Windows to turn the device off to save power" and make sure it's not ticked.

    2- Power plan settings > select the power plan you use most and go to advanced settings > There should be a wireless adapter block, set it to Maximum Performance > Apply changes and restart computer.

    3- If any of the above doesn't work, try rolling the Wireless adapter driver to older versions, restart and see if it works.

    Sent from my SM-N900 using Tapatalk
     
    Kevin@GenTechPC likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page