MSI GS43VR Phantom Pro's Owner's Lounge

Discussion in 'MSI Reviews & Owners' Lounges' started by MiSJAH, Jul 1, 2016.

  1. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
    Yeah, first of all the "System Idle Process" is most always going to be taking up 99% or so when nothing else is going on, as that's what it is the "System Idle Process" It's not using CPU at 99% - it's just showing the idle % :)

    There shouldn't be anything found by accurate malware software in the vanilla Windows 10 install right off Microsoft media. These are errors of some kind in their detection database - common enough really.

    If you have a "clean install" of Windows from MS media, it's not going to have OEM specific drivers for some things, you need to go to the vendor site to download the latest driver, many from MSI or directly from the part maker - like Intel, Killer, Realtek, etc.

    It's a mess to try to do this yourself, as for one thing, you don't want the Realtek vanilla driver from their site, you want the Nahimic / Realtek pair driver from MSI.

    The Killer drivers are getting frequent bug fix updates since Windows 10 release, as MS keeps changing the OS and the vendors keep updating their drivers to catch up. MSI's version may or may not be as new as available directly from the Killer site.

    This is why it's best to stick with the vendor OS image, build on what they have done, and uninstall the "bloatware" you *know* you don't need - don't just uninstall everything with MSI's name in it :)

    It's a steep learning curve the first time from a "clean install", why put that on yourself just as you are trying to get to know the laptop.

    You wouldn't season unknown food, so don't blindly blow away a new laptops OS build until you get to know it and benchmark it.

    If you do eventually do a "clean install" you will have some data collected on the stock install to prove to yourself it was an improvement or performs worse.

    And, don't forget to make a bootable recovery USB 3.0 Flash drive so you can restore back to the out of the box configuration should the need arise. It's a lot quicker to getting you back to work should you encounter a drive failure or corrupted OS install.
     
    DukeCLR, SirGadden and Prototime like this.
  2. alejo099

    alejo099 Notebook Guru

    Reputations:
    0
    Messages:
    63
    Likes Received:
    29
    Trophy Points:
    26
    For those with microstutters maybe you can try this solution. The GS40 had the same issue and some people had it fixed:

    https://forum-en.msi.com/index.php?topic=270179.0

    By uninstalling the touchpad driver. Hopefully it helps! (Might not since it apparently is the Optimus, but maybe its worth a try).

    I'll be getting mine this weekend. Hopefully it doesn't have the same issue! I've been entered into the lottery! :eek:

    Ordered from Xotic PC and upgraded the SSD where windows comes. Hopefully the clean install they did helped. Fingers crossed!
     
    hmscott and Prototime like this.
  3. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
    That sure is weird :)

    There should be 2 levels of restore, one is light and just resets everything back to defaults, and one is a complete restore from the recovery partition.

    It sounds like maybe you only did the reset and not the restore? Maybe try that other option - be sure and backup your personal stuff to another drive before doing that :)

    You shouldn't need to install from MS media, avoid that if you can. It may stop this problem, but then you have the problem of finding all the drivers and apps to install over the generic drivers MS provides, can be time consuming and take days/weeks before you find everything - or even realize it's missing.

    I would open a ticket with MSI, from your registration account on the MSI support site (register your laptop), and MSI should have a step by step to fix this - lots of people seem to have this problem - but so far you're the first that didn't solve the problem by doing a restore.

    You can also create the MSI Flash Recovery drive, 32GB USB 3.0 drive, that you can then use to restore to another drive, and try that too.

    MSI won't usually RMA a laptop unless you have done a complete recovery restore. Not that you need to worry about RMA, this has been fixed with a full recovery restore :)
     
    SirGadden and Prototime like this.
  4. SirGadden

    SirGadden Notebook Enthusiast

    Reputations:
    5
    Messages:
    30
    Likes Received:
    13
    Trophy Points:
    16
    Appreciate your help, thanks! :)

    I did notice something strange last night, while checking both MSI Dragon Center and Windows task manager at the same time, Windows reported 100% CPU usage while MSI reported less than 5% usage.
    I guess MSI is doing something funky here..?
    Also tried running HWinfo at the same time and even though I set min. CPU to 5% in the Windows energy settings I never saw it go below Turbo speed (3.1GHz) while idling (was in Comfort mode in Dragon Center), MSI trolling yet again?

    Now about that weird fan-like sound, I got both CPU and GPU fan to stand completly still in Eco-mode but that sound was still there and just as load, gonna try remove the HDD tonight. Sounds like it's coming from where the HDD is...
     
    hmscott and Prototime like this.
  5. Prototime

    Prototime Notebook Evangelist

    Reputations:
    140
    Messages:
    572
    Likes Received:
    773
    Trophy Points:
    106
    Definitely weird that task manager and the Dragon Center are reporting such wildly different things. I've noticed that there's sometimes a slight difference between what the two report with respect to CPU usage, but it's usually only 1-2%, and often the two match up completely. I'm excited to hear if any of this might change for you after you swap drives and try a full restore!

    Also I'm curious, do your CPU and GPU fans ever turn completely off when on auto mode? If not, what temps are you usually seeing for them? I've noticed more than one GS43VR owner saying that their fans are always on, but mine rarely turn on when I'm not gaming; at least on my end, the CPU fans only appear to come on once the temp hits 60 C, and they turn off once the CPU hits 50 C again. (And the GPU fans only come on when the GPU is in use.)
     
    Last edited: Sep 16, 2016
    SirGadden and hmscott like this.
  6. SirGadden

    SirGadden Notebook Enthusiast

    Reputations:
    5
    Messages:
    30
    Likes Received:
    13
    Trophy Points:
    16
    YES! :D
    Friday is awesome day it seems, firstly:

    1. The Microstutter is goooooone :D Uninstalled the Elan trackpad drivers as suggested earlier in this thread and it did the trick!

    2. Removed the HDD and that awful sound is gone! :D My GS43 is now completely silent when in Eco mode and not gaming! Maybe I'll pop another SSD in there some day later...

    Yes, both are generally off when in Eco mode, 60 C and 50 C seems to be the threshold tempratures for turning on and off respectively just like you suggested :)

    OMG I LOVE this computer now <3 :D
    Just a fresh install of Win 10 and it's gonna be perfect!

    And here's some friday fun for you all, MSI vs. Microsoft (with Swedish as system language, sorry):
    [​IMG]

    And that SSD speed: <3
    [​IMG]
     
    hmscott and Prototime like this.
  7. whirledpeas

    whirledpeas Notebook Enthusiast

    Reputations:
    7
    Messages:
    35
    Likes Received:
    35
    Trophy Points:
    26
    I figured this out. It turns out that you have to use Nvidia Profile Inspector to set Adaptive V-Sync since this option is not in the Nvidia Control Panel. I also set the FPS cap and Triple buffering along the way to minimize input lag on the laptop's 60Hz screen. These settings are:

    Under Sync and Refresh Section

    Frame Rate Limiter: 61.8fps
    Triple buffering: On
    Vertical Sync: Force On
    Vertical Sync Smooth AFR behavior: On
    Vertical Sync Tear Control: Adaptive

    I also found another interesting thing which will force the laptop's internal screen to use the dGPU on most apps/games and minimize the switching to iGPU and thus reduce stuttering:

    Under Other Section:

    Enable application for Optimus: SHIM_RENDERING_MODE_ENABLE
    Optimus flags for enabled applications: SHIM_MCCOMPAT_ENABLE

    Setting these Optimus related settings also solves another mystery: upon rebooting, Dragon Center will overclock the dGPU (Core +100 MHz and Memory +200 MHz) even on the internal screen, which produces the same behavior as plugging laptop into an external monitor and using it exclusively (effectively disabling Optimus by turning iGPU off and using dGPU to drive everything), a Dragon Center behavior that I discovered previously. So I think Dragon Center overclocks the GPU upon booting if it detects that the dGPU is being used (via HDMI or Mini DP to external screen) or being set to use (via internal screen in this case) exclusively, which is the case now in both scenarios.

    @Prototime , hope this answers your question about the GPU overclocking behavior of Dragon Center. In regards to the CPU, after doing some 3dmark benchmark analysis, now I don't think that Dragon Center will overclock the CPU because CPU-Z and ThrottleStop show no CPU overclocking behavior upon booting in both scenarios mentioned above where dGPU is used exclusively. The physics score increase in 3dmark is most likely due to the fact that the iGPU is inactive in these scenarios and there is no CPU overhead to pass the display signal from the dGPU -> iGPU -> screen (since dGPU drives everything), which gives the CPU more resource to spend on the 3dmark physics test and that leads to the physics score increase.
     
    Last edited: Sep 17, 2016
    hmscott and Prototime like this.
  8. PMF

    PMF Notebook Consultant

    Reputations:
    19
    Messages:
    284
    Likes Received:
    251
    Trophy Points:
    76
    Some interesting info in there, thanks! However, please do note you can't turn off Optimus for the internal screen - the hardware is physically wired such that the dGPU sends the frames to the iGPU, and then to the screen, at least according to all info we've seen thus far. If those settings kill battery life by about 50% at idle, then maybe, somehow, you managed to turn off Optimus.
     
    gbenedetto likes this.
  9. whirledpeas

    whirledpeas Notebook Enthusiast

    Reputations:
    7
    Messages:
    35
    Likes Received:
    35
    Trophy Points:
    26
    Yes, the 2 Optimus settings I mentioned will not turn off Optimus completely when internal screen is used but it will use the dGPU for most apps/games. And it will also overclock the dGPU upon booting by the Dragon Center. The other scenario using external screen via HDMI and Mini DP will turn off Optimus/iGPU and let the dGPU drive the display exclusively.
     
    PMF likes this.
  10. toxotis70

    toxotis70 Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    7
    Trophy Points:
    6
    what do you loose if Uninstall the elan TouchPad driver?

    Sent from my Nexus 6P using Tapatalk
     

Share This Page