most of my usb HDDs does not show up in Safety remove window

Discussion in 'Windows OS and Software' started by NumLock, Jun 3, 2018.

  1. NumLock

    NumLock Notebook Evangelist

    Reputations:
    38
    Messages:
    368
    Likes Received:
    1
    Trophy Points:
    31
    3 out of 4 of my usb hard disk drives does not show any option to eject (when i right click on them in my computer) or appear in the safely remove button.

    I'm on windows 10 with the latest updates up until today. What could be the problem? I've restarted my computer and the same thing happens. is there something i can do?
     
  2. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    497
    Messages:
    3,111
    Likes Received:
    364
    Trophy Points:
    151
    Does it see it as a USB hard drive and what kinda usb hard drive are we talking about?
     
  3. 9ac3

    9ac3 Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    6
    You can shut down the computer and then take it out to be safe.
     
  4. Woodking

    Woodking Notebook Consultant

    Reputations:
    21
    Messages:
    252
    Likes Received:
    90
    Trophy Points:
    41
    Right click on 'Computer' on your Windows 10 desktop - 'Manage' and this will open up 'Computer Management'. Go into 'Disk Management' and select the USB drive (if it is visible in there) and then select that disk number on the left of its description, 1-2-3 or whatever it may be, right click on it and it should have the option to eject it. I have a drive that didn't appear in 'Safely Eject' but it was there in Disk Management.

    Hope this works for ya' :)
     
Loading...

Share This Page