More Windows 10 shenanigans - Anniversary Update - all kernel mode drivers must be signed

Discussion in 'Windows OS and Software' started by Ethrem, Aug 1, 2016.

Thread Status:
Not open for further replies.
  1. ratinox

    ratinox Notebook Deity

    Reputations:
    119
    Messages:
    1,047
    Likes Received:
    516
    Trophy Points:
    131
    I do get the same Steam error 2 with Civ V but it is not Windows 10 1607's fault. Players who haven't installed the update are seeing the same error, especially players who recently purchased the game.

    Gaming Center and other bloatware problems are kernel mode drivers not being properly signed (temporary fix: disable UEFI Secure Boot until permanent solutions come down).

    Telemetry shutoff settings are sticking for me (nb: I'm running with Secure Boot disabled, dunnow if this is relevant).
     
    hmscott likes this.
  2. 3Fees

    3Fees Notebook Deity

    Reputations:
    531
    Messages:
    960
    Likes Received:
    121
    Trophy Points:
    56
    Its called a Windows 10 Feature update,lol it could take about an hour or so do this
    Cumulative Update for Windows 10 Version 1607: August 2, 2016
    Version 1607 (OS Build 14393.10)
     
    hmscott likes this.
  3. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
  4. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
  5. ratinox

    ratinox Notebook Deity

    Reputations:
    119
    Messages:
    1,047
    Likes Received:
    516
    Trophy Points:
    131
    As noted, the Steamworks issues reportedly caused by 1607 are also being experienced by Windows 7 users. They are also being experienced by users who reverted to 1511. Whatever the problem is, Windows 10 AU is not the direct cause.
     
    alexhawker and hmscott like this.
  6. Ethrem

    Ethrem Notebook Prophet

    Reputations:
    1,404
    Messages:
    6,706
    Likes Received:
    4,735
    Trophy Points:
    431
    10 broke my VPN. Also, 10 forced Secure Boot in my UEFI settings at some point. I've never turned that on yet it was enabled.

    So Microsoft lied about upgrades not affecting kernel mode drivers and one of the updates forced Secure Boot on at some point. Yeah I'm over it.

    I'll take care of it today lol. I tend to be anal about those things too I was just tired at that point.
     
    Raiderman, TANWare and hmscott like this.
  7. TANWare

    TANWare Just This Side of Senile, I think. Super Moderator

    Reputations:
    2,537
    Messages:
    9,567
    Likes Received:
    4,977
    Trophy Points:
    431
    I am probably close behind you. I just am not sure Windows 7 is where I want to be. I know I have another 4 years or so but do I really want to give M$ any kind of support? Better yet are they deserving of support? M$ is like an old family member that has become addicted to drugs. No matter how many times they falter and mess you up you want to give them another chance. Are we now enablers?
     
  8. Ethrem

    Ethrem Notebook Prophet

    Reputations:
    1,404
    Messages:
    6,706
    Likes Received:
    4,735
    Trophy Points:
    431
    If I had an actual computer monitor I'd be running Mint 18 for what it's worth. Most of my gaming is on the console these days anyway and if push came to shove I could always enable my onboard graphics and set up a KVM using PCIe pass-through for my 780 Ti to function perfectly in a Windows VM.

    Right now I'm kind of pissed about the LAN speed... The I217-V Intel LAN is running like 36Mbps while my little Broadcom m.2 combo card that doesn't even have an external antenna runs a flat 180Mbps. Obviously there's a driver issue at play but I'm even on the latest Intel drivers for my LAN so I don't know what the problem is. Guess I'll just use WiFi. Need to test this new router out anyway. 8.1 and 10 have perfect 180Mbps LAN speed out of the box. 7 needs a driver and it doesn't work well at all.
     
    hmscott and Starlight5 like this.
  9. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
    Did you try manually setting the link speed, sometimes I have had old Windows 7 drivers stuck at 100mbps, manually setting 1000mbps fixes that.
     
    Ethrem likes this.
  10. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    7,079
    Messages:
    20,412
    Likes Received:
    25,193
    Trophy Points:
    931
    "Now fixed

    Edit: it seems the broken games may be a steamworks issue affecting all versions of Windows and happening at the same time as AU roll-out may be a coincidence. Valve hopes to have a fix out today."

    RESOLVED: Steam Error 2 - Windows 10 Anniversary Update
    https://steamcommunity.com/app/8930/discussions/0/360671352684764658/?ctp=2#c360671352685113103
     
    Last edited: Aug 5, 2016
    Ethrem and inm8#2 like this.
Loading...
Thread Status:
Not open for further replies.

Share This Page