Missing Service in Windows 7 Home Premium

Discussion in 'Windows OS and Software' started by Sammy225, Sep 22, 2010.

Thread Status:
Not open for further replies.
  1. Sammy225

    Sammy225 Notebook Geek

    Reputations:
    19
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    15
    I am missing the following function: "Windows Resource Protection". A "Service" should be available for it which is under "Windows Modules Installer".

    Would anyone know how to recreate the Service? I have a Samsung R580 and there was no install disk that came with it...just a hidden partition to restore the OS. I don't even know if it originally had it or not. I just need that Service.

    I basically want to run the 'sfc /scannow' command at the cmd prompt to check for DLL and other Windows Protected File changes.

    Thanks!

    Dave
     
  2. Sammy225

    Sammy225 Notebook Geek

    Reputations:
    19
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    15
    Update:

    Found a copy of TrustedInstaller.exe in a hidden Windows folder and copied it to the right place. From there, it was a matter of running the Service and bingo! A'OK!

    Got the command running but it didn't fix what I was hoping for!

    Gotta keep on troubleshooting!

    BTW: It was AVAST AV that that thought it was a virus so ripped it out of the 'servicing' folder!
     
  3. newsposter

    newsposter Notebook Virtuoso

    Reputations:
    801
    Messages:
    3,881
    Likes Received:
    0
    Trophy Points:
    105
    Do you have your install of Avast set to automatically force-move suspicious files?

    If so, change the config to 'ask me'.

    Given the number of false-positives thrown by most/all of the anti-virus programs, it's dangerous (silly?) to let any of them work without supervision.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page