]]>

Microlags Fix

Discussion in 'Windows OS and Software' started by Danishblunt, Jan 21, 2018.

  1. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    205
    Messages:
    1,725
    Likes Received:
    651
    Trophy Points:
    131
    Intel:
    NVIDIA:
    Also Nvidia has stated that it has something to do with MSHybrid and some kind of issue. Meanwhile intel trying to fix this bug caused by while being concerned about meltdown and Spectre.

    I wonder why pascal is mostly affected by this and very few maxwell cards. While kepler and such run absolutely fine.
     
  2. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,579
    Messages:
    4,918
    Likes Received:
    2,795
    Trophy Points:
    231
    Yeah exactly like I said in older post, tweaking MS Hybrid profile will force iGPU.
     
  3. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    205
    Messages:
    1,725
    Likes Received:
    651
    Trophy Points:
    131
    It won't work because it still turns on for 0.5 seconds regardless. The fact that most maxwell cards, all kepler and earlier cards are not affected and almost all pascal cards are affected shows that NVIDIA has done something.

    I tried to tinker with MSHyrbid myself, never made it working properly. I reduced the lag a bit but nothing more. Meanwhile friend of mine running newest FCU and GTX 970M doens't have the issue.
     
    Vasudev likes this.
  4. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    205
    Messages:
    1,725
    Likes Received:
    651
    Trophy Points:
    131
    I think this might be some sort of optimus + MSHyrbid conflict and now Intel is trying to supress optimus somehow. Is only my theory, so don't think it's facts.
     
  5. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,579
    Messages:
    4,918
    Likes Received:
    2,795
    Trophy Points:
    231
    Who said Maxwell and old GPUs don't have issues? I have it but I forced iGPU on battery mode otherwise there's momentary stutters. Its good actually Intel is providing a fix that's been unresolved for a year.
    AMD GPU on a notebook doesn't have this issue. I saw issues on nvidia GPUs every time.
     
  6. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,579
    Messages:
    4,918
    Likes Received:
    2,795
    Trophy Points:
    231
    They can't because those profiles are embedded in nvidia driver profiles to switch between IGPU and dGPU.
     
  7. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    205
    Messages:
    1,725
    Likes Received:
    651
    Trophy Points:
    131
    Read more closely. I said most maxwell cards. I've seen very few cases where maxwell cards would have the same issue, never seen any kepler cards tho. There are very few examples of pascal working flawlessly, this only happened for the GTX 1050 series tho.

    Maybe you got any idea what the GTX 1050 does different than the higher models?

    if you go to this thread a guy posted an example of a GTX 1050 notebook that didn't have this issue:
    https://communities.intel.com/thread/119093?start=135&tstart=0
     
    Vasudev likes this.
  8. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,579
    Messages:
    4,918
    Likes Received:
    2,795
    Trophy Points:
    231
    I configured my cousin's HP Omen 15 with 7700HQ and 1050 which stuttered like hell and barely usable. I used DDU to clean them up and tweaked it like the settings provided to you. One more thing I noticed that temp sensor is disabled for GTX 1050 and I was able to read only Core clocks and Memory freq. Afterwards, it worked flawlessly.
     
  9. Danishblunt

    Danishblunt Notebook Deity

    Reputations:
    205
    Messages:
    1,725
    Likes Received:
    651
    Trophy Points:
    131
    What settings did you exacly change. I need it as accurate as possible and see if it does anything for me.
     
  10. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    1,579
    Messages:
    4,918
    Likes Received:
    2,795
    Trophy Points:
    231
    I used intel 4771 driver along with nvidia 381.xx series driver with following settings, do note I haven't changed the MS Hybrid settings because it was missing in that driver and only present when I updated to 388.xx & above.
    • Nvidia shader cache=off
    • physx=cpu
    • power mgmt mode=adaptive
    • In Intel I changed Color range or something to Full Range 0-255
    • Put in Balanced mode on AC and Max battery life on battery mode.
     

Share This Page