MC7700 Sierra Airprime card - Cheap data plan!

Discussion in 'Panasonic' started by Azrial, Mar 14, 2016.

  1. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,420
    Messages:
    6,745
    Likes Received:
    1,090
    Trophy Points:
    331
  2. Toughbook

    Toughbook Drop and Give Me 20!

    Reputations:
    1,247
    Messages:
    7,228
    Likes Received:
    232
    Trophy Points:
    231
    Read the reviews! Hilarious!
     
    Shawn likes this.
  3. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    17
    Messages:
    213
    Likes Received:
    66
    Trophy Points:
    41
    Just the tip?

    Alright. I'll see myself out.
     
  4. CWB32

    CWB32 Need parts for my flying saucer.

    Reputations:
    179
    Messages:
    1,536
    Likes Received:
    393
    Trophy Points:
    101
    cough cough ...
    odd , i do not see any "accessory" lube packets .
    i take it that those are not included ?
     
  5. SugarD-x

    SugarD-x Notebook Enthusiast

    Reputations:
    10
    Messages:
    45
    Likes Received:
    8
    Trophy Points:
    16
    At least he's getting some tonight. :D

    This is really making me want to get my MC7354 card working in my CF-30. I just don't want to deal with calling into T-Mobile's customer service line. Every time I try to activate over the internet, the stupid thing encounters an unknown error and tells me to call T-Mobile directly. (I know if I do, it is going to be the headache from hell to get a plan set up). Aside from that, everything else seems to work fine on it.
     
  6. MCCSolutions

    MCCSolutions Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    5
    I wanted to thank you for this!

    After running around to different websites to get the appropriate drivers and manager I had issues where the card would only connect to HSPA on AT&T(12mbps Down 1mbps Up with all bars, even worse with anything less), I tried several SIM cards from my other phones and tablets.

    My Sierra MC7700 was unlocked and already had ALL Bands enabled(00) however it would now show or connect to anything other than AT&T(HSPA), I tried the North American Bands command with the same results. Eventually I tried the ALL LTE BANDS command and it worked! Now it only shows AT&T(LTE 4G) and I get upward of 30mbps down and 28mbps up with only 3 bars(8/6 with one bar, 18/18 with two bars)

    Im using it on a Dell E6430(mPCIe WWAN Slot, internal antennas), max temperature was 28c) I plan to use the GPS but I need to install another antenna.

    Its funny because the Sierra website is garbage, makes you register and when I tried they gave me an error because I was not using a unique(business) email domain.

    I got my connection manager from Google Drive link on another forum, Drivers from the Fujitsu Website(7710 Drivers), AT&T Firmware from Panasonic, and I used Huawei Modem terminal for AT Commands. Took way more work than it should have.

    I also noticed that LTE APN settings were only available in the windows connection manager after the latest update, prior to that it just said APN. Now you can set the Internet APN(Handshake/mms?) and the LTE APN separately.

    I came from a Surface 3 Professional LTE from AT&T I use for work which got horrible reception and only got speeds similar to the HSPA, also it dropped connection frequently. I am pleased with this card, I get much better reception in my stone house and service vehicle. Even if I have to buy a few extra assuming these fail after a year or two its worth it!
     
    kode-niner likes this.
  7. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    17
    Messages:
    213
    Likes Received:
    66
    Trophy Points:
    41
    I am glad it worked out for you although I find it curious that with all bands enabled your module prefers to connect to slower HSPA frequencies first. I suspect your connection manager software is the culprit.
     
Loading...

Share This Page