M4800 Owner's Thread

Discussion in 'Dell Latitude, Vostro, and Precision' started by changt34x, Oct 29, 2013.

  1. nk12

    nk12 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    5
    Can you share your modification with us in detail? How's the battery life/head with the overclock gpu?

    Is the the same procedure as shown in

    http://forum.notebookreview.com/thr...ocking-vbios-mod-dell-precision-m4800.789891/
     
  2. Yuuji

    Yuuji Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Well for the battery life, if you still have the intel iGPU (which you can undervolt with intel XTU) enable it doesn't really change because the firepro totally poweroff when not in use (so still around 5 hours with a 97Wh battery), and still limit itself to 400MHz on battery if you disable the intel iGPU.

    And yes, I followed the instruction of this thread, flashing in windows (make sure to have your intel iGPU enable for this)
     

    Attached Files:

  3. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    Guys, I ran into a bizarre airplane mode issue on my m4800.
    My m4800 is now completely stuck in airplane mode. There's no way to disable airplane mode...
    What should I do?
    This happened after I update my windows 10 two days ago.

    Here's a summary of my situation:
    - laptop seems to be in permanent airplane mode.
    - airplane mode button is not working. I tried to re-install M4800 airplane mode switch driver but no luck.
    - both airplane mode and wifi icons are grayed out. They can't be clicked.
    - I tested with my USB wifi adapter, it could detect wifi signals but it quickly went back to airplane mode. Apparently, there's no problem with my Wifi card or USB wifi adapter.
    - I updated BIOS to the latest version but no luck.
    - Network adapter reset / reinstall didn't work
    - I did Windows 10 reset.. but now my windows 10 starts with airplane mode turned on.

    It looks like M4800's airplane mode switch is no longer compatible with newer version of Windows 10...

    Please help. Thanks
     
    Last edited: Jan 18, 2020
  4. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    and what is shortcut command for airplane mode on / off ?
    on other laptops, Fn + PrtScrn will trigger airplane mode on / off but on M4800, that will take a screenshot instead. It doesn't seem to have airplane on / off shortcut command.

    so here's my warning to you guys. Don't get the windows 10 update from 1/15/2020. It looks like it has something that screws M4800's airplane mode switch.
     
  5. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    774
    Messages:
    4,432
    Likes Received:
    1,350
    Trophy Points:
    231
    It sounds like the laptop thinks that your physical airplane mode switch is "stuck" on. I have M6700 with the same switch and same driver and I am having no trouble (with the latest Windows 10 update).
    I looked in Device Manager and it looks like there is no option to disable this switch. However, if you uninstall it in device manager, the system is no longer able to detect when the switch is moved. (You would have to do this after every reboot as it will be re-detected.)
     
    John Carlson likes this.
  6. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    Thanks. I already tried that. There's airplane mode driver... I did uninstall and also re-install with this one:
    https://www.dell.com/support/home/ca/en/cabsdt1/drivers/driversdetails?driverid=px8mm

    It didn't fix anything... any other suggestion?
     
  7. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    Maybe it could be that my airplane mode switch is broken???
    Is it possible to take out my airplane mode switch from M4800? and permanently disable it?

    Windows 10's airplane mode is a really bad feature.. Microsoft guys had to provide a way to permanently disable it. Because this kind of problem can make your laptop totally useless. I can't believe there's no way to solve this simple problem.
     
  8. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    774
    Messages:
    4,432
    Likes Received:
    1,350
    Trophy Points:
    231
    Go to Device Manager, right-click/uninstall the Airplane Mode Switch (under Human Interface Devices). Do NOT try to redetect and install a new driver.
    With the Airplane Mode Switch uninstalled, you should be able to toggle Airplane Mode back off in Action Center. ("Speech bubble" thing in bottom right.)

    This would be a temporary fix as the device would eventually be re-detected automatically, but if it works I have an idea for a permanent fix.
     
    Last edited: Jan 18, 2020
    John Carlson likes this.
  9. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    Thanks, that didn't worked. I uninstalled Airplane Mode Switch driver but my laptop was staying locked at airplane mode. However, I could re-enable Wifi by suspending 'Radio Management' services on task manager.
    Here are the steps I followed:

    1. Open your task manager
    2. Find 'Service Host: Radio Management Service'
    3. Click on 'End task'

    After that, I could turn on Wifi.. but this doesn't look like a complete fix. I can connect to Wifi but it still shows airplane mode icon... and the 'Service Host: Radio Management' will likely start again whenever I reboot my laptop.
    So this 'Service Host: Radio Management Service' is a part of this Windows 10 system.

    If I can completely blacklist this 'Radio Management Service' from task manager, I could solve this problem, I believe.
     
    Last edited: Jan 18, 2020
  10. John Carlson

    John Carlson Notebook Consultant

    Reputations:
    0
    Messages:
    263
    Likes Received:
    8
    Trophy Points:
    31
    It looks like ending 'Service Host: Radio Management Service' on task manager solved my problem.
    I ended 'Service Host: Radio Management Service' on task manager several times and I blocked it on Task Blocker software. And now my airplane mode switch is working fine again... this is so strange.
    https://sourceforge.net/projects/taskblocker/

    So this software allows you to block any task from starting up on task manager. I added the 'Service Host: Radio Management Service'...

    It took me one full day to fix this problem. and now my Win 10 has been reset.
    I think Microsoft or Dell guys should provide a better way to permanently disable airplane mode. In case your airplane mode switch breaks down, it can lock your laptop up. It is one of the most poorly programmed features on Windows 10.

    The problem is 'Service Host: Radio Management Service' running in background. It's not fully compatible with Dell M4800? or it has bugs... anyways, it's best to permanently disable it.
     
    Last edited: Jan 18, 2020
Loading...

Share This Page