m18xR1 ati mobility 4870 black screen

Discussion in 'Alienware 18 and M18x' started by cisik, Oct 16, 2019.

  1. cisik

    cisik Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    Hi guys,
    i have m18x R1 model with A05 unlocked bios and i try to connect ati mobility 4870 card/s.
    I read ton of posts but people that seem to have similar problem with different card didn't post any solution. Case is when i connect 4870 i get black screen and 8 beeps.
    When i use only integrated graphics (no cards installed) laptop is starting normally.
    When i use integrated graphics (nvidia card installed as master) laptop is starting normally.
    When i use nvidia card installed as master laptop is starting normally.
    When i use nvidia card installed as master and ati 4870 installed as slave laptop is starting normally but in devices manager i see there is error 10 with ati card.
    When i use ati 4870 card installed as master i get 8 beeps and black screen.
    I tried to google for answers but unfortunatelly didn't find any. Do you know if that old card can work in m18x ? Maybe it's not supported at all? Do you have any ideas what else can i try?
     
  2. ssj92

    ssj92 Neutron Star

    Reputations:
    1,917
    Messages:
    3,850
    Likes Received:
    4,687
    Trophy Points:
    331
    When you are using 4870 in master slot are you using SG or PEG graphics mode in the BIOS video configuration?
     
  3. cisik

    cisik Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    In PEG mode i get black screen and 8 beeps.
    In SG mode laptop is turning on normally and 4870 is visible in devices manager but it looks the same like in PEG mode when card is installed as slave, error 10.
    Maybe i should add i didn't yet try any drivers/catalys installation or vbios flash because i assumed first laptop should be able to boot with 4870 as master and then i will worry about windows config. GPU Z shows 4870 as dell card.
    Does anyone know if it makes any difference in my case if I use UEFI or Legacy BIOS?
     
    Last edited: Oct 16, 2019
  4. cisik

    cisik Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    UPDATE
    Small but progres, i changed UEFI setting from disabled to enabled and laptop starts with 4870 as master but there is no backlit of LCD. Any ideas? I don't want to mess around with more BIOS settings on my own.
     
Loading...

Share This Page