M18 R2 upgrade to GTX 1070 complications

Discussion in 'Alienware 18 and M18x' started by Dr. Traxus, Jun 13, 2019.

Thread Status:
Not open for further replies.
  1. Dr. Traxus

    Dr. Traxus Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    6
    Hello fellow NBR users,
    I have plans to revive my old m18x and upgrade it to new glory so I bought a GTX 1070 on a black PCB and physical installation went fine, upgrading to Raidriar's BIOS also went through without any complications. Now the fun stuff starts...
    When I tried to install Windows 10 in UEFI mode (yeah, I win10 hate it too but I enjoy Forza too much to give up on it :D), no drives and boot-sticks showed up as bootable devices. The only Thing it showed me was "UEFI Onboard LAN IPv4". I switched to legacy (don't know if this is stupid or not) and everything showed up (my 3 drives of the HDD bay aswell as the mSata SSD where I intend to install the OS. The bootstick was also present). I installed Win10 on the mSata SSD and let the updates do their thing (tweeking would come later).
    The next serious Problem was the Installation of the Drivers. I tested various versions with no succes, it started installingy then it cancelled telling me that the Display Driver failed and the other stuff like PhysX and Geforce Experience were not installed (I'm not sure if I modded the .inf files correctly, I got confused with that "new" SectionXXX, but I think that shouldn't be the Problem since the Driver allowed me to accept their EULA).
    Any suggestions what I could do in order to get my beast breathing fire again?

    Thanks in Advance.
     
    Kade Storm likes this.
  2. Raja786

    Raja786 Notebook Consultant

    Reputations:
    5
    Messages:
    290
    Likes Received:
    42
    Trophy Points:
    41
    Have you tried disabling driver signature enforcement? If not do that and then try installing drivers again.

    To disable hold down shift key and click restart - troubleshoot - advanced options - startup settings - restart - f7 and your done.


    Sent from my iPhone using Tapatalk
     
    Kade Storm, M18x-oldie and Dr. Traxus like this.
  3. Dr. Traxus

    Dr. Traxus Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    6
    Hi Raja786,
    sometimes forgetting about some simple things like this can screw up your day… :D Now I'm mad at myself for not trying that before hand.
    Thank you, that solved the issue. The other issue with win10 only working in legacy mode was solved by making a Win10 DVD and installing a fresh copy of the OS.
     
  4. Raja786

    Raja786 Notebook Consultant

    Reputations:
    5
    Messages:
    290
    Likes Received:
    42
    Trophy Points:
    41
    Nice mate, glad I could help


    Sent from my iPhone using Tapatalk
     
    M18x-oldie likes this.
  5. Homer S

    Homer S Notebook Evangelist

    Reputations:
    11
    Messages:
    314
    Likes Received:
    86
    Trophy Points:
    41
    Are you able to run Fire Strike from 3dMark on your rig? I'm trying on mine but no luck. Scores of zero.

    Homer
     
  6. Dr. Traxus

    Dr. Traxus Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    6
    Hey Homer, sry for the late reply, I can run Fire Strike on my rig, I only scored 7998 points which is pretty sad when comparing it with other users. I constantly hit the powerlimit.
     
  7. Homer S

    Homer S Notebook Evangelist

    Reputations:
    11
    Messages:
    314
    Likes Received:
    86
    Trophy Points:
    41
    Hmm... take a peek here. I am able to run 3dMark stuff now with the 1070. I suspect it was either a driver issue or my SLI cable is not 100%. Also, that post I pointed to has two alternatives to "reset" some throttling issues.

    Homer
     
  8. MagicMike

    MagicMike Notebook Consultant

    Reputations:
    19
    Messages:
    212
    Likes Received:
    68
    Trophy Points:
    41
    I have since tested the method that worked for you, and this time it worked for me as well. So I would say try ssj92's method first and then the one I suggested if you get no luck.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page