M17Xr4 GTX 675m HDMI/DISPLAY PORT Issue

Discussion in 'Alienware 17 and M17x' started by flyingsaucer75, Feb 6, 2020.

  1. flyingsaucer75

    flyingsaucer75 Notebook Enthusiast

    Reputations:
    10
    Messages:
    23
    Likes Received:
    5
    Trophy Points:
    6
    Help needed! Hi everyone first all....

    I've Dell M17xr4 since 2012:
    I7 3840QM
    Intel IVY Bridge
    Nvidia GTX 675M
    8GB RAM
    PSU 330W

    In 2015 I lost my screen display during a simple NVIDIA Driver upgrade and then using an IN/FAMOUS Nvidia tool (8 Beeps of death). After one year I succeeded to build a cable and with an USB programmer I repaired my EDID LGD02DA Display; now everything is ok.

    My laptop has Windows 7 64bit Ultimate (First HDD) (I think it's not fully UEFI COMPLIANT OS).
    Two days ago I've installed a second Internal HDD and tried Windows 10 Pro install in full UEFI.

    I've flashed VBIOS for my GTX Dell 675m - 70.24.4E.00.10.zip (UEFI SUPPORT)

    Installed Windows 10 with these Bios Settings

    Load Legacy OPROM = Disabled

    Secure Boot = Disabled
    Fast Boot = Disabled


    With Windows 10 Pro 64bit everything works perfectly I can use Internal and external HDMI Display (27" DELL) without issue I can switch from internal to external, extend display, turn Off second display (external HDMI) and keep internal display ON or I can turn OFF internal and use as primary display my external HDMI monitor.

    Now I cannot do same things with Windows 7 64bit.

    I.E.

    If I've tried to disable internal display and I use my second monitor as first display it works but I cannot revert.... there's no way to turn ON internal display and turn off external.

    This happens even if I use Intel 4000 and GTX 675M togheter or Discrete only GPU GTX 675m

    (While in Windows 10 I can Do everything)

    There's only a way to do this set BIOS:

    Load Legacy OPROM = Enabled


    (I've tried also a new fresh Windows 7 64bit Ultimate install with full UEFI) But I've same HDMI/DISPLAY PORT video issue.

    Now I'm on latest A15 stock firmware and I've done step by step from a05 till latest always only STOCK Bios.
    I've also tried to reset NVRAM.

    A modded A15 Bios can Help? Anyway it's better stay on a latest modded Bios with a system configuration likes mine? (I don't do anykind of overclock now I use my m17xr4 only as Sampler for musical Keyboard with an external AUDIO CARD)

    Thanks for Helping
    Best Regards
    Tony
     
Loading...

Share This Page