m17x unlocked A14 bios, windows 10 usb 3.0 issue

Discussion in 'Alienware 17 and M17x' started by Imonk86, Apr 7, 2019.

  1. Imonk86

    Imonk86 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    6
    Iv read many posts on a variety of sites including this one about the issue. All 4 usb ports are 3.0 and work with most devices, but some devices that require 3.0 spacificly wont be recognized.
    My searches found that it's an issue between intel and microsoft acknowledging it as an actual issue. I saw that at one point Intel had a driver update for windows 10, but pulled support and the file in question from the site on the first of January. Old drivers dont fix the problem either. Iv done pretty much everything. It sucks because I purchased a hdmi capture device that requires usb 3.0 and itll pass through the feed to my tv just fine, but wont stay mounted or be acknowledged by the software that's ment to view the feed on my laptop.

    After some more digging I found a thread where many people who had the same problem figured out how to modify drivers to sort out this problem. https://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html
    I followed the instructions in the above link and my issue is gone now. hope this helps anyone else who still has the same issues.
     
    Last edited: Apr 7, 2019
    TheReciever likes this.
  2. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    433
    Messages:
    2,620
    Likes Received:
    1,484
    Trophy Points:
    181
    Is this on the r5/aw17 r1?
     
  3. Imonk86

    Imonk86 Newbie

    Reputations:
    0
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    6
    Mine is a Alienware M17X R4, custom unlocked bios A14. Though I believe this issue has nothing to really do with any spacfic Alienware itself, but rather Windows 10 and Intel. I followed all the instructions in the link I provided based on which system mine is compatible with and now my issue is gone. I am currently playing around with the settings for my capture card as we speak.
     
  4. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    433
    Messages:
    2,620
    Likes Received:
    1,484
    Trophy Points:
    181
    I don't seem to have that issue on the ranger so maybe it's a different chip set, anyways, thanks for sharing!
     
Loading...

Share This Page