M17x R4 - 60hz panel working but 120hz no backlight in EDP port

Discussion in 'Alienware 17 and M17x' started by Kyle2k80, Nov 15, 2020.

  1. Kyle2k80

    Kyle2k80 Notebook Enthusiast

    Reputations:
    0
    Messages:
    22
    Likes Received:
    2
    Trophy Points:
    6
    Hello, I hope someone can help me, here I go:

    So I upgraded to a 120hz screen and it worked fine for a week or two, but I tried to upgrade to a 980m and had to revert panels to sort my bios out for the 980m, turned out the 980m had issues so I reverted to my 860M.

    Now for some reason I get no backlight on my 120hz screen, its set to PEG mode but still not backlight, no beeps, I can see the screen if I use a flashlight, it works fine but no backlight..

    does anyone know what could be causing the problem?

    things I’ve tried:
    - cleaning the LCD cable & port with IPA (whilst it was off, it dried completely before retrying the laptop.
    -different GPUS
    -different bios settings

    non above worked, here’s my specs, hope to get some replies :/

    M17x R4
    I7 3630QM
    GTX 860M
    16GB DDR3
    240W PSU
    60Hz screen & 120Hz screen
     
  2. Reciever

    Reciever D! For Dragon!

    Reputations:
    915
    Messages:
    4,255
    Likes Received:
    2,575
    Trophy Points:
    231
    install driver and see if the backlight initiates, some laptops will not have backlight until this happens.

    If after driver is installed and still no backlight then its likely an issue with the panel itself.
     
  3. mpechura

    mpechura Notebook Enthusiast

    Reputations:
    0
    Messages:
    27
    Likes Received:
    3
    Trophy Points:
    6
    So I had the problem with no beeps and no backlight on my 120hz screen.
    What the problem turned out to be in my case is the eDP cable is too short and the cable would disconnect from the panel.
    So I would try connecting the cable to the panel and check the results before mounting the panel using the screws.
    I glued the blood thing in place with super glue.

    Other suggestions are below:
    - I didn't need to unlock BIOS (makes your task so much easier). But I had to mod the .inf, disable signature enforcement and change some bios settings (Set to UEFI mode. Disabled fastboot, legacy options and adapter warning).
    - I had to convert my HDD from MBR to GPT. WIth EaseUS Partition Master I DIDN'T even have to reinstall Windows (the whole process takes like 10 minutes with no input from you).

    I also took the battery out as the battery didn't have enough juice to power my 1070.
     
Loading...

Share This Page