M17x R2 7970m CrossfireX Ultimate Installation and Tweaking Guide

Discussion in 'Alienware 17 and M17x' started by sangemaru, Jun 7, 2013.

  1. arturo74r

    arturo74r Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    3
    Trophy Points:
    16
    Before I try baking the GPU. Is there a way to blind flash a vbios? since I get the blinking LED and I am failing post I am not sure how I could possibly do it. Any suggestions welcome
     
  2. Raidriar

    Raidriar Notebook Prophet

    Reputations:
    1,122
    Messages:
    4,530
    Likes Received:
    2,848
    Trophy Points:
    231
    I am unaware of a blind flash procedure on the M15x or M17x R2
     
  3. arturo74r

    arturo74r Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    3
    Trophy Points:
    16
    From reading some of this thread it looks like I might have a newer Dell VBIOS which is not compatible and there is no way to downgrade on this system. I would really like to be able to test this card to sell it, any ideas?
     
  4. PsiPr0

    PsiPr0 Notebook Evangelist

    Reputations:
    95
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    30
    Would a 7970m be plug and play and faster than a gtx580m in an M17x-r2? Looking to upgrade my GPUs and going with a single card before braving crossfire/sli. Anyone have an install of a single 7970m?
     
  5. 5HT

    5HT Notebook Guru

    Reputations:
    5
    Messages:
    56
    Likes Received:
    18
    Trophy Points:
    16
    Hi ,

    Is white screen a common problem with RGB LCD and 7970m in M17x R2 ?
    My external monitor works fine but i get white screen on main laptop display
     
  6. 5HT

    5HT Notebook Guru

    Reputations:
    5
    Messages:
    56
    Likes Received:
    18
    Trophy Points:
    16
    Bear with me as this is going to be long Unedited copy paste post for above, or the impatient ones short Answer is yes

    Here it Goes -->

    1. Hi ,

      Is white screen a common problem with RGB LCD and 7970m in M17x R2 ?
      My external monitor works fine but i get white screen on main laptop display


    2. [​IMG]
      Nospheratu Notebook Deity

      Unfortunately I am running the v1.2's and don't have any first hand experience with the CLEVO v1.1's. Fortunately, a fellow member, TR2N is running the v.1.1 CLEVO 7970M in his M17x R2 so he would be your best bet to provide you with accurate information (he also experienced the white screen problem). PM him for details on his vBIOS and configuration.

      I'm sorry I couldn't have been of more help.

      Nos


    3. [​IMG]
      5HT Notebook Guru

      Thanks Nospheratu , I will contact TR2N also i had a question what if i get a Non RGB screen, will it still be a problem, i mostly use external monitor but i just need my laptop screen working for now so that i can login to Oracle Linux 5 which does not unfortunately work on external monitor until in login into it with my credentials


    4. [​IMG]
      Nospheratu Notebook Deity

      I don't know for certain if it will work, as I can't recall anyone who's experienced the white screen issue who's swapped out the RGB screen with the CCFL version.


    5. [​IMG]
      5HT Notebook Guru
      I have ordered no RGB screen , we will know as soon as i get it


    6. [​IMG]
      5HT Notebook Guru

      CCFL non RGB works like a charm, no white screen issue any more, now i will try to get my other 7970m working in crossfire n alone, someone it stopped working 6 months ago n i never got to fix it

      Sent from my SM-G900T using Tapatalk


    7. [​IMG]
      Nospheratu Notebook Deity

      That's great news 5HT! Well done! You should add this information to a thread to help others.

    8. [​IMG]
      5HT Notebook Guru

      Yes i will make it a thread after a few more test, i am currently trying to get my other clevo 7970m v1.1 to work, i will first try to flash it with vbios from the card which is working, its called Thames.rom and i got vbios from TR2N too who has v1.1 card and he sent me surprising Thames.rom vbios too, i dont know if its just the names which are same or something else is different too until i check them each one through flash

    9. [​IMG]
      Nospheratu Notebook Deity

      GPU Shark is a very useful tool to determine current loaded vBIOS and the different performance states and voltages for each card in Detail view. I've found that v0.6.6 works the best for my setup.

      http://www.geeks3d.com/downloads/201209/GPUShark-0.6.6.exe

      You could also use HxD Hex editor's comparison function to see if there's any differences between the vBIOS files.


      Nospheratu, Jun 3, 2017 Report
      Reply
    10. [​IMG]
      5HT Notebook Guru

      i used and HxD hex editor file comparison utility and here is what i found, both rom's are different, the one which i already have is vBios 15.022 and the one which TRON gave is 15.017 of sv17 , i flashed the one which tron gave but still no luck, flash was successful but windows wont move further after Initial windows boot screen and machine will restart, same happens with 15.022, it use to work with 15.022 like 6 months ago, card shows up under device manager in safe mode though, i am not sure if card is bad or i have wrong vbios, I did a clean reinstall of AMD drivers too after DDU but no luck
     
  7. 5HT

    5HT Notebook Guru

    Reputations:
    5
    Messages:
    56
    Likes Received:
    18
    Trophy Points:
    16
    Continued..
    [​IMG]
    Nospheratu Notebook Deity
    1. What driver are you using? Try an older driver version. I'm currently on 17.3.3 as newer drivers give me BSOD. There are numerous issues with the new drivers and older hardware.

      Here's a list of previous drivers for Windows 7 x64

      I also have a few CLEVO vBIOS's that I've tested and work on my v1.2 cards. If you want to try them out you can download them here.


    2. [​IMG]
      5HT Notebook Guru

      I was using latest Driver , I will try using 17.3.3 and then go to even older ones like 16.2, I will try out your vBioS's too and then try to Bake the card in an oven as suggested by TRON as last effort


      Reply
    3. [​IMG]
      5HT Notebook Guru

      I also have a few CLEVO vBIOS's that I've tested and work on my v1.2 cards. If you want to try them out you can download them here.
      The Link you sent are of Desktop Drivers, are they same for Laptop ?


    4. [​IMG]
      Nospheratu Notebook Deity

      Once you click on the driver you want to download it will take you to the driver specific page where you can view the release notes and compatibility but all of them should be compatible with laptop GPU's.


    5. [​IMG]
      5HT Notebook Guru

      Thanks, I tried drivers 17.3.3 with all vbios's you gave + vbios from Tron and the Vbios i had on my working v1.1 card but no luck, windows wouldn't even start past windows screen only black screen
      then i tried same with driver's of version's 16 & 13 no luck there too, same result as with version 17 drivers, then i tried with driver 12.6, i got this-->
      vbios 15.017 = works, windows boot up past login like normal, i launch gpu-z to for temp which shows 31 C doesn't go higher goes down to 29 C n back again, but then after a couple of minutes , i get black screen , laptop unresponsive, so hard shutdown by holding off button
      vbios 15.024 of P270 = same as above
      vbios 15.024 of P370 = same as above
      vbios 15.019 = BSOD
      vbios 15.021 = BSOD
      vbios 15.022 (from the card which works) = works longer than others but ends up similarly

      Sticker on the card mentions vbios 15.024

      I dont know if baking it would fix it , not sure whether i should try it or try other vbios


    6. [​IMG]
      Nospheratu Notebook Deity

      Damn... that's a lot of work you put into it man.

      In my opinion baking the card is a bit extreme especially since we know that the v1.1 isn't the most compatible of cards. It could work perfectly fine in a CLEVO laptop and by baking it incorrectly you risk the chance of damaging a working card. Besides this doesn't seem to be an idle candidate for baking.

      If you haven't already try disabling ULPS after the driver install before restarting the machine.



    7. [​IMG]
      5HT Notebook Guru

      yea spent almost my entire sunday doing this,
      Also does it matter to Disable ULPS if i just use one card, cos all the things i did was just with one card in primary slot , i am not using crossfirex , let me know


    8. [​IMG]
      Nospheratu Notebook Deity

      Disabling ULPS usually helps with CrossFire issues but I thought you were trying to get the second card to work in CrossFire! :oops: So you have one v1.1 card that works, but the second v1.1 doesn't work in the primary slot even with the same vBIOS and driver that you're using with the working card? That's really weird, now the baking makes a bit more sense.

      Have you tried the weird card in the secondary slot with the working in the primary? Do you get the same results?

    9. [​IMG]
      5HT Notebook Guru

      Yes, the non working card was my secondary card, all was working fine until one day i started getting huge stutters and fps drops on more digging i found out that my secondary card was not working correctly, so i focused on fixing it alone as primary
      Also my working card works with any driver, no issues with it


    10. [​IMG]
      5HT Notebook Guru

      One more thing except 12.6 and version 17.x.x Drivers none other Driver versions i tried would list Video Driver to install after Hardware detection part of Installation
     
  8. 5HT

    5HT Notebook Guru

    Reputations:
    5
    Messages:
    56
    Likes Received:
    18
    Trophy Points:
    16
    continued..
    [​IMG]
    Nospheratu Notebook Deity
    1. Oh noes... TR2N is most likely right with the baking then. Identical hardware and vBIOS yet different results isn't a good sign.

      Are the cards identical though? Are the stickers on both cards with version numbers etc both the same?

      Where did you buy the cards from? Any chance of an exchange with another?

    2. [​IMG]
      5HT Notebook Guru

      I Bought both the cards from NBR member like a year ago, he use to live nearby locally and has moved now,
      The stickers on the cards both mention AMD WIMBLEDON v1.1 2G but bios sticker on working card mentions : vBios: BR42768.008 & on Non-working card it mentions vBios : 015.024.000.001


    3. [​IMG]
      Nospheratu Notebook Deity

      5HT said:
      One more thing except 12.6 and version 17.x.x Drivers none other Driver versions i tried would list Video Driver to install after Hardware detection part of Installation
      Can you try checking if the Hardware ID under Device Manager->Your GPU->Properties->Details->Hardware Ids (from the drop down list) for the faulty card is the same as the working card? The driver install inf matches up with this Hardware ID.


    4. [​IMG]
      5HT Notebook Guru

      Nospheratu said:
      Can you try checking if the Hardware ID under Device Manager->Your GPU->Properties->Details->Hardware Ids (from the drop down list) for the faulty card is the same as the working card? The driver install inf matches up with this Hardware ID.

      Here is the Hardware ID image , they have same ID

      Also i was thinking, would a dell card in secondary slot work in crossfire with 1.1 clevo or would v1.2 work or do i have to get v1.1 only

      Attached Files:
    5. [​IMG]
      Nospheratu Notebook Deity

      That should mean that the other drivers apart from 12.6 and 17.x.x does not list the video driver to install with the working card either? Did you download the drivers from the previous drivers link I posted earlier?

      You can make sure that the driver is compatible by checking in your C:\AMD\<Driver Version Folder>\Packages\Drivers\Display\WT6A_INF\ folder after the driver extracts for the inf file. There might be multiple inf files for Windows 7, 8 and 10. Search within the file/s for your Hardware ID, PCI\VEN_1002&DEV_6800

      If theres no occurance of that Hardware ID that means the driver is not catering for the 7970M.

      I'm not sure but I do remember a few members here ran different versions of cards. I cant remember their usernames but I think TR2N was one of them.

    6. [​IMG]
      5HT Notebook Guru

      Yes you are correct, they donot list driver for working card too, yes i downloaded from the link you posted
      I checked for Versions 15 , 14 too, there the HID is listed

      I will check with TR2N

      Now how do i make this conversation as thread for members to view it and get benefited by it ?


    7. [​IMG]
      Nospheratu Notebook Deity

      Well you don't have to start a new thread, you can update the below thread with what works with your v1.1 card. So if anyone installs a v1.1 card they know what vBIOS and version to use that works on our machines. You can basically outline your experiences and what you did including replacing the screen with the part number etc.

      M17x R2 7970m CrossfireX Ultimate Installation and Tweaking Guide

      If AMD's previous driver list don't cater for our cards, even if the release notes say they do, it's going to be tough finding older drivers as most other sites only cater for desktop drivers :(


    8. [​IMG]
      5HT Notebook Guru

      Thats a good idea, Also about AMD's Drivers we can get old drivers from Guru3d website but still it will sux that the Main company itself wont have legacy drivers
      I was thinking to try my Dell 770M card in m17x R2, i have two of them from my AW18 which has now one single 980M, if i can get single 770M to work then maybe i will try to put one single 980M using a modded 3 pipe heatsink, since now i dont have a RGB screen i think it should work with proper drivers in place, one question though does m17x r2 must absolutely require a graphics card to work ?


    9. [​IMG]
      Nospheratu Notebook Deity

      I think there were quite a few issues trying to get a 980M to work on non UEFI machines like ours. Search for "M17X R2 980M" I'm sure you'll get some good information. I don't think anyone was able to get it to work properly though :(

      Yes, we have to have a dedicated graphics card installed. Unlike the M17X R1 we don't have an integrated GPU. I think that's a good thing though as a lot of users have issues with AMD's Enduro or nVIDIA's Optimus.



    10. [​IMG]
      5HT Notebook Guru

      I am trying to first get single 770m installed on it and make it work, do you know what drivers should i try ?

      Well , i tried 770m latest drivers from Nivida website and it wont detect Hradware, now i will try driver from eurocom website
      http://downloads.eurocom.com/support/drivers/upgradeyourlaptop/Alienware/

     
  9. 5HT

    5HT Notebook Guru

    Reputations:
    5
    Messages:
    56
    Likes Received:
    18
    Trophy Points:
    16
    continued ..
    5HT Notebook Guru
    1. Ok with 770M only external screen works, laptop screen remains black, is there something missing ? if only somehow i can get 770m to work on it then i can go for 980m too


    2. 5HT Notebook Guru

      Got back to 7970m and oracle linux 5, trying to find away to install drivers on it , Linux is 64 Bit, close to my OL5 is RHEL5


    3. [​IMG]
      Nospheratu Notebook Deity

      I think I remember vaguely that you have to disable the onboard audio in the BIOS to get the screen to work with the 770M.... but now that I think about it that sounds odd, I'll try to find the thread with the information.


    4. [​IMG]
      Nospheratu Notebook Deity

      Found it, see here.


    5. [​IMG]
      5HT Notebook Guru

      Nospheratu said:
      Found it, see here.
      Tried that but didnt help

    Will post and edit more as time permits
     
  10. TR2N

    TR2N Notebook Deity

    Reputations:
    269
    Messages:
    1,227
    Likes Received:
    167
    Trophy Points:
    81
    Have a Clevo 7970m with my M17x R2 (see sig)
    Still running beautifully after all these years.

    heheheh :)
     
    Nospheratu likes this.
Loading...

Share This Page