M17R3 - 3rd party power supply not working properly

Discussion in 'Alienware 17 and M17x' started by Darmzotte, Oct 1, 2016.

Thread Status:
Not open for further replies.
  1. Darmzotte

    Darmzotte Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    6
    Hello. After my original power supply died (240W/19.5V/12.3A) I bought this one off amazon, with the same specifications, advertised as compatible with the alienware M17X series of laptops.
    https://www.amazon.de/gp/product/B00IIJ8OOO/ref=oh_aui_detailpage_o08_s00?ie=UTF8&psc=1
    When booting up a warning pops up, telling me it recognized a 3rd party 90W power adapter instead of the original 150W one. (Which it never had to begin with, like I said the original was 240W).
    I have a noticable performance loss now, I cannot play any game without heavy stuttering.

    I mailed the seller but have not received an answer yet. Looking through the forums I haven't found a solution either, I've tried starting without PS, then plugging it in, plugging it in while in the BIOS and starting without battery, and disabling the PS detection warnings, but nothing worked.

    Thanks in advance for any help.
     
  2. Zoltan@HIDevolution

    Zoltan@HIDevolution Company Representative

    Reputations:
    203
    Messages:
    200
    Likes Received:
    94
    Trophy Points:
    41
    It could be a defective AC adapter so continue on with contacting the seller and request a replacement.

    Sent from my SAMSUNG-SM-N915A using Tapatalk
     
Thread Status:
Not open for further replies.

Share This Page