1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

m15x web cam drivers and Alienware Sense

Discussion in 'Alienware' started by Wokawidget, Feb 12, 2010.

Thread Status:
Not open for further replies.
  1. Wokawidget

    Wokawidget Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    I am having trouble finding web cam drivers for my new m15x.
    It's currently using the MS default drivers from way back in 2006.

    The web cam works when using the cam software that came with the laptop.
    However, when using the Sense Facial Recognition during logon it hangs on Initializing, and then gives me a "License key is invalid" error message, and then I am forced to login the old fashioned way.

    I believe this is linked to the incorrect web cam drivers.

    I am looking for the Windows 7 x64 drivers.

    Does anyone know where I can get these from?

    Cheers,

    Woka
     
  2. Docsteel

    Docsteel Vast Alien Conspiracy

    Reputations:
    296
    Messages:
    1,564
    Likes Received:
    202
    Trophy Points:
    81
    Have you set up your account on Alienware's site for support? You can pull down drivers there as well, I would hope they have it ; )
     
  3. lgsshedden

    lgsshedden Notebook Consultant

    Reputations:
    16
    Messages:
    299
    Likes Received:
    4
    Trophy Points:
    31
    all driver support for the M15 all powerful are on the Dell site only
    therre is no specific web cam software: you can google and add a free webacam software such as Cyberlink YouCam
    be aware that Alienwware has just this week issued an updated version of Command Center, available on the Dell download site: try installing it first and then tweak from there
     
  4. Wokawidget

    Wokawidget Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Typical. They released a new version littlerally a few hours after I downloads.
    OK. This new version gets rid of the "License key is invalid" issue...however I simply cannot enable AlienSense.
    I can see my face in the web cam when loggin in and it saus I need to select a user and enter a password to setup that user for AlienSense. However, after looking in the Users box in the advanced aliensense config I see no users...no users are being added.
    When I login AlienSense shows a msg box that displays for 12-15 seconds. This says that due to my current configuration AlienSense is disabled. It says I need to check the User Rights Management in the AlienSense Management console....what User Rights Management?!
    If I set AlienSense to continuously monitor ppl sat at my laptop then in the taskbar the tooltip for the aliensense systray icon is "Aliensense is disabled".

    It's clearly enabled from the command center...the FAService is runnign and there are no event errors...Why is it not running? What is not running?

    Cheers,

    Steve
     
  5. BatBoy

    BatBoy NBR Community Moderator

    Reputations:
    7,391
    Messages:
    7,968
    Likes Received:
    16
    Trophy Points:
    206
    Two options -

    1. Easy route, uninstall Command Center and reinstall

    2. Check your startup items and verify FATrayMon.exe is enabled @ startup. ;)

    Also, FWIW - IMO, Aliensense is a resource hog and pure eye candy. As long as you are happy with it and it does not cause any performance issues for you... then enjoy! :)
     
  6. svrep

    svrep Company Representative

    Reputations:
    43
    Messages:
    259
    Likes Received:
    0
    Trophy Points:
    30
    Good news here...to "setup" a user in AlienSense, simply log in as you normally would with your face visible and the blue "Alien Head" outline around your face. That's it! It will learn right then and there. Do the same any time in the future that you are not recognized...just log in. It will acquire additional biometric templates in order to improve future performance in that location.

    What account name are you logging in with? Is it by any chance "Administrator"?
     
  7. svrep

    svrep Company Representative

    Reputations:
    43
    Messages:
    259
    Likes Received:
    0
    Trophy Points:
    30
    Thank you. I agree with your balanced take on resource use in general...if a program is doing what you want it to and isn't causing problems then that's great!

    In this case AlienSense is specifically designed to be very, very light on resource use. Especially in FaceLogin mode, Aliensense completely disconnects from the camera about 45 seconds after login at which point CPU use should be almost unreadable.

    In the other two modes (User Switching and Continuous Security), AlienSense continues to do real-time analysis of video after login in order to further protect your desktop and data. Obviously this analysis uses some CPU cycles, though it should still be a very small amount.
     
  8. Wokawidget

    Wokawidget Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    Yes it was administrator. Domain admin to be exact.

    I have just installed Windows 7 x64 Ult and tested the following:

    1) Login with local user. Works
    2) Login with domain user. Works
    3) Login with domain admin and things get disabled. Any ideas? Is there a way I can override this? I can see the security aspect of not allowing domain admins, plus, the domain admin account is used by many ppl and not usually restricted to one user.

    When logging in as domain admin a msg box appears saying everything is disabled with the current config and that I should check the user rights assignment in the Alien Sense Console.

    cHEERS,

    Woka
     
  9. svrep

    svrep Company Representative

    Reputations:
    43
    Messages:
    259
    Likes Received:
    0
    Trophy Points:
    30
    When logging in as the account specifically called "Administrator", AlienSense is disabled.

    You are exactly correct with your reasoning as to why this is the case. The assumption is that this is a high level person who may not want to be restricted by the security policy set by AlienSense. Also in the case where you have multiple users who log in with the same account then you definitely want it to be disabled automatically so as not to associate multiple faces with the same username. You should only associate your face should with your own user account. There is currently no way to change this setting.
     
  10. Wokawidget

    Wokawidget Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for your response.
    Wasted countless hours on this.

    "Aliensense is disabled with the current configuration...Please see User rights assignment in the Aliensense console"

    is VERY misleading. No such thing as user rights assignment in the aliensense config.

    "Aliensense is disabled for all administrators for security reasons, no need to waste hours trying to work out why it's disabled" would have been a MUCH better message and I wouldn't have wasted any time on the issue :)

    Cheers,

    Woka
     
Thread Status:
Not open for further replies.

Share This Page