m15x gtx770m guide.

Discussion in 'Alienware M15x' started by rsgametech, Feb 14, 2015.

Thread Status:
Not open for further replies.
  1. rsgametech

    rsgametech Notebook Guru

    Reputations:
    0
    Messages:
    63
    Likes Received:
    16
    Trophy Points:
    16
    -Dell 3gb gtx 770m
    -Download latest driver.
    - Extract driver 7-Zip/winrar to a folder.
    - Display.Driver folder -> open nvdmi.inf (notepad) CTRL+H -> Find What: 05AE Replace With: 02A2 -> Hit 'Replace All' -> Save.
    - ...International folder\ run setup exe.
    -Allow unsigned driver.
     
    Azshalasa likes this.
  2. Azshalasa

    Azshalasa Notebook Consultant

    Reputations:
    5
    Messages:
    137
    Likes Received:
    12
    Trophy Points:
    31
    This dont work for M15X with GTX 765M in Windows8
     
    robb41488 likes this.
  3. robb41488

    robb41488 Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    15
    Trophy Points:
    16
    thats because its not complete. theres alot missing thats causing you to white, green, or pink screen

    start with this guide... hopefully it helps

    1. Disabled audio in bios (A09) and get the 770m fully working. I used the nvidiaoem 327.44 drivers from laptopvideo2go.
    2. Enable audio in the bios.
    3. Restart into safe mode and uninstall the generic High Definiton Audio Codec drivers from device manager.
    4. Restart again and enter safe mode to install the latest dellaudio drivers. Once this is done you should see the IDT control panel in control panel.
    5. Disable all sound cardsunder Sound, video and game controllers. For good measure also disable high definiton audio controller under system devices. Also go the the volume settings and set windows sounds to no sound.
    6. Restart into full windows. You should be able to boot even with audio enabled in the bios now.
    7. Go into idt control panel and toggle the power management to enabled (don't know if this did anything but worth a shot.
    8. Try enabling the IDT codec in device manager. If you yellow screen, restart and hope you can get into normal windows 8without yellow screening.
    9. If you do manage to finally get the PC to boot with sound enabled in device manager, don't touch the volume tab or anything as it will instantly yellow screen.
    10. Get into playback devices by right-clicking the volume icon on the taskbar. From here disable all audio playback devices and recording devices.
    11. Your pc should now be stable enough to do some things. Try reinstalling Nvidiadrivers again for good measure and when done, Re-enable just Speaker/Headphonesin the playback menu and restart.
    12. You should hopefully have stable audio output.
     
    Azshalasa likes this.
  4. Azshalasa

    Azshalasa Notebook Consultant

    Reputations:
    5
    Messages:
    137
    Likes Received:
    12
    Trophy Points:
    31
    Ok, i'll try again upgrade to Win8. But i'm sure, i was tryied too many ways before, and i never get it work with audio.
    I'm now downloading Nvidia 347.52 and let's try ur tutorial.
     
    robb41488 likes this.
  5. robb41488

    robb41488 Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    15
    Trophy Points:
    16
    are you going to be able to modify the .inf file for 347.52 to work?
     
    Azshalasa likes this.
  6. robb41488

    robb41488 Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    15
    Trophy Points:
    16
    also theres a few ways to get this done. this is how i had to do windows 7

    1. Disabled audio in bios (A09) and get the 770m fully working including the hdmi audio drivers. at this point my pc green screened but thats ok. I used the nvidiaoem 347.52

    2. Enable audio in the bios.

    3. Restart into safe mode and uninstall the generic High Definiton Audio Codec drivers from device manager.

    4. Restart again and enter safe mode to install the latest dell audio drivers. Once this is done you should see the IDT control panel in control panel.

    5. Disable all sound cards under Sound, video and game controllers including the IDT AND NVIDIA DRIVERS.

    6. Restart into full windows. You should be able to boot even with audio enabled in the bios now.

    7. once in full windows reinstall the IDT drivers with the idt sound and nvidia sound drivers still disabled, this will enable idt and force the driver. once complete you should have sound!!! DO NOT REBOOT YET OR YOU WILL GREEN SCREEN UPON BOOT

    8. make sure to leave the nvidia hdmi audio disabled!!

    9. disable and renable your video card. not sure why but this solved my issues!!! NOW YOU MAY REBOOT AND ENJOY YOUR PC AGAIN!

    10. once rebooted open the playback devices panel and disable the idt display port and nvidia hdmi 1, 2, and 3 (our pcs only use one hdmi outpu) leave the rest enabled

    then this is how i got the display port working

    11. reinstall the nvidia drivers and make sure to include the hdmi drivers. (this will force the nvidia sound card and drivers)

    12. reboot, make sure IDT display port is still disabled in the sound devices. then plugin to a displayport (i use a displayport to hdmi adapterfor my tv)

    13. open playback devices again and look to see if nvidia hdmi 0 has picked up your device.

    14. set your nvidiahdmi0 to default.

    15. sit back and enjoy your pc again.

    16. remember DO NOT reenable the idt displayport in playback or you will yellow/white screen and will need to boot to safemode to disable idt audio in the device manager and follow step 7 again
     
    Superman0902 and Azshalasa like this.
  7. Azshalasa

    Azshalasa Notebook Consultant

    Reputations:
    5
    Messages:
    137
    Likes Received:
    12
    Trophy Points:
    31
    OK bro, i was tottaly wrong. It's DONE! TOTAL successful to install Nvidia Drivers for GTX 765M and sound works great.
    BUT nothing is perfect, can't play NOTHING my M15X looks like run with Stealth Mode ON all the time. ( i'm using StopThrottle)
    Its so ridiculous i lost 30 FPS + in games.

    i used to play Alien Isolation with 50~~60 FPS now i'm playing with 12~~17
    Wolf New Order was 20~~30 FPS MAXED OUT, now is 10~~18
    Dying Light was 20~~30 FPS ALL LOW, now 7~~15

    World of Warcraft was 30 to 60 FPS MAXED OUT, now 20

    What to do ? D: Any idea?

    // NOTE

    Look that video i'm playing AlionIsolation, no move, no walk everything stop on screen and FPS HOLD to 18, every 5 secs , my fps up to 42 and back to 18. NO MOVE, THERE'S NOTHING on screen, just a stopped character.


    // This just happens with 150W PSU
    // With 180W PSU it just hold in 15FPS.
     
    Last edited: Feb 19, 2015
    robb41488 likes this.
  8. robb41488

    robb41488 Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    15
    Trophy Points:
    16
    sounds like your not clocking correctly. have you tried using gpu-z to figure out if your clocks are spooling up correctly?

    if not you will need a new bios.
     
  9. Azshalasa

    Azshalasa Notebook Consultant

    Reputations:
    5
    Messages:
    137
    Likes Received:
    12
    Trophy Points:
    31
    Look yourself, my BIOS Version is A09.


    // Note I think my Throttle Stop doesn't work, there's no difference in my FPS if it is open or closed.
     

    Attached Files:

    Last edited: Feb 20, 2015
    robb41488 likes this.
  10. robb41488

    robb41488 Notebook Guru

    Reputations:
    0
    Messages:
    51
    Likes Received:
    15
    Trophy Points:
    16
    i meant a new bios on your card. some of the 770s dont clock up properly unless the correct vbios is flashed.
    if you flashed the OC bios from slv7 you may be locked at 400/400 like i was.
    hit the ? next to the bus interface and run the shader tester in gpu-z, then switch to sensors to check what your card is clocking up to
     
    Azshalasa likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page