Lost your touchpad lights or functionality on your Alienware? Here's the solution

Discussion in 'Alienware' started by Ultra Male, Jun 25, 2019.

  1. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    20,379
    Messages:
    20,426
    Likes Received:
    29,671
    Trophy Points:
    931
    So me and a friend of mine had noticed that our touchpad light is not working coincidentally at the same time.

    Last thing we did as I recall is to force install the Intel Chipset Drivers offered by SupportAssist. You see, when we ran SupportAssist, it would always give us a notification that there is 1 driver update pending despite us having had installed that exact same version which was the Intel Chipset Driver.

    So what I did on my and his machine is to force install the driver using the -overall command via command prompt as the regular installation would still give us that notification that there is a driver update after we rebooted.

    I was very puzzled, under device manager, the touchpad was not listed, only some HIDdevice but not the actual touchpad, it's like the installation of the Intel Chipset Driver had completely removed it! We tried everything, BIOS reflashed then set the settings back to factory, no luck, reinstalled the touchpad driver, no luck, obviously because there is no touchpad in the device manager to begin with for that driver to be installed.

    I then thought of reinstalling the Intel Serial I/O Driver, when I tried installing it, it said that it's already installed so it gave me 2 choices, to remove it or to repair, I chose the 2nd option which is repair and within a few seconds voila!! the touchpad light came back on and it was functional and it reappeared in device manager and was recognized again under the Alienware Pointing devices!

    Just wanted to share my experience in case someone runs into such issue
     
    Last edited: Jul 4, 2019
  2. Classified

    Classified Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    3
    Trophy Points:
    6
    Exactly the same issue I encountered during the initial manual driver update on my A51m. I didn't mind it at first and when I went on to update the serial I/O driver, it came back on "automagically".
     
    Ultra Male likes this.
Loading...

Share This Page