Looking for premamod for p157sm due to fan being limited

Discussion in 'Sager and Clevo' started by Obakemono, Jun 14, 2018.

Tags:
  1. Obakemono

    Obakemono Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hello, this is my first post here after a lot of reading on the subject and i hope you can help me guys :)

    The fan speed in my clevo p157sm seems to be limited to a 35% of its full speed, my guess is due to the amd driver, the graphics card is a Radeon HD8970m and the laptop is running Windows 8.1

    I would like to try to solve it with the Prema mod for my bios since i have read it allows for a better/manual fan control allowing me to put it manually to 100% and it seems that the correct way to get the modded bios is to politely ask to @Prema if he will be kind enough enough to share it with me.

    I would be very gratefull if he or someone can share it.

    Thak you!
     
  2. senso

    senso Notebook Evangelist

    Reputations:
    189
    Messages:
    564
    Likes Received:
    93
    Trophy Points:
    76
    Fn+1 should work, have you tried pressing it?
     
    Obakemono likes this.
  3. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    624
    Messages:
    4,204
    Likes Received:
    1,681
    Trophy Points:
    231
    Wrong, there is no fan control on your model, trust me I have the same as you do. Try FN+1 (not F1) and see if it does any better.
     
    Obakemono likes this.
  4. Obakemono

    Obakemono Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    It doesn't change anything :s

    The Fn+1 combionation doesn't seem to change anything, when i stress the GPU, the fan goes up to 2400 revolutions, and HWinfo says it is at 35%, can you tell me what speed should i expect at 100%?
     
  5. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    624
    Messages:
    4,204
    Likes Received:
    1,681
    Trophy Points:
    231
    Try another stock BIOS and EC, my XMG version of the notebook had no FN +1 feature either due to their EC firmware for some reason disabling it.
     
    Obakemono likes this.
  6. Obakemono

    Obakemono Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I had the XMG version too, i have flashed the same BIOS and EC from Sager i guess and now the Fn+1 woks like a charm, whith that and the liquid metal i can play now in the mid 50sº to low 70sº which is nice enough for this laptop!

    Should i mark this as solved somehow?

    Thank you very much!
     
  7. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    624
    Messages:
    4,204
    Likes Received:
    1,681
    Trophy Points:
    231
    We don't have that feature as far as I remember, just let the thread sink into the depths of necroland where someone in a couple of years will gravedig it back up for no other reason other than to make people spam "NECRO" and make a mod close it.
     
    Obakemono likes this.
  8. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    7,603
    Messages:
    47,848
    Likes Received:
    12,924
    Trophy Points:
    931
    Does not tend to happen round here.
     
    Obakemono likes this.
  9. Obakemono

    Obakemono Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    After some more testing i have found not only that i can now use FN+1 to go full speed on the fan, but also that i don't really need it because with the new flashed BIOS and EC the fan profile seems to work properly, 100% fan speed automatically kicks in once i reach mid 70'sº which didn't happened with XMG bios that apparently never goes further tan 2400rpm.

    @Danishblunt a little off-topic, i will maybe open a thread on it later, you say you have or had the P157SM, have you successfully used Windows 10 on it? Everytime y try it i have random kernel power errors followed by spontaneous shutdowns, also intense lag on resizing windows, have you encountered any of this symptoms on it?

    Maybe i should try with the new BIOS/EC

    Thank you :)
     
  10. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    624
    Messages:
    4,204
    Likes Received:
    1,681
    Trophy Points:
    231
    When installing W10 immiediately disable bluetooth and fingerprint drivers, then install the newest one you can find and the BSOD should stop. Mine would freeze as well on stock W10 drivers.
     
Loading...

Share This Page