Linux on Sager NP6165 / Clevo W150ER

Discussion in 'Sager/Clevo Reviews & Owners' Lounges' started by cengique, Jun 22, 2012.

Thread Status:
Not open for further replies.
  1. Rauch

    Rauch Notebook Consultant

    Reputations:
    24
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    30
    Keep up the good work! All I can say is during my brief testing of Mint 13, everything was functional with the exception of Bumblebee and the occasional lockup!

    So, you're on the right track. I'm going to be moving back to Arch shortly.. Once I figure out this recurrent "BEEP BEEP BEEP... 1 minute later BEEP BEEP **SHUTDOWN**"

    I'm not a big fan of Debian distributions since I've began using Arch/Gentoo.
     
  2. cengique

    cengique Notebook Enthusiast

    Reputations:
    3
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    15
    No, you can put the iwconfig line in a configuration file. I don't use Arch, so I'm not sure how it works, but for Debian/Ubuntu, you can put a line in /etc/sysconfig/network
     
  3. defcronyke

    defcronyke Newbie

    Reputations:
    12
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hey Linux Sager users, I just wanted to let you all know that I've worked out a recipe for getting Bumblebee working with the Optimus GT650M and the NVidia proprietary driver. I don't promise anything, so don't go out and buy one of these laptops just because I said it works, but if you have one already, you might want to check out my recipe here: Hybrid Graphics Tutorial - NVidia Optimus with the GeForce GT 650M on Linux

    It's been tested on a Clevo W150ERM running Linux Mint 13 Cinnamon, and I have a report of it working with a GTX660M on Ubuntu 12.04 as well. That being said, it should work with slight modifications on any Linux distribution.

    Basically, until Bumblebee 3.0.1 and the nvidia driver 304.22b make it into your distro's repositories, you'll probably need to follow a similar procedure to the one explained in my tutorial.

    The tutorial explains how to install the official version of the NVidia driver in a non-standard location, without removing all your existing OpenGL stuff. It goes on to explain how to get the newer version of bumblebee installed from the git repository, and configured to be able to find all the NVidia libraries, but to use an Intel driver when accessing the framebuffer.

    Full instructions are at the link I provided, but please only follow them on a fresh install of your operating system, with all important data backed up somewhere else first.

    Sager is awesome, I still have a 3GHz P4 system probably from around 2003ish, and it's only needed a replacement hard drive and cd drive over the years, and it still blows a lot of newer laptops out of the water.

    Keep rockin' those Clevos everyone!
     
  4. jaug1337

    jaug1337 de_dust2

    Reputations:
    2,135
    Messages:
    4,862
    Likes Received:
    1,031
    Trophy Points:
    231
    +1

    Well done mate!!
     
  5. PopeJamal

    PopeJamal Notebook Consultant

    Reputations:
    7
    Messages:
    104
    Likes Received:
    4
    Trophy Points:
    31
    Wow, that's alot of work! Glad you got it sorted out.

    I ended up getting my 680M working by using the xorg-edgers ppa. It has a newer kernel (3.5 for the IvyBridge mouse scroll freeze issue) and the 304.22 Nvidia driver (which is the first driver to support my card).

    I might try this method next time I need to do a re-install. Excellent write-up!
     
  6. Rauch

    Rauch Notebook Consultant

    Reputations:
    24
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    30
    Nicely done, mate!

    One question though... Don't Debian distros no longer use /emu1/ and instead use /usr/lib32?

    Testing via Mint 13, /emu1/ was not a valid location.
     
  7. defcronyke

    defcronyke Newbie

    Reputations:
    12
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hey Rauch,

    The 64-bit nvidia installer put all the 32-bit libs under the /emul directory when I installed on Linux Mint 13 Cinnamon (note it's emul with an "L", not a "1"). There seemed to be no command line args to change that directory, even though there are args to change the directories for everything else. It's possible the installer might put them somewhere else on a different distro, but when I did it on Mint 13, they definitely went under the /emul directory (no-one else seems to use that directory for anything, so NVidia is probably just a bit out of touch with Linux)
     
  8. Rauch

    Rauch Notebook Consultant

    Reputations:
    24
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    30
    That was my mistake, I meant /emul/.

    Anywho, it didn't seem to place them there for me on Mint 13 Cinnamon Strange, huh? Any chance you could list off the files you copied just so I can compare?

    Bumblebee is working nicely as it is. So for some strange reason maybe the installer had messed up somewhere or another.
     
  9. defcronyke

    defcronyke Newbie

    Reputations:
    12
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I don't have access to the system anymore, but maybe you installed the nvidia driver from a PPA? Distro-packaged versions of the nvidia driver will put their files in the correct place for the distro... Sorry I can't tell you the exact files you'd need to copy, but next time you do an install using the official driver (at least if you follow my instructions), it should make the /emul folder for you, and put all the required 32-bit libs under that location. Honestly, I had to reinstall Mint so many times to work out this method, if things aren't working for you 100%, you should start with a fresh install and try following my tutorial (unless you know of a better way).
     
  10. cengique

    cengique Notebook Enthusiast

    Reputations:
    3
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    15
    Thanks! Apparently I missed this message of yours. The lockup may be fixed by resetting rc6 parameter for the Intel 4000HD. See the first post.

    That sounds bad. I saw your other posts now.

    I was able to update my Debian installation using apt-get. Somehow aptitude was getting confused. I forced apt-get to get everything from testing and it was fine. Now some of the other stuff is not working, but it's just a matter of time of fixing them.

    I may install Gentoo on a separate partition down the road. No time now.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page