Linux gpu undervolt

Discussion in 'Sager and Clevo' started by Vernoux, Apr 25, 2020.

  1. Vernoux

    Vernoux Notebook Enthusiast

    Reputations:
    2
    Messages:
    16
    Likes Received:
    12
    Trophy Points:
    6
    Hi there!
    Is there any alternative to afterburner on Linux regarding undervolting the nvidia gpu's?
    Thanks
     
  2. TheDantee

    TheDantee Notebook Evangelist

    Reputations:
    44
    Messages:
    459
    Likes Received:
    215
    Trophy Points:
    56
    if you have nvidia-settings downloaded you can run a command " sudo nvidia-xconfig --cool-bits=28 " this will allow you to overclock through the nvidia control panel and you can also run a command after reboot " nvidia-smi -i 0 -pl 100 " where 100 is the max W you want the card to draw not the same as undervolting but pretty close. Theres a program called nvidiux but I cant seem to get it work your results may differ tho and you can give that a shot.
     
    win32asmguy and Vernoux like this.
  3. Vernoux

    Vernoux Notebook Enthusiast

    Reputations:
    2
    Messages:
    16
    Likes Received:
    12
    Trophy Points:
    6
    Many thanks! I'll try those
     
  4. Vernoux

    Vernoux Notebook Enthusiast

    Reputations:
    2
    Messages:
    16
    Likes Received:
    12
    Trophy Points:
    6
    Hm, for some reason I can't get it to work through smi.
    "Changing power management limit is not supported for GPU: 00000000:01:00.0.
    Treating as warning and moving on."

    Also enabling coolbits does not change anything in nvidia settings except "Editable Performance Levels"

    p775tm1-g with gtx 1080
     
    Last edited: Apr 26, 2020
  5. TheDantee

    TheDantee Notebook Evangelist

    Reputations:
    44
    Messages:
    459
    Likes Received:
    215
    Trophy Points:
    56
    You should see Fan Settings under GPU 0 Thermal Settings Tab Under PowerMizer you will have gained Graphics Clock Offset and Memory Transfer offset however for Power management has to be done through console did u try the same command without sudo? Also did you reboot? Also try setting your card is in preferred mode of "Prefer Maximum Performance" Basically P0 Mode. You can also check your xorg.conf by running sudo nano /etc/X11/xorg.conf and under the Section "Device" make sure there is no option for "PowerMizerLevel" if there is just delete it and Do CTRL+X to and then press Y to save and exit editing.
     
    Last edited: Apr 27, 2020
Loading...

Share This Page