Lenovo Y700-17isk + EXP GDC BEAST 9.0b m.2 x4 Cannot initialize!

Discussion in 'e-GPU (External Graphics) Discussion' started by REGEN42, Sep 16, 2019.

  1. REGEN42

    REGEN42 Notebook Enthusiast

    Reputations:
    9
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    Good day!

    Please help me to solve the problem with my egpu.

    I have:
    * Notebook Lenovo Y700-17isk
    * EXP GDC BEAST 9.0b m.2 x4
    * DELL DA2 power supplies and ATX Seasonic 650W Gold
    * MSI GTX 1080/gt 840/firepro v5900
    * Creative ZXR sound card

    [​IMG]

    When I connect power to the laptop and to the board, the video card does not show any signs of activity. It does not heat up and the cooler does not spin, I tried with different power supplies, with different video cards, the result is the same. The laptop does not see the video card at all.

    In the BIOS, I disabled the built-in video adapter (gtx 960m) and pxe boot.

    Questions.
    1. The egpu should start when the gdc beast receives a power-on signal from the laptop? So there is no signal? Or it should start immediately when i turn on the extermal atx/dell da2 psu?
    2. Do i need to modify the BIOS to unlocked one (with additional options)? Or did I came across a defective controller?
    3. I have a CREATIVE ZXR pci-e sound card, can I theoretically use it instead of a video card?
    4. Do i need to use software like DIY eGPU Setup 1.35? https://egpu.io /egpu-setup-13x/
    5. Do i need to connect monitor directly to external gpu or hdmi output on laptop is ok to use with external monitors/projectors?
    exp gdc 9.0b? (pic attached)[​IMG]

    Thanks for the help!!!
     
Loading...

Share This Page