Lenovo Y50 Owners and Information Thread

Discussion in 'Lenovo' started by kingfirejet, Jun 5, 2014.

  1. Structamention

    Structamention Notebook Geek

    Reputations:
    0
    Messages:
    82
    Likes Received:
    15
    Trophy Points:
    16
    My Y50 has always sort of...had both? So like here's the dolby. And here's the realtek. This is how it's been since I bought the laptop.
     
  2. ATG

    ATG 2x4 Super Moderator

    Reputations:
    3,306
    Messages:
    4,461
    Likes Received:
    344
    Trophy Points:
    151
    The Dolby seems to be installed but is it on? Open the "Dolby Digital Plus" app and check it.

    I don't know how it is right but when the Y50 was a new model and people were buying it there were discussions about the audio and we came to the conclusion that the Dolby only works with the Realtek driver from Lenovo. When someone tried to use an updated Realtek driver the Dolby wouldn't start and the sound without it was crap.

    Fyi my Realtek driver version is 6.0.1.7525
     
  3. tugapt

    tugapt Notebook Enthusiast

    Reputations:
    0
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    15
    guys i need some help

    i can buy this for 80 euros

    samsung pm871 512ssd

    it will be good for replace the 1tb sshd lenovo y50-70 ? its compatible?

    [​IMG]
     
  4. m1ko

    m1ko Notebook Consultant

    Reputations:
    0
    Messages:
    110
    Likes Received:
    19
    Trophy Points:
    31
    I recently update my drivers to the latest (376 or whatever) only to find out that it overheats my laptop, to the point it was a 90° idle. When i tried playing battlefield bad company 2, the FPS would go from 60 to 23 every few seconds. When i disconnected the power, the laptop crashed with a BSOD.

    So i cleaned the fans, using can of compressed air, and rebooted. No difference.

    I then decided to revert to the old driver (372.70) and the laptop still did that 23-60 stuff. I remember reading thatnvidia purposefully downgrades the performance of old components in order to make people buy their new stuff. So i thought, what if i go even more back in time?

    And so i lowered to (368.69) and then to a driver that was released the same year the laptop was released (355.98), and the 23-60 stuff happens very rarely.

    Problem is it never seems to stay still at 60FPS, even if its a fairly old game, and ever if all the settings are set to low.

    Tl:dr: What i am asking is: what driver should i use to optimize performance? i just want to be able to play games with a stable framerate that wont go 23-60.
     
  5. Quicklite

    Quicklite Notebook Deity

    Reputations:
    156
    Messages:
    1,573
    Likes Received:
    16
    Trophy Points:
    56
    Hi guys,
    Sorry to bump up an old thread. Using an old Y50-70 with 860M & Core i7 with Windows 10 Fall update. Have repasted it and cleaned it up a bit today, before clean installing Win 10.

    However, the trackpad seems awkward. Have to press very hard click to get the left/right clicks to register (where as the lightest tap on the trackpad registers okay, I'm thinking there is some issues / not sure if it's hardware or software). Have tried to clean around the trackpad module, and tighten the screw. Didn't really help. It was a clean Win 10 install - Windows found the mouse driver (needed hard press). I tried the DRP.su tool afterwards, to grab the latest version no luck neither, same low responsiveness to clicks.

    If I replace it with this "new" trackpad parts - do you think it will be better? (just trying to get an idea if it might help - because it's quite a long parts shipping time from China)
    https://www.ebay.co.uk/itm/Original...221321?hash=item25df10f889:g:JnsAAOSwX7pZqis7
     
  6. Structamention

    Structamention Notebook Geek

    Reputations:
    0
    Messages:
    82
    Likes Received:
    15
    Trophy Points:
    16
    I have a Lenovo Y50 from 2014. In most respects it's still quite fast and whatnot for browsing and stuff.

    However, recently it randomly "hangs." For example, I will ctrl + t for a new Chrome tab and it just freezes for a bit. Or once I do flag + L to lock and it hangs for a bit first.

    This problem is not consistent. So after it hangs on a new tab, subsequent new tabs are back to being instantaneous. The flag + L hang also does not usually happen. It feels random. Again, as I said the thing is usually still quite fast. Boots in 8 seconds, etc. It's just that a few weeks ago this new issue popped up.

    Any ideas on how to figure out what could cause the hanging?

    Thanks.

    Misc. specs and info:
    • Windows 8.1 OS.
    • 8 GB RAM.
    • GTX 860m, 2GB VRAM.
    • i7-4700HG CPU, 2.4 ghz turbo to 3.4
    • BIOS is from 2014, V1.09.
    • Replaced the stock hybrid drive with a crucial SSD years ago.
     
  7. AdnanS

    AdnanS Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Hi guys,

    After reading many post in the forums here on notebookreview, I was finally able to repaste my Lenovo Y50 with Grizzly Conductonaut (took safety measure - nail polish and electric tape), also undervolted the CPU using Throttlestop by -100mv.

    Now my laptop does not heat up, I see under 78 degree celsius after playing for hours on end.

    My question is can i unlock the bios to undervolt the GPU too or overclock the CPU, I realize that may require something like a mod (premamod perhaps).

    @Prema or @Phoenix would you be able to help here? I tried searching the forums and internet but find mixed or confusing information


    Misc. specs and info:
    • Lenovo y50 70 (non touch)
    • Windows 10 OS.
    • 8 GB RAM.
    • GTX 860m, 2GB VRAM
    • i7-4700HG CPU, 2.4 ghz turbo to 3.4
     
Loading...

Share This Page