Latitude, or even Dell-specific Keyboard driver?

Discussion in 'Dell Latitude, Vostro, and Precision' started by cognus, Nov 2, 2019.

  1. cognus

    cognus Notebook Deity

    Reputations:
    186
    Messages:
    870
    Likes Received:
    16
    Trophy Points:
    31
    This is a Wake-via-USB issue. I am trying unsuccessfully to get Wakeup from sleep mode working properly, or conveniently, on a Dell Latitude 7470. Despite searching the dell support site by Service Tag for all the most current drivers, and running their little Driver-detector utility and getting everything up to date, does not work right. Every Windows 10 device I personally have, and all the ones I've worked on, could be made to awaken from sleep by keyboard, wireless or wired, as well as by built-in keyboard and/or trackpad if laptops. Nothing except for 'sleep button' I've tried yet works on this one. I installed a very recent [like 3 weeks old] BIOS update that was supposed to fix a few things but no help for this.

    The Keyboard shown in Device Manager is generic: MS provided PS/2 generic. I see nothing on the dell website that actually has a keyboard driver. The Alps touchpad package is titled "touchpad and keyboard", but examining everything extracted, it is nothing but alps touchpad. the Device Manager entry for Keyboard is generic, driver dated 6/21/2006. I have enabled the BIOS setting to allow the system to wake on usb.

    When looking at Properties of the touchpad and keyboard, there is no "Power" Tab at all. Nothing under properties for either that addresses power parameters. Disabling / Enabling selective suspend USB in the Power Options has no effect. The "sleep" button, oddly enough, works to put to sleep and wakeup from sleep even if I disable it [that is, elminate it as an option under Power Options.... don't use it]. That is the ONLY way to wake the system. Setting the Lid-Close to "sleep" works to put the system to sleep, but only sometimes works to awaken it.

    This windows 10 install is clean from MS-utiltity USB Media. I'm willing to do it again but it just doesn't seem like a Windows 10 issue. Maybe I'm wrong.

    appreciate any help you guys can provide.
    c
     
Loading...

Share This Page