L502X modded bioses download (GPU voltages and more!)

Discussion in 'Dell XPS and Studio XPS' started by capitankasar, Dec 30, 2011.

  1. capitankasar

    capitankasar Notebook Deity

    Reputations:
    231
    Messages:
    1,700
    Likes Received:
    117
    Trophy Points:
    81
    ty

    yep, they both use the same chip (GF108), but the board is different I think.

    the gt525m uses the board 1079df50
    and
    the gt540m uses the board 1079df40

    I were able to see it while hex editing the bioses, using nbitor, and on the driver identifiers at some sites.

    also, at least on the L502X, the gt540m comes with twice memory ammount than gt525m, so is there a chance the voltage regulator settings are different in hardware.
    I have suspects even hexediting the advanced vbios values of the card firmware, driver hacking would be required too, at least to report the correct voltage output since the voltage profiles seems to be different per each cards.

    also it seems a lot of headache just for an extra 0.02v (1v = 0.98v + 0.02v)

    if my gt525m (wich seems to dislike to be OCed a lot) and other ppl 525m cards run them at gt540m clocks easly even an the 0.85v undervolted voltage, overvolting to 0.98v should be enough in most cases
     
  2. Arj12

    Arj12 Notebook Enthusiast

    Reputations:
    0
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Ok, I have flashed the undervolted version for the GT525m (0.83-0.85 profile) and am wondering where I can check to see if the graphics card is using the right voltage?
     
  3. NeoMesal

    NeoMesal Notebook Consultant

    Reputations:
    59
    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    31
    Have flashed the undervolted GT 540M BIOS - Reports the 0.85v 3D and works fine for me :cool: (still needed to revert back to A06 to install)

    There is a noticeable drop in temperatures; on average about a 5-7C in Furmark, max of about 74/75C. - Remember this is without a repaste or cooling pad! Very cool if I say so myself (no pun intended). :D Still need to test stability & oc, if it works fine I might stay with this mod.

    Feel free to remove that red text that you despise :p

    Thanks again :) :)
     
  4. NeoMesal

    NeoMesal Notebook Consultant

    Reputations:
    59
    Messages:
    282
    Likes Received:
    1
    Trophy Points:
    31
    Download Nvidia Inspector from this link:

    nvidiaInspector.rar

    You can also use it to control overclocking if you want
     
  5. sevenofnine

    sevenofnine Notebook Guru

    Reputations:
    0
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    15
    Hey Matix,

    I hope to give the undervolted version a go later in the week too, thanks for dipping your toe in the water first! Did you find the temps dropped whilst non-gaming too, i.e. fan comes on less frequently?
     
  6. capitankasar

    capitankasar Notebook Deity

    Reputations:
    231
    Messages:
    1,700
    Likes Received:
    117
    Trophy Points:
    81
    thank you for your feedback, red text removed :)
    I need to check why it keep asking u to revert to A06 first, I flashed several A07 modded bioses again and again and didnt found any message asking version issues.

    are you using the batch file? or are you flashing it manually with winflash?
    I allways use the batch file to use the advanced flashing parameters and avoid clicking on the winflash interface buttons (save some time)

    thank you a lot for testing the 540m version :)
     
  7. jkbuha

    jkbuha Notebook Guru

    Reputations:
    35
    Messages:
    55
    Likes Received:
    4
    Trophy Points:
    16
    Hey kasar

    Did you manage to get a newer version of the vbios firmware to work on your machine?

    If not - I have another idea. Did you try to modify the subsystem id of the bios using NiBiTor? It's a slim chance but might just work.

    On a related note I'm going to be working on the BIOS hidden menus next. Hopefully we should be able to see some results very soon!

    Cheers
    jkbuha
     
  8. nomygod

    nomygod Notebook Geek

    Reputations:
    6
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    15
    Hidden menus yay! *chants* fan control! fan control!

    FYI I switched back to undervolted with OC to 540m and everything is still stable.
     
  9. capitankasar

    capitankasar Notebook Deity

    Reputations:
    231
    Messages:
    1,700
    Likes Received:
    117
    Trophy Points:
    81
    hey mate ;)

    nope, all my tries to flash the newer vbios working on l502X resulted in a failure, leaving the card unusable , the device apeared with problems on the device manager, thats why I didnt posted any modded bios with the newer firmware, I just got the current formware from the stock bios working with the modifications. :(

    and yep, I also tried to change the subsystem ID to the one the current l502x vbios have, and still no success.

    maybe If I get a chance to obtain a clean image of the newer firmware with no modifications by anyone ,I can try again to flash it again.

    in the other hand, working on menus, and splash image would be nice!, since the xps 15 R2 and the 15z are really similar laptops, I think we can keep working togheter, sharing and posting the usefull information and the sucessfull tests.

    glad to know :)
    what are your GPU clocks and voltage used? I asume you are using the 0.85v 3d profile version
     
  10. nomygod

    nomygod Notebook Geek

    Reputations:
    6
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    15
    GPU 672/1344/900
    2d 0.83
    3d 0.85
    I'll do a 10 minute furmark test on a tabletop to determine my heat. Note that with new paste, stock bios and stock gpu clocks, that temp was 75. Will post the new temp in an edit
    Edit: 75C again. Not sure what that says, but data's data
     
Loading...

Share This Page